Author Topic: Ingest Dialog does't open when card mounted in El Capitan  (Read 8935 times)

Offline RonD200

  • Member
  • **
  • Posts: 88
    • View Profile
    • Digital Images by Ron Skinner
Ingest Dialog does't open when card mounted in El Capitan
« on: October 11, 2015, 07:18:15 AM »
For some reason Photo Mechanic doesn't start and launch when a card is mounted in my card reader, this just started happening, I'm on a Macbook Pro running El Capitan and Photo Mechanic Version 5.0, build 16765 (2682973). I checked my Preferences and they are set to open the ingest dialog  when a card is mounted and I also clicked "Configure Image Capture to Launch PhotoMechanic....
My Gallery - Digital Images by Ron Skinner
My Blog - Ron's Blog
______________________________________

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20531
    • View Profile
    • Camera Bits, Inc.
Re: Ingest Dialog does't open when card mounted in El Capitan
« Reply #1 on: October 11, 2015, 09:52:46 AM »
Ron,

For some reason Photo Mechanic doesn't start and launch when a card is mounted in my card reader, this just started happening, I'm on a Macbook Pro running El Capitan and Photo Mechanic Version 5.0, build 16765 (2682973). I checked my Preferences and they are set to open the ingest dialog  when a card is mounted and I also clicked "Configure Image Capture to Launch PhotoMechanic....

If you open up Image Capture and look at its settings, is it set to launch Photo Mechanic?
If PM is already running and you insert a card, does Ingest start up?

-Kirk

Offline camerauk

  • Newcomer
  • *
  • Posts: 41
    • View Profile
Re: Ingest Dialog does't open when card mounted in El Capitan
« Reply #2 on: October 12, 2015, 08:03:47 AM »
Hi
I am having the same problem
If i mount a card when Photo Mechanic is running it brings up the ingest box
If Photo Mechanic is not running it won't start up and bring up the ingest window or launch Photo Mechanic like it did before

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20531
    • View Profile
    • Camera Bits, Inc.
Re: Ingest Dialog does't open when card mounted in El Capitan
« Reply #3 on: October 12, 2015, 09:02:57 AM »
I am having the same problem
If i mount a card when Photo Mechanic is running it brings up the ingest box
If Photo Mechanic is not running it won't start up and bring up the ingest window or launch Photo Mechanic like it did before

Can you please check your Image Capture settings and see if it is set to launch PM?

-Kirk

Offline RonD200

  • Member
  • **
  • Posts: 88
    • View Profile
    • Digital Images by Ron Skinner
Re: Ingest Dialog does't open when card mounted in El Capitan
« Reply #4 on: October 12, 2015, 02:11:13 PM »
Ok I seem to have fixed the problem, if PhotoMechanic was open when I inserted a card the Ingest dialog would open.  If PhotoMechanic was not open nothing would happen, even though I had my preferences set correctly in PhotoMechanic.  I went to Image Capture and it was set to open "No Application" when a card was inserted even though in PhotoMechanic I clicked on the Configure Image Capture to open PhotoMechanic.  I configured Image Capture manually to open PhotoMechanic and now it works as it should.  I don't think the  Configure button in PhotoMechanic is configuring Image Capture to open PhotoMechanic like it did in Yosemite.
My Gallery - Digital Images by Ron Skinner
My Blog - Ron's Blog
______________________________________

Offline camerauk

  • Newcomer
  • *
  • Posts: 41
    • View Profile
Re: Ingest Dialog does't open when card mounted in El Capitan
« Reply #5 on: October 13, 2015, 04:18:16 AM »
I have had a look in Image Capture settings and can not find Photo Mechanic in there
How would I go about setting this up ?

Andy

Offline MickO

  • Camera Bits Staff
  • Sr. Member
  • *****
  • Posts: 321
    • View Profile
    • Camera Bits
Re: Ingest Dialog does't open when card mounted in El Capitan
« Reply #6 on: October 13, 2015, 08:49:49 AM »
If I recall correctly, a memory card has to be plugged in for this process. With the memory card mounted, Open Image Capture.

1. Select the card in the upper left.
2. click the gadget in the lower left to open your options
3. Select  Other, and then Photo Mechanic

I hope this helps

Edit: In a previous version of this message I had suggested selecting No Application. I usually am in Image Capture telling it not to do anything when I plug my phone in, so that is my default solution. My apologies. :-)

-Mick



[attachment deleted by admin]
« Last Edit: October 13, 2015, 11:51:22 AM by MickO »
----------------------
Mick O
Camera Bits

Offline camerauk

  • Newcomer
  • *
  • Posts: 41
    • View Profile
Re: Ingest Dialog does't open when card mounted in El Capitan
« Reply #7 on: October 14, 2015, 01:42:47 PM »
If I recall correctly, a memory card has to be plugged in for this process. With the memory card mounted, Open Image Capture.

1. Select the card in the upper left.
2. click the gadget in the lower left to open your options
3. Select  Other, and then Photo Mechanic

I hope this helps

Edit: In a previous version of this message I had suggested selecting No Application. I usually am in Image Capture telling it not to do anything when I plug my phone in, so that is my default solution. My apologies. :-)

-Mick

Thank you I will give that a go later and update on the outcome :)

Offline nharnik

  • Full Member
  • ***
  • Posts: 112
    • View Profile
Re: Ingest Dialog does't open when card mounted in El Capitan
« Reply #8 on: October 14, 2015, 02:24:46 PM »
I was having the same problem of PM not bringing up the ingest dialog in El Capitan.

One can configure Image Capture to have PM open upon seeing a camera disk, but the Photos App would also always open it's import dialog box, and then I would need to uncheck a box to teach Photos to not open when "this camera, (or this disk)" is mounted.
I needed to do the same operation in Photos for disks from every camera, and also configure Image Capture for disks from every camera, and only then Photos would not launch and PM would launch.
However, if you format a disk in the camera, and I do that a lot, all is forgotten, and Photos opens again, Image Capture does not remember the settings and PM will not open the ingest dialog.

My unsophisticated solution to this problem was to delete the Photos App.
(El Capitan protects the Photos App and will not let it be deleted, so I booted into an external disk and in that way I was able to delete the App.)

And since then PM launches the ingest dialog upon insertion of a disk as expected, and my computer seems not to complain about the missing app.
I have no idea what happens under the hood, and what will happen down the road when El Capitan gets an update, and if the missing Photos App will cause problems, but for now I'm happy I don't have to fight El Capitan.

Offline camerauk

  • Newcomer
  • *
  • Posts: 41
    • View Profile
Re: Ingest Dialog does't open when card mounted in El Capitan
« Reply #9 on: October 16, 2015, 12:01:03 AM »
Configuring Capture has worked for me
I also format my disks in camera and I have not had a problem since with Photo Mechanic opening and ingesting from the card.
I have Photos installed and that works fine and does not open when mounting a card from my D3

Offline schlotz

  • Member
  • **
  • Posts: 54
    • View Profile
Re: Ingest Dialog does't open when card mounted in El Capitan
« Reply #10 on: October 24, 2015, 04:05:14 AM »
I've done some extensive testing with multiple cards, readers and different usb slots and can confirm that once a card is reformated in the camera all of the settings in Image Capture are NOT RETAINED. Plugging a reformated card back in causes Photos to come up and not Photo Mechanic. Apple has really caused a serious PITA with El Capitan.

Offline soren steffen

  • Full Member
  • ***
  • Posts: 114
    • View Profile
Re: Ingest Dialog does't open when card mounted in El Capitan
« Reply #11 on: October 26, 2015, 06:06:05 AM »
Just curious, what cameras are you using?
I have set Image capture for my Nikon D750 and D3s and they have no problems with Photos after formatting in cameras.

-Søren

Offline schlotz

  • Member
  • **
  • Posts: 54
    • View Profile
Re: Ingest Dialog does't open when card mounted in El Capitan
« Reply #12 on: October 26, 2015, 06:09:34 AM »
Canon 1DX's and a 5D3

Offline Frantisek Vlcek

  • Sr. Member
  • ****
  • Posts: 449
    • View Profile
Re: Ingest Dialog does't open when card mounted in El Capitan
« Reply #13 on: December 11, 2015, 11:54:58 AM »
***a note - this is not Photomechanic's problem. This seems to be Apple's problem***

Any update on this issue? Photos.app opens every time I insert a (previously formatted in camera) card, no matter what settings I selected in Image Capture or Photos itself. OS X 10.11.2

This seems just like another Cupertino f**k up. This is not just annoying, this is costing me very valuable time when editing photos under deadline!

I even considered deleting the Photos.app altogether, although I do use it for the iCloud photos from my iPhone.

Everybody having this issue, please at least give them your feeback https://www.apple.com/feedback/photos.html.

For the record, I am using Canon cameras.

In the meantime, I am seriously considering downgrading back to Mountain Lion, the last version of OS X that just worked...

I even tried combing through various plist files if there is an option for that, to no avail.

Offline robok

  • Newcomer
  • *
  • Posts: 24
    • View Profile
Re: Ingest Dialog does't open when card mounted in El Capitan
« Reply #14 on: December 12, 2015, 08:03:59 AM »
Feedback left for Apple.

I tried to delete Photos also.

Very frustrating. Not much more to add to the above.