Author Topic: Ingest “keep separate source folders" not working  (Read 4813 times)

Offline Jen Mack

  • Newcomer
  • *
  • Posts: 32
    • View Profile
Ingest “keep separate source folders" not working
« on: February 03, 2016, 10:11:49 PM »
Hi,

I just got a new backup camera, and was playing with ingest options. I found that the “keep separate source folder names only” and “preserve all source directories” *both* import the DCIM folder and the folders below it.

Camera is a Canon SL1, and I formatted a card, and shot one picture, then created a new folder and shot once, then the same for a third folder.

on import using “keep separate” I got
Desktop/DCIM
-/100CANON
-/101CANON
-/102CANON

Which is the same as preserve.

I also formatted the card and shot a few frames so there was only 100CANON folder, then imported, and the DCIM folder came along for the ride. When the manual says one folder will be treated the same as “ignore” and neither the DCIM or 100CANON will show up.

PM v.5.16960

So it seems the “keep separate” option is misbehaving. Is this a known thing?

Thanks!

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24172
    • View Profile
    • Camera Bits, Inc.
Re: Ingest “keep separate source folders" not working
« Reply #1 on: February 04, 2016, 10:17:06 AM »
Jenny,

Does the DCIM folder contain any files at all?

If you are using a Mac and have browsed the card with the Finder, it will put files on your card that will trip up this feature in Ingest.
Could you post the full directory structure here?  I need to know what OS you're using and then I'll give you instructions on how to do this.

-Kirk

P.S. The manual is misleading in that it mentions the DCIM folder at all.  The feature does not care about the naming structure of the folders.  It simply removes empty parent folders and preserves non-empty folders.

Offline Jen Mack

  • Newcomer
  • *
  • Posts: 32
    • View Profile
Re: Ingest “keep separate source folders" not working
« Reply #2 on: February 04, 2016, 10:18:30 AM »
Mac 10.11.3

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24172
    • View Profile
    • Camera Bits, Inc.
Re: Ingest “keep separate source folders" not working
« Reply #3 on: February 04, 2016, 10:40:45 AM »
Mac 10.11.3

OK, so here are the instructions for Mac OS X:

First open up a Terminal window (launch the Terminal application which can be found in Applications/Utilities/)

Then enter the following:

find (add a space after the word "find")

Then switch to the Finder and locate your camera card.  Drag and drop the camera card volume onto the terminal window.  You should now see something like this:

find /Volumes/EOS_DIGITAL

Then press enter/return.  Copy and paste the output in your reply to this message.

Thanks,

-Kirk

Offline Jen Mack

  • Newcomer
  • *
  • Posts: 32
    • View Profile
Re: Ingest “keep separate source folders" not working
« Reply #4 on: February 04, 2016, 03:20:21 PM »
Ok, this is after a format and then creating folders after every two shots:

/Volumes/EOS_DIGITAL
/Volumes/EOS_DIGITAL/DCIM
/Volumes/EOS_DIGITAL/DCIM/100CANON
/Volumes/EOS_DIGITAL/DCIM/100CANON/IMG_0001.JPG
/Volumes/EOS_DIGITAL/DCIM/100CANON/IMG_0002.JPG
/Volumes/EOS_DIGITAL/DCIM/EOSMISC
/Volumes/EOS_DIGITAL/DCIM/EOSMISC/M2100.CTG
/Volumes/EOS_DIGITAL/DCIM/EOSMISC/M2101.CTG
/Volumes/EOS_DIGITAL/DCIM/EOSMISC/M2102.CTG
/Volumes/EOS_DIGITAL/DCIM/101CANON
/Volumes/EOS_DIGITAL/DCIM/101CANON/IMG_0001.JPG
/Volumes/EOS_DIGITAL/DCIM/101CANON/IMG_0002.JPG
/Volumes/EOS_DIGITAL/DCIM/102CANON
/Volumes/EOS_DIGITAL/DCIM/102CANON/IMG_0001.JPG
/Volumes/EOS_DIGITAL/DCIM/102CANON/IMG_0002.JPG
/Volumes/EOS_DIGITAL/MISC
/Volumes/EOS_DIGITAL/._.Trashes
/Volumes/EOS_DIGITAL/.Trashes
/Volumes/EOS_DIGITAL/.fseventsd
/Volumes/EOS_DIGITAL/.fseventsd/fseventsd-uuid

My ingest settings for this test and results in the finder are attached.

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24172
    • View Profile
    • Camera Bits, Inc.
Re: Ingest “keep separate source folders" not working
« Reply #5 on: February 04, 2016, 04:13:26 PM »
Jenny,

Thank you for the detailed results.

What causes your camera to create the MISC folder?  Is it present on a newly formatted card?

-Kirk

Offline Jen Mack

  • Newcomer
  • *
  • Posts: 32
    • View Profile
Re: Ingest “keep separate source folders" not working
« Reply #6 on: February 04, 2016, 04:29:12 PM »
Good catch.

So I used the terminal to delete the MISC folder (so no .DS_Store files would get added). Then re-ingested with the same settings as above and it worked as expected. 100-103CANON landed in the dated folder.

To double check I reformatted the card, and shot 1 picture. The MISC folder was there. It looks like the camera is creating it.

I found this on a quick search: http://photo.stackexchange.com/questions/12926/what-is-the-function-of-the-misc-folder-on-my-memory-card

So it’s a Canon thing. :(  I guess PM just needs to look at the DCIM folder and ignore anything else at the card’s root level.

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24172
    • View Profile
    • Camera Bits, Inc.
Re: Ingest “keep separate source folders" not working
« Reply #7 on: February 04, 2016, 07:43:17 PM »
Jenny,

Good catch.

So I used the terminal to delete the MISC folder (so no .DS_Store files would get added). Then re-ingested with the same settings as above and it worked as expected. 100-103CANON landed in the dated folder.

To double check I reformatted the card, and shot 1 picture. The MISC folder was there. It looks like the camera is creating it.

I found this on a quick search: http://photo.stackexchange.com/questions/12926/what-is-the-function-of-the-misc-folder-on-my-memory-card

So it’s a Canon thing. :(  I guess PM just needs to look at the DCIM folder and ignore anything else at the card’s root level.

Yes, PM would have to accommodate this quirk.  Odd that the camera creates it right away instead of when it is needed.

-Kirk

Offline Jen Mack

  • Newcomer
  • *
  • Posts: 32
    • View Profile
Re: Ingest “keep separate source folders" not working
« Reply #8 on: February 04, 2016, 08:40:51 PM »
Ok, I’ll just delete that MISC folder before ingest from now on. Is this something that could be addressed in a dot release? Because it seems most newer Canons act this way.

Using the folders is great way to keep individual participants separated. A note on the program of “10x” by a name and I can keep track of who’s who. My old Fuji didn’t have folder selection, so I never played with this.

Offline Jen Mack

  • Newcomer
  • *
  • Posts: 32
    • View Profile
Re: Ingest “keep separate source folders" not working
« Reply #9 on: April 05, 2016, 08:01:57 PM »
Just upgraded to a 7D Mark II, and it also creates the MISC folder at the root level of both the SD and CF card.