Author Topic: chinese or other characters appear when starting to type  (Read 4458 times)

Offline kbw

  • Newcomer
  • *
  • Posts: 15
    • View Profile
chinese or other characters appear when starting to type
« on: June 12, 2016, 08:51:18 PM »
I'm going through multiple photos in preview mode, with the information window open. :(

As each photo cycles through, I'm adding a description and then ctrl-> to move along to the next image.

My problem is this:

Almost everytime, when I begin to type, the first character gets interpreted as a chinese character. I then need to backspace and start over entering the description. It usually goes to all normal characters on the next try.

How can I prevent this from happening?

Thanks!
Ken
« Last Edit: June 12, 2016, 10:13:11 PM by kbw »

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2478
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: chinese or other characters appear when starting to type
« Reply #1 on: June 12, 2016, 10:59:41 PM »
Weird, what OS and version of PM are you using?
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline kbw

  • Newcomer
  • *
  • Posts: 15
    • View Profile
Re: chinese or other characters appear when starting to type
« Reply #2 on: June 12, 2016, 11:52:00 PM »
Windows 8 and the latest version of PM. This only happens with PM, not with any other program.
It's not always Chinese characters..They are various alternative ascii codes. Sometimes a little square box, various alt type symbols... But only the first character that I type...then it goes back to a normal alphabet

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2478
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: chinese or other characters appear when starting to type
« Reply #3 on: June 13, 2016, 02:32:54 AM »
To my knowledge PM only uses the standard keyboard input routines, so I do suspect there is something on your particular system (especially since no one else has reported your issue so far).

Have you already re-installed PM? If you have and it did not solve the issue, do you perhaps have some keyboard enhancing software installed?
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: chinese or other characters appear when starting to type
« Reply #4 on: June 13, 2016, 08:02:50 AM »
Windows 8 and the latest version of PM. This only happens with PM, not with any other program.
It's not always Chinese characters..They are various alternative ascii codes. Sometimes a little square box, various alt type symbols... But only the first character that I type...then it goes back to a normal alphabet

Are you using an Input Method?

I don't think I've ever heard of this before.

-Kirk

Offline kbw

  • Newcomer
  • *
  • Posts: 15
    • View Profile
Re: chinese or other characters appear when starting to type
« Reply #5 on: June 13, 2016, 08:11:02 AM »
I may have selected a different font or something like that when I was first installing.

I'll check that later today.

In the meantime, can someone provide the font defaults for the program?

I've noticed that there's a huge list of possible fonts. Are there any other input methods are similar options that I may have inadvertently altered?

It's good to know that no one else has this problem, which means that a clean install will probably solve, although I'm hesitant to lose all of my settings so far.

thanks all for your quick replies!

Ken

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: chinese or other characters appear when starting to type
« Reply #6 on: June 13, 2016, 09:58:19 AM »
Ken,

I may have selected a different font or something like that when I was first installing.

I'll check that later today.

In the meantime, can someone provide the font defaults for the program?

Photo Mechanic has no special font requirement.  It only uses default system-provided fonts.

I've noticed that there's a huge list of possible fonts. Are there any other input methods are similar options that I may have inadvertently altered?

Fonts are not Input Methods.  I suspect you're not using an Input Method on your system.  They're very specific UI tools that allow a person with a Roman keyboard enter text phonetically in different languages like Japanese, Chinese variants, Korean, etc.

It's good to know that no one else has this problem, which means that a clean install will probably solve, although I'm hesitant to lose all of my settings so far.

Reinstalling Photo Mechanic will not lose your settings.  They're not part of the installer/uninstaller so they will be maintained through a reinstall.

-Kirk

Offline kbw

  • Newcomer
  • *
  • Posts: 15
    • View Profile
Re: chinese or other characters appear when starting to type
« Reply #7 on: June 13, 2016, 06:47:00 PM »
Here's an example of the issue, when I typed, "Mage"

I'll check the other settings soon

Offline kbw

  • Newcomer
  • *
  • Posts: 15
    • View Profile
Re: chinese or other characters appear when starting to type
« Reply #8 on: June 13, 2016, 09:56:24 PM »
Can anyone out there confirm that my "IPTC encoding" is set correctly?

This is from the "Information" page, which is the page where I'm having the problem with strange characters showing up.

I want to check this before reinstalling, because if it's a setting issues... and settings are retained across installs... then it seems to make sense to check with folks first on this particular setting.

Many thanks.
Ken

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2478
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: chinese or other characters appear when starting to type
« Reply #9 on: June 13, 2016, 10:29:20 PM »
As you're on Windows, one of the Latin encodings is probably more appropriate, but I'm quite sure this isn't the problem. Looking at your screenshot, what I do notice is that the font used for the caption is incorrect; it is way too big. Did you perhaps paste something into the box instead of typing? If so, it may be the source of your problems…
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline kbw

  • Newcomer
  • *
  • Posts: 15
    • View Profile
Re: chinese or other characters appear when starting to type
« Reply #10 on: June 13, 2016, 10:41:22 PM »
I just hit control,+ to make things bigger and easier to read.

What's a typical selection for that drop down? I'd love to give that a quick try before reinstalling.

Ken

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2478
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: chinese or other characters appear when starting to type
« Reply #11 on: June 13, 2016, 11:33:26 PM »
Hi Ken,

As I said, one of the Latin ones.

What happens if you don't press CTRL+ do the strange characters still show up then?
Furthermore, what happens if you select all characters (including the weird ones) and paste them in e.g. a word document.
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: chinese or other characters appear when starting to type
« Reply #12 on: June 14, 2016, 09:52:16 AM »
Ken,

Can anyone out there confirm that my "IPTC encoding" is set correctly?

This is from the "Information" page, which is the page where I'm having the problem with strange characters showing up.

I want to check this before reinstalling, because if it's a setting issues... and settings are retained across installs... then it seems to make sense to check with folks first on this particular setting.

The IPTC encoding is used when writing legacy IPTC data, it has no bearing on what happens to the text when you type it, only how it is encoded when writing legacy IPTC data.  XMP data is always Unicode.

You can adjust the size of the font in the Accessibility tab in the Preferences dialog.  I have no idea what pressing Ctrl-+ will do in the IPTC dialogs.  Perhaps that is the reason for your issue.

-Kirk
 

Offline kbw

  • Newcomer
  • *
  • Posts: 15
    • View Profile
Re: chinese or other characters appear when starting to type
« Reply #13 on: June 15, 2016, 11:32:38 AM »
Hi Guys,

There's some confusion here. The strange characters show up when I start typing in the Description box. It has nothing to do with font size... I just adjusted that after the fact so it was easier to see in this forum.

When a strange character shows up, if I backspace and type again, problem solved. It's just that it happens almost everytime... and I'm going through a lot of photos.

Could it be that I'm inadvertently typing a strange character sequence? I'm not sure, but I've only seen it with PM and not with any other of the many programs that I use every day.

I have another session coming up soon, and I'll try to figure out more.

Thanks for your replies!

Offline timeboxphoto

  • Newcomer
  • *
  • Posts: 11
    • View Profile
Re: chinese or other characters appear when starting to type
« Reply #14 on: September 17, 2016, 02:11:10 PM »
I had the same problem for a long time and because it got so bad I just stopped using any feature of PM other than ingesting and star ratings (I was working on thousands of images a week doing code replacement).

EDIT: It's been so long that I forgot how to perform CR... but didn't do enough to see the issue crop up.
« Last Edit: September 17, 2016, 02:19:48 PM by timeboxphoto »