Author Topic: Photo Mechanic/NX issue  (Read 3427 times)

Offline kamcma

  • Newcomer
  • *
  • Posts: 1
    • View Profile
Photo Mechanic/NX issue
« on: February 24, 2007, 06:14:44 PM »
Whenever I edit a NEF in NX and close it to go back to Photo Mechanic, the preview updates correctly and that all great, but it also loses whatever I've color coded the photo as and its status as tagged or not. This happens whenever I edit a photo. Is this a glitch? I hope it's just some setting. It's hugely annoying.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21337
    • View Profile
    • Camera Bits, Inc.
Re: Photo Mechanic/NX issue
« Reply #1 on: February 25, 2007, 02:58:15 PM »
Whenever I edit a NEF in NX and close it to go back to Photo Mechanic, the preview updates correctly and that all great, but it also loses whatever I've color coded the photo as and its status as tagged or not. This happens whenever I edit a photo. Is this a glitch? I hope it's just some setting. It's hugely annoying.

What OS are you running?
What version of Capture NX are you running?
What version of Photo Mechanic are you running?

-Kirk

Offline greenthi

  • Newcomer
  • *
  • Posts: 2
    • View Profile
Re: Photo Mechanic/NX issue
« Reply #2 on: February 26, 2007, 11:27:58 AM »
Howdy, I have the same thing happen to me
Running Mac OS X  10.4.8, Capture NX 1.1, and PM 4433
« Last Edit: February 26, 2007, 11:59:50 AM by greenthi »

Offline dennis

  • President
  • Camera Bits Staff
  • Sr. Member
  • *****
  • Posts: 412
    • View Profile
    • Camera Bits, Inc.
Re: Photo Mechanic/NX issue
« Reply #3 on: February 26, 2007, 01:54:40 PM »
Whenever I edit a NEF in NX and close it to go back to Photo Mechanic, the preview updates correctly and that all great, but it also loses whatever I've color coded the photo as and its status as tagged or not. This happens whenever I edit a photo. Is this a glitch? I hope it's just some setting. It's hugely annoying.

In order for PM's tag and color class to "stick" with a NEF file you need to set your preferences to: 1) in the IPTC/XMP tab, check the "Add embedded IPTC" for TIFF-based RAW photos; 2) in the Files tab set "Save/load tag and color class in IPTC/XMP" to be either "For RAW photos only" or "For all photos".  Otherwise the tag and color class won't be maintained when Capture NX writes out a new NEF.  Normally PM only puts this info at the end-of-file in a proprietary fashion which would get lost when another program like Capture NX saves a new file (whether it be NEF, JPEG, or TIFF).  By putting this info in the IPTC (and assuming some editing program like Capture NX or Photoshop maintain all IPTC data which they do), the tag and color class will be maintained in the saved file.

One reason to not do this is that it slows down tagging etc, especially if you batch tag a bunch of JPEGs.  But if you want this info to stick, especially for a saved-as JPEG for example, you need to put this info in the IPTC and/or XMP.  Since Capture NX only handles embedded IPTC, this is where you need to save this info.

The behavior has changed a bit in 4.5.  The Files tab preference will now say "Add tag, color class, and star rating to IPTC/XMP" and the options will be "Only when updating IPTC/XMP", "Always for RAW files", and "Always for all photos".

--dennis

Offline greenthi

  • Newcomer
  • *
  • Posts: 2
    • View Profile
Re: Photo Mechanic/NX issue
« Reply #4 on: February 27, 2007, 12:35:40 PM »
Thanks for the quick reply. It's keeping all the colors & tags made after the preference change but not the ones done before. A little suffering but nothing major.