Author Topic: Ratings for Fuji files in Photo Mechanic missing in Lightroom after import.  (Read 4564 times)

Offline googlephonics

  • Newcomer
  • *
  • Posts: 1
    • View Profile
Hello! I really hope somebody can help me out. I normally shoot Canon and my workflow is: Ingest/Rate in Photo Mechanic, then import to Lightroom and do editing there. Never had a problem with this setup.
 
I recently bought a Fuji XT-1 and I ingest/rate the RAF files in PM but the ratings are not in Lightroom after I import to LR. I tried the "Read metadata from file" option and that didn't bring any changes whatsoever. Canon's CR2 files behave normally and ratings are all there.
 
I noticed that when I rate in PM, a xmp file is created with my ratings etc. Then when I import to LR the following happens:
 
For Canon files: the existing xmp file gets rewritten by LR, adding stuff about camera, lens, etc. Ratings that were there are left intact.
 
For Fuji files: the existing xmp file is left untouched. Instead, LR creates a different xmp file with info about camera, lens, etc but no "rating" value.
 
I have no idea where the problem lays (LR, PM or some setting in the camera itself). I've tried googling but no luck. If this turns out to be obviously not a PM thing I apologize in advance.
 
Any help would be much appreciated!
 
Thanks in advance,
 
Beto.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24277
    • View Profile
    • Camera Bits, Inc.
Beto,

Hello! I really hope somebody can help me out. I normally shoot Canon and my workflow is: Ingest/Rate in Photo Mechanic, then import to Lightroom and do editing there. Never had a problem with this setup.
 
I recently bought a Fuji XT-1 and I ingest/rate the RAF files in PM but the ratings are not in Lightroom after I import to LR. I tried the "Read metadata from file" option and that didn't bring any changes whatsoever. Canon's CR2 files behave normally and ratings are all there.
 
I noticed that when I rate in PM, a xmp file is created with my ratings etc. Then when I import to LR the following happens:
 
For Canon files: the existing xmp file gets rewritten by LR, adding stuff about camera, lens, etc. Ratings that were there are left intact.
 
For Fuji files: the existing xmp file is left untouched. Instead, LR creates a different xmp file with info about camera, lens, etc but no "rating" value.

Where is LR creating this "different xmp file"?  Are the filenames exactly the same or do they differ in case (one has an uppercase XMP extension and one has a lowercase xmp extension)?

-Kirk

Offline Bob Russell

  • Camera Bits Staff
  • Full Member
  • *****
  • Posts: 160
    • View Profile
    • Camera Bits, Inc.
There are two other things to check if you are still having a problem with missing labels or stars. When Importing into Lightroom, make sure to use the Add option so Photo Mechanic and Lightroom will be working with the same set of files.  The Metadata presets can also erase labels and ratings from Imported images. Check the Metadata Presets from the Metadata menu to make sure the Rating and Label field apply boxes are not checked. See my attached jpeg for details.

--Bob