Author Topic: Unable to set ratings on external drive  (Read 1498 times)

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 17402
    • View Profile
    • Camera Bits, Inc.
Re: Unable to set ratings on external drive
« Reply #15 on: February 09, 2017, 07:22:50 am »
Jarle,

This has been driving me crazy, but I have finally found the problem. In my opinion, it's a bug:

I usually shoot NEF+JPEG. Setting ratings works fine. Once in a while, I delete the superfluous JPEG files (only raw files and edited JPEGs are permanently archived). Having deleted the JPEGs, ratings do no longer work.

PM can rate RAW files by either writing to the RAW file itself or by creating/writing to an XMP sidecar file.  It should be able to handle your case just fine.  If PM can't read the files but can write to them then PM won't be able to see the ratings that it just wrote.  Please explain in detail how to reproduce this problem.

Thanks,

-Kirk

Offline jarle

  • Newcomer
  • *
  • Posts: 26
    • View Profile
Re: Unable to set ratings on external drive
« Reply #16 on: February 09, 2017, 07:43:46 am »
Please explain in detail how to reproduce this problem.
Easy:

1. I just took two photos NEF+JPEG. Copied both photos to a new folder (total number of files in folder: 4). Added ratings to both photos (total number of files: 6). Ratings are displayed correctly by PM.

2. I then delete the two JPEGs. I now have 4 files in my folder: two NEFs and two XMPs. Ratings are no longer displayed. Whatever I do, the ratings are gone (i.e. not visible within PM) and cannot be changed. I then tried to delete the two XMP files, but I'm still unable to add ratings. Strange. I've attached a screenshot of my XMP preferences.

Jarle


Offline jarle

  • Newcomer
  • *
  • Posts: 26
    • View Profile
Re: Unable to set ratings on external drive
« Reply #17 on: February 09, 2017, 07:54:57 am »
Under XMP preferences, I changed to Read XMP sidecar file first (apparently the default setting). Everything seems to work fine now. Very strange, since I cannot remember having ever changed this setting. Perhaps the default setting was changed (by you guys) at some point?

Jarle

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 17402
    • View Profile
    • Camera Bits, Inc.
Re: Unable to set ratings on external drive
« Reply #18 on: February 09, 2017, 09:05:05 am »
Jarle,

Under XMP preferences, I changed to Read XMP sidecar file first (apparently the default setting). Everything seems to work fine now. Very strange, since I cannot remember having ever changed this setting. Perhaps the default setting was changed (by you guys) at some point?

We haven't changed the defaults recently.  I expect that your RAW files have an IPTC record in them that has very little data (certainly no rating) and because your settings preferred reading embedded IPTC over XMP sidecars, PM read the embedded IPTC and ignored your XMP sidecar file.

If you want to send me a sample file that previously exhibited the problem, I'll look into it further.

-Kirk

Offline jarle

  • Newcomer
  • *
  • Posts: 26
    • View Profile
Re: Unable to set ratings on external drive
« Reply #19 on: February 09, 2017, 11:07:54 am »
Thanks Kirk. Sent a sample file via wetransfer.

Just to clarify (for future readers of this thread), the problem I've seen is NOT related to my external drive, as I first thought. Also, if you're using the default IPTC/XMP settings, everything works fine.

Kirk: Seems like my problem is related to these two settings:
"Allow RAW files to be modified" was unchecked AND
"Read embedded IPTC" was set to first, as seen in screenshot above.
..perhaps in combination with my NEF files (Nikon D4 - with in-camera embedded copyright information - not sure if this is IPTC or EXIF data)

Jarle

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 17402
    • View Profile
    • Camera Bits, Inc.
Re: Unable to set ratings on external drive
« Reply #20 on: February 09, 2017, 11:16:15 am »
Jarle,

Thanks Kirk. Sent a sample file via wetransfer.

Just to clarify (for future readers of this thread), the problem I've seen is NOT related to my external drive, as I first thought. Also, if you're using the default IPTC/XMP settings, everything works fine.

Kirk: Seems like my problem is related to these two settings:
"Allow RAW files to be modified" was unchecked AND
"Read embedded IPTC" was set to first, as seen in screenshot above.
..perhaps in combination with my NEF files (Nikon D4 - with in-camera embedded copyright information - not sure if this is IPTC or EXIF data)

Thanks for the sample file.  I couldn't find any IPTC data, but the NEF does have embedded XMP metadata produced by your camera.  Your previous settings in PM had PM set to read embedded IPTC first, embedded XMP second, and sidecar XMP last. 

The NEF contained this metadata which doesn't have a rating:

<?xpacket begin="" id="W5M0MpCehiHzreSzNTczkc9d"?>
  <x:xmpmeta xmlns:x="adobe:ns:meta/">
    <rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
    <rdf:Description rdf:about="" xmlns:xmp="http://ns.adobe.com/xap/1.0/">
    <xmp:CreatorTool>NIKON D4 Ver.1.10 </xmp:CreatorTool>
    <xmp:CreateDate>2017-02-09T07:21:35.70</xmp:CreateDate>
    </rdf:Description></rdf:RDF>
  </x:xmpmeta>
<?xpacket end="w"?>

PM read this data as directed and ignored the sidecar XMP.

-Kirk