Author Topic: Error message "SD Cards not ejecting because in use"  (Read 334 times)

Offline fotobarone

  • Newcomer
  • *
  • Posts: 33
    • View Profile
Error message "SD Cards not ejecting because in use"
« on: May 13, 2017, 06:57:35 am »
Hi Guys, i'm facing this issue sometimes when ingesting my SD cards, which are all the same Lexar 1000X 32GB SDHC.
It's very annoying because i usually ingest 2 cards at the same time and when this message is shown up, related to one SD only, the whole ingest process freezes, until i press the ok button and the other SD ingest process can continue.
This happens regardless of the card reader and USB port getting used, and the same SD which today has just shown this issue, maybe tomorrow will work just fine...
Using Photo Mechanic Version 5.0, build 18359 (5034d39) on a MacBook Pro (Retina, Mid 2012)
Camera Fujifilm XT-2

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 17653
    • View Profile
    • Camera Bits, Inc.
Re: Error message "SD Cards not ejecting because in use"
« Reply #1 on: May 13, 2017, 10:47:11 am »
I found this handy guide for finding out what application is denying an eject operation:

Quote
If it happens again, open the Terminal utility and run the following command:
 
diskutil list
 
In the output of this command, make note of the disk identifier for your external drive (something like disk1 or disk2), and then use it in the following command:
 
sudo lsof /dev/disk1
 
This will output all the files that are currently open on that drive, and show you what program has them open. If you cannot figure out what the output means, copy and paste the output to a reply here.

Offline fotobarone

  • Newcomer
  • *
  • Posts: 33
    • View Profile
Re: Error message "SD Cards not ejecting because in use"
« Reply #2 on: May 15, 2017, 02:51:05 am »
Thanks, Kirk: i'll give it a try as soon as it happens again.
Cheers..!