Author Topic: 4.5 Beta Bugs  (Read 32811 times)

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20513
    • View Profile
    • Camera Bits, Inc.
Re: 4.5 Beta Bugs
« Reply #30 on: April 01, 2007, 07:42:11 PM »
Using: Windows Xp, (SP 2, 2gb memory, 2 hard disks, two monitors).

The beta edition is file PMSetup4.5b0331.exe.  The "about" information is version 4.5.

If I drag and drop a thumbnail or a file name onto the PM beta icon, the image dropped is not positioned nor selected in the contact sheet.

Did even 4.4.3.3 do that behavior?

-Kirk

Offline Paul Smith

  • Member
  • **
  • Posts: 83
    • View Profile
Re: 4.5 Beta Bugs
« Reply #31 on: April 01, 2007, 07:48:11 PM »
Just downloaded the latest (third) beta. The first thing I noticed is that, when selecting multiple non-contiguous images using the command key, there seems to be a lag from when I click on the image and when the highlight appears around the image. This was not the case with PM 4.4.

I'm using Mac OS 10.4.9 on a 2GHz Dual G5 with 4.5 MB RAM.

Cheers,

Paul

Offline Kevin M. Cox

  • Sr. Member
  • ****
  • Posts: 410
  • PM 5 Build 19749 | macOS 10.13.6 (17G7024)
    • View Profile
    • Kevin M. Cox | Photojournalist
Re: 4.5 Beta Bugs
« Reply #32 on: April 01, 2007, 08:12:00 PM »
Paul, this sounds like the same issue that is being worked through in this thread:
http://forums.camerabits.com/index.php?topic=1181.0

Do you have the Favorites/Navigator pane completely collapsed on your Contact Sheet windows?  If so, try expanding them out a bit with the splitter.  I think the performance should be back.  Let me know if this helps.

-Kirk

Try Kirk's above suggestion re: the Favorites/Navigator pane on the left side of the Contact Sheet and see if it makes any difference. I personally get the slow behavior when the Navigator is hidden but performance is fast when the Navigator is visible.
Kevin M. Cox | Photojournalist
https://www.KevinCox.com

Offline Paul Smith

  • Member
  • **
  • Posts: 83
    • View Profile
Re: 4.5 Beta Bugs
« Reply #33 on: April 01, 2007, 08:34:11 PM »
Paul, this sounds like the same issue that is being worked through in this thread:
http://forums.camerabits.com/index.php?topic=1181.0

Do you have the Favorites/Navigator pane completely collapsed on your Contact Sheet windows?  If so, try expanding them out a bit with the splitter.  I think the performance should be back.  Let me know if this helps.

-Kirk

Try Kirk's above suggestion re: the Favorites/Navigator pane on the left side of the Contact Sheet and see if it makes any difference. I personally get the slow behavior when the Navigator is hidden but performance is fast when the Navigator is visible.

Hi Kevin,

Thanks, I'd missed that thread. Yes, the problem does disappear when I have the Favorites/Navigator pane open. Hope it's fixed in the full release.

Cheers,

Paul

Offline Kevin M. Cox

  • Sr. Member
  • ****
  • Posts: 410
  • PM 5 Build 19749 | macOS 10.13.6 (17G7024)
    • View Profile
    • Kevin M. Cox | Photojournalist
Re: 4.5 Beta Bugs
« Reply #34 on: April 01, 2007, 08:36:20 PM »
Paul, I'm sure it will be. Kirk is working on this specific issue right now.
Kevin M. Cox | Photojournalist
https://www.KevinCox.com

Offline TonyField

  • Newcomer
  • *
  • Posts: 18
    • View Profile
Re: 4.5 Beta Bugs
« Reply #35 on: April 01, 2007, 09:40:40 PM »
Using: Windows Xp, (SP 2, 2gb memory, 2 hard disks, two monitors).

The beta edition is file PMSetup4.5b0331.exe.  The "about" information is version 4.5.

If I drag and drop a thumbnail or a file name onto the PM beta icon, the image dropped is not positioned nor selected in the contact sheet.

Did even 4.4.3.3 do that behavior?

My last used beta was in file:  PMSetup4.5b0319.exe.  It operated in the same way.

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20513
    • View Profile
    • Camera Bits, Inc.
Re: 4.5 Beta Bugs
« Reply #36 on: April 01, 2007, 09:55:46 PM »
Using: Windows Xp, (SP 2, 2gb memory, 2 hard disks, two monitors).

The beta edition is file PMSetup4.5b0331.exe.  The "about" information is version 4.5.

If I drag and drop a thumbnail or a file name onto the PM beta icon, the image dropped is not positioned nor selected in the contact sheet.

Did even 4.4.3.3 do that behavior?

My last used beta was in file:  PMSetup4.5b0319.exe.  It operated in the same way.

Right.  What I asked was if 4.4.3.3 had the desired behavior or not.  Looking at the code, I can see that it is quite likely that it has never done what you're requesting it do.  You see, when you drop a photo on the application icon, it launches a new instance of Photo Mechanic which sees that another one already exists.  Then it sends a message saying "open the file that was dropped on me".  Unfortunately there is a limit to how long command line parameters can be, so if you dropped a bunch of files on the icon then a few of them might be able to be represented within the command line length limit, but some of them may not.  This means that such a feature would never be completely reliable unless I can think of a different way to do this.

-Kirk

Offline TonyField

  • Newcomer
  • *
  • Posts: 18
    • View Profile
Re: 4.5 Beta Bugs
« Reply #37 on: April 02, 2007, 12:59:24 AM »
Right.  What I asked was if 4.4.3.3 had the desired behavior or not.  Looking at the code, I can see that it is quite likely that it has never done what you're requesting it do.  You see, when you drop a photo on the application icon, it launches a new instance of Photo Mechanic which sees that another one already exists.   ...

Sorry I was not clear.  If PM is not running and I drop a selected  Windows Explorer thumbnail or file name onto the PM desktop icon, I would expect PM to start running, position the contact sheet to the exact contact sheet thumbnail, select the thumbnail (and then display the preview). For example, Adobe Bridge and to a certain degree, even Windows Picture and Fax Viewer (which does not have a "contact sheet") work in this way.  At present, PM will only open the directory as a contact sheet but NOT position to the dropped file.

The expectation is that a single file name is dropped onto the desktop icon - or that a single file name is added to the command line when PM would be executed and that file name would be used for processing.  This is, as far as I can see, the  operation of most programmes such as Microsoft Word, Notepad, and many other programmes.  As another example, if you use the PM option of "Show In Windows Explorer", explorer will display the directory, position the directory to the (last) file selected, and select the (last) file.  (I cannot comment on how apple systems work).

If multiple files are dropped onto the desktop icon (or if multiple file names are added to the command line execution) things can be confusing.   In the case of Adobe Bridge, multiple instances of Bridge are invoked - one for each file name and the image is properly displayed on each of the preview screens.  This multiple activation strategy seems to be operationally incorrect (IMO) for PM.  I would think the best strategy would be to only open the first file on the command line, display the directory as a contact sheet, position the contact sheet to the file, select the file (and, preferably display the preview).

If a thumbnail from a PM contact sheet is drag-and-dropped onto the PM desktop icon, the present action of "do nothing" seems to be correct.

tony.

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20513
    • View Profile
    • Camera Bits, Inc.
Re: 4.5 Beta Bugs
« Reply #38 on: April 02, 2007, 06:46:38 AM »
Tony,

Right.  What I asked was if 4.4.3.3 had the desired behavior or not.  Looking at the code, I can see that it is quite likely that it has never done what you're requesting it do.  You see, when you drop a photo on the application icon, it launches a new instance of Photo Mechanic which sees that another one already exists.   ...

Sorry I was not clear.  If PM is not running and I drop a selected  Windows Explorer thumbnail or file name onto the PM desktop icon, I would expect PM to start running, position the contact sheet to the exact contact sheet thumbnail, select the thumbnail (and then display the preview). For example, Adobe Bridge and to a certain degree, even Windows Picture and Fax Viewer (which does not have a "contact sheet") work in this way.  At present, PM will only open the directory as a contact sheet but NOT position to the dropped file.

The expectation is that a single file name is dropped onto the desktop icon - or that a single file name is added to the command line when PM would be executed and that file name would be used for processing.  This is, as far as I can see, the  operation of most programmes such as Microsoft Word, Notepad, and many other programmes.  As another example, if you use the PM option of "Show In Windows Explorer", explorer will display the directory, position the directory to the (last) file selected, and select the (last) file.  (I cannot comment on how apple systems work).

If multiple files are dropped onto the desktop icon (or if multiple file names are added to the command line execution) things can be confusing.   In the case of Adobe Bridge, multiple instances of Bridge are invoked - one for each file name and the image is properly displayed on each of the preview screens.  This multiple activation strategy seems to be operationally incorrect (IMO) for PM.  I would think the best strategy would be to only open the first file on the command line, display the directory as a contact sheet, position the contact sheet to the file, select the file (and, preferably display the preview).

If a thumbnail from a PM contact sheet is drag-and-dropped onto the PM desktop icon, the present action of "do nothing" seems to be correct.

Please post this as a feature request.  This is not a PM 4.5 beta bug.  I cannot hold up the release of PM 4.5 for any additional new features.  I hope you understand.

-Kirk

Offline bcap

  • Newcomer
  • *
  • Posts: 35
    • View Profile
Re: 4.5 Beta Bugs
« Reply #39 on: April 02, 2007, 08:54:50 AM »
Kirk have you been able to reproduce the problem I had?

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20513
    • View Profile
    • Camera Bits, Inc.
Re: 4.5 Beta Bugs
« Reply #40 on: April 02, 2007, 08:58:26 AM »
Kirk have you been able to reproduce the problem I had?

Not yet.

-Kirk

Offline heavymeister

  • Member
  • **
  • Posts: 92
    • View Profile
Re: 4.5 Beta Bugs
« Reply #41 on: April 02, 2007, 02:36:42 PM »
Kirk,

PM4.5.b031, Mac OS X.4.9, G4 1Ghz
While browsing some older files I get a lot of black thumbnails (from jpeg) saying "Unsupported Format Variant". With PM4.4 they showed up OK. Also the preview of the D100 NEF is not as highly resoluted as the D200 NEFs. I was hoping for cure with PM4.5.

Greetings,
HM 
« Last Edit: April 02, 2007, 02:39:54 PM by heavymeister »

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20513
    • View Profile
    • Camera Bits, Inc.
Re: 4.5 Beta Bugs
« Reply #42 on: April 02, 2007, 04:23:01 PM »
HM,

PM4.5.b031, Mac OS X.4.9, G4 1Ghz
While browsing some older files I get a lot of black thumbnails (from jpeg) saying "Unsupported Format Variant". With PM4.4 they showed up OK. Also the preview of the D100 NEF is not as highly resoluted as the D200 NEFs. I was hoping for cure with PM4.5.

It would be useful to have some samples of those images.  I would recommend that you empty out your image cache too and see if that makes any difference.

As for the D100 images, they still have a very small embedded JPEG which is what PM displays by default.  You can either press the 'Q' key in the Preview window to view the RAW rendered version, or you can enable RAW rendering in the Preview tab of the Preferences dialog.  Another option would be to use Nikon's NPrevCreator3 to generate high-resolution previews in your NEF files.  The quality is nice and the speed in PM is great.

Contact me privately if you want to upload some sample images.

-Kirk

Offline Marty Ojaste

  • Member
  • **
  • Posts: 66
    • View Profile
    • Martin Ojaste
Re: 4.5 Beta Bugs
« Reply #43 on: April 02, 2007, 09:07:35 PM »
I get the unknown format errors on my Win Vista system. I first noticed it when I exported from Lightroom a bunch of JPG images to a folder. Most of the images are visible in PM 4.5, but sprinkled through them are the unknown format errors. My solution was to avoid looking in folders that other programs are using. When i do that the error does not appear.

\Marty

\Marty