Author Topic: Color class and Star ratings not being sent to Lightroom.  (Read 471 times)

Offline Joescrogham

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Color class and Star ratings not being sent to Lightroom.
« on: December 16, 2017, 11:30:42 am »
Need help getting the color class and star ratings to transfer to Lightroom. I'm running Lightroom CC Clasic and the latest PM. In LR under catalog settings I have automatically wright changes to XMP checked. The color names are the same in both LR and PM. In PM the color classes are set to Adobe Lightroom and the Synchronize color class with IPTC urgency field box is checked. Can someone please tell me how to get the color class and star rating to transfer from PM to LR?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 17995
    • View Profile
    • Camera Bits, Inc.
Re: Color class and Star ratings not being sent to Lightroom.
« Reply #1 on: December 16, 2017, 11:48:13 am »
Need help getting the color class and star ratings to transfer to Lightroom. I'm running Lightroom CC Clasic and the latest PM. In LR under catalog settings I have automatically wright changes to XMP checked. The color names are the same in both LR and PM. In PM the color classes are set to Adobe Lightroom and the Synchronize color class with IPTC urgency field box is checked. Can someone please tell me how to get the color class and star rating to transfer from PM to LR?

If you've already imported your images into Lr and then you make changes to metadata outside of Lr (for instance with PM), you'll need to force Lr to read the metadata from the files.  Use the "Read Metadata from Files" command on the Metadata menu in Lr.

HTH,

-Kirk

Offline Joescrogham

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Color class and Star ratings not being sent to Lightroom.
« Reply #2 on: December 16, 2017, 02:51:01 pm »
My workflow is to ingest them into PM, make my selections, crops, color code and give a star rating then import them into LR by opening LR and dragging the selections over.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 17995
    • View Profile
    • Camera Bits, Inc.
Re: Color class and Star ratings not being sent to Lightroom.
« Reply #3 on: December 16, 2017, 05:54:31 pm »
My workflow is to ingest them into PM, make my selections, crops, color code and give a star rating then import them into LR by opening LR and dragging the selections over.

Please post a screenshot of your IPTC/XMP settings and list the file types you work with.  Use the 'Attachments and other options' link when you're composing your reply to this message and there you'll be able to upload your JPEG format screenshot.

Thanks,

-Kirk

Offline Joescrogham

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Color class and Star ratings not being sent to Lightroom.
« Reply #4 on: December 16, 2017, 08:05:56 pm »
I only use Nikon RAW and jpg files. Raw files are from a D800 if that makes a difference.


Offline Joescrogham

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Color class and Star ratings not being sent to Lightroom.
« Reply #5 on: December 16, 2017, 08:07:37 pm »
oops, let me try that again.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 17995
    • View Profile
    • Camera Bits, Inc.
Re: Color class and Star ratings not being sent to Lightroom.
« Reply #6 on: December 18, 2017, 07:38:14 am »
Settings look good.  Can you provide a NEF+XMP and a JPG (if you're having problems with both)?

Thanks,

-Kirk

Offline Joescrogham

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Color class and Star ratings not being sent to Lightroom.
« Reply #7 on: December 18, 2017, 11:59:56 am »
Hmmm  ok well the raw file is larger than the 16 mb size limit. I can give you the XMP and Jpg file though. The raw file is 37 mb.


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 17995
    • View Profile
    • Camera Bits, Inc.
Re: Color class and Star ratings not being sent to Lightroom.
« Reply #8 on: December 18, 2017, 03:35:15 pm »
Need help getting the color class and star ratings to transfer to Lightroom. I'm running Lightroom CC Clasic and the latest PM. In LR under catalog settings I have automatically wright changes to XMP checked. The color names are the same in both LR and PM. In PM the color classes are set to Adobe Lightroom and the Synchronize color class with IPTC urgency field box is checked. Can someone please tell me how to get the color class and star rating to transfer from PM to LR?

Thanks for the samples.  There is no rating or label in those files.  I suggest turning off the "synchronize" setting as it was only really useful for users who also used iView Media Pro.  Then on the "Files" section of the Preferences dialog, make sure that the "Always update XMP label when changing Color Class" is set.

HTH,

-Kirk

Offline Joescrogham

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Color class and Star ratings not being sent to Lightroom.
« Reply #9 on: December 18, 2017, 04:25:57 pm »
Well, there is in PM. I circled the thumbnail in the contact sheet.

I turned off the synchronize setting under the general preferences tab. It still does not send the data over to lightroom.

The box is checked to Always update XMP label when changing Color Class.

Is there something in lightroom that could be causing the problem? I've been playing with it but from what I can tell all the settings that are mentioned in the online manual are set correctly.


Offline Jerry H

  • Camera Bits Staff
  • Full Member
  • *****
  • Posts: 107
    • View Profile
    • Camera Bits, Inc.
Re: Color class and Star ratings not being sent to Lightroom.
« Reply #10 on: December 19, 2017, 09:05:37 am »
I suggest that you use Photo Mechanic's Update IPTC/XMP command located in the Tools menu so that the XMP sidecar files get updated with the rating information.

In Lightroom, make sure that you're not applying a metadata preset to the images on import (menu: Metadata > Edit Metadata Presets). You may need to have LR re-read the metadata, after updating the IPTC/XMP in PM, by right-clicking on the folder from LR's Folders navigator panel and choosing Synchronize Folder from the contextual menu.

I hope this helps,

Jerry

Offline Joescrogham

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Color class and Star ratings not being sent to Lightroom.
« Reply #11 on: December 20, 2017, 01:53:34 am »
That was it!  I had metadata presets turned on. I thought they just appended to the metadata but I guess they totally replace it. I'll have to enter all the shoot info in Photo Mechanic instead of Lightroom. Anyway, it's working like a champ now and I'm a happy camper! I can do one import now into Lightroom instead of 4. This just made life so much easier! 

Thank You!  8) 8) 8) 8)