Author Topic: XMP file problem 4.4.3.3 & 4.5, Mac  (Read 4850 times)

Offline gregoire

  • Member
  • **
  • Posts: 54
    • View Profile
    • www.emilegregoire.com
XMP file problem 4.4.3.3 & 4.5, Mac
« on: March 21, 2007, 07:41:14 AM »
Kirk,

Just downloaded 4.5 beta to see if it got rid of a problem I just noticed on 4.4.3.3 (both for Mac, recently switched, using OS X 10.4.9 on an Intel system). Alas, 4.5 has the same problem:

When I tag a photo in PM all of my ACR data gets tossed out of the XMP file. I'm using ACR 3.7 in CS2 (Bridge/Photoshop). Untagging doesn't solve the problem. I can send you two XMP files: one before and one after tagging so you can see the difference. Seems like basically the complete XMP file gets replaced - nothing is left that was in it before using PM.

Might have something to do with Canon changing the XMP files in ACR v3.7 to support Lightroom.

Happens with all three settings in the dropdown list in IPTC/XMP preferences / For TIFF-based RAW photos. So there's no workaround for me but to just use PM for ingestion - and I really want to use it all the time ;)

Emile

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: XMP file problem 4.4.3.3 & 4.5, Mac
« Reply #1 on: March 21, 2007, 08:36:07 AM »
Emile,

Just downloaded 4.5 beta to see if it got rid of a problem I just noticed on 4.4.3.3 (both for Mac, recently switched, using OS X 10.4.9 on an Intel system). Alas, 4.5 has the same problem:

When I tag a photo in PM all of my ACR data gets tossed out of the XMP file. I'm using ACR 3.7 in CS2 (Bridge/Photoshop). Untagging doesn't solve the problem. I can send you two XMP files: one before and one after tagging so you can see the difference. Seems like basically the complete XMP file gets replaced - nothing is left that was in it before using PM.

Might have something to do with Canon changing the XMP files in ACR v3.7 to support Lightroom.

Happens with all three settings in the dropdown list in IPTC/XMP preferences / For TIFF-based RAW photos. So there's no workaround for me but to just use PM for ingestion - and I really want to use it all the time ;)

I would want the CR2 file as well as the two XMP files.

Contact me privately for server upload information.

-Kirk

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: XMP file problem 4.4.3.3 & 4.5, Mac
« Reply #2 on: March 22, 2007, 07:14:34 AM »
Emile,

Just downloaded 4.5 beta to see if it got rid of a problem I just noticed on 4.4.3.3 (both for Mac, recently switched, using OS X 10.4.9 on an Intel system). Alas, 4.5 has the same problem:

When I tag a photo in PM all of my ACR data gets tossed out of the XMP file. I'm using ACR 3.7 in CS2 (Bridge/Photoshop). Untagging doesn't solve the problem. I can send you two XMP files: one before and one after tagging so you can see the difference. Seems like basically the complete XMP file gets replaced - nothing is left that was in it before using PM.

Might have something to do with Canon changing the XMP files in ACR v3.7 to support Lightroom.

Happens with all three settings in the dropdown list in IPTC/XMP preferences / For TIFF-based RAW photos. So there's no workaround for me but to just use PM for ingestion - and I really want to use it all the time ;)

Here is the solution to your problem.  Adjust your IPTC/XMP preferences to look like this:



[attachment deleted by admin]

Offline gregoire

  • Member
  • **
  • Posts: 54
    • View Profile
    • www.emilegregoire.com
Re: XMP file problem 4.4.3.3 & 4.5, Mac
« Reply #3 on: March 28, 2007, 04:03:42 AM »
Kirk, as usual: thanks.

I found that changing the settings for 'When reading IPTC/XMP' did the trick and the rest of the settings (When saving) don't make a difference. That way I can still embed data into the file itself which is my preferred way of working. Tagging, adding captions, etc etc, all works as should.

Thanks again, you've solved a huge problem!

Emile