Author Topic: Long "Getting sort data" message when multi-tasking between PM and other apps.  (Read 1050 times)

Offline alexz59

  • Newcomer
  • *
  • Posts: 4
    • View Profile
I am running Photo Mechanic Version 5.0, build 19094 (12cba6f) and I run Mac OS X 10.13.2 on my Intel-based iMac. (3.5 GHz Intel Core i7, 32 GB RAM, SSD)

I have a contact sheet open with a large number of RAW .NEF photos (usually several thousand) and I'm in the preview window rating my photos. Whenever I click off of Photo Mechanic, use any other application for a few seconds (such as a web browser to read my email) and come back to Photo Mechanic I have to wait for it to reload, which takes 2-3 minutes. I get a "Getting sort data..." message and can't do anything in the meantime until it's done reloading. It's a bit frustrating because nothing changes as far as my photos go or the folder they are in, all I do is go to another application and come back and have to wait a long time for Photo Mechanic to become responsive again. I should also mention that I order my photos by capture time.

Any way to fix this is greatly appreciated! Thank you!

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 18507
    • View Profile
    • Camera Bits, Inc.
I am running Photo Mechanic Version 5.0, build 19094 (12cba6f) and I run Mac OS X 10.13.2 on my Intel-based iMac. (3.5 GHz Intel Core i7, 32 GB RAM, SSD)

I have a contact sheet open with a large number of RAW .NEF photos (usually several thousand) and I'm in the preview window rating my photos. Whenever I click off of Photo Mechanic, use any other application for a few seconds (such as a web browser to read my email) and come back to Photo Mechanic I have to wait for it to reload, which takes 2-3 minutes. I get a "Getting sort data..." message and can't do anything in the meantime until it's done reloading. It's a bit frustrating because nothing changes as far as my photos go or the folder they are in, all I do is go to another application and come back and have to wait a long time for Photo Mechanic to become responsive again. I should also mention that I order my photos by capture time.

Any way to fix this is greatly appreciated! Thank you!

I'd like to see your Photo Mechanic log.  In Photo Mechanic go to the Help menu and choose "Reveal Support Data..." and moments later a Finder window will come forward with the zipped log file selected.  Use the 'Attachments and other options' link when you're composing your reply to this message and there you'll be able to upload your zipped PM log file.

Thanks,

-Kirk

Offline alexz59

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Hi Kirk,

Here you go.

Thank you!!

Alex

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 18507
    • View Profile
    • Camera Bits, Inc.
Alex,

There are loads of errors and warnings in your log.  What day and about what time were you getting the sluggish response?

-Kirk

Offline alexz59

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Hi Kirk,

It happened several times since this morning and happens every time I use PM. I've been using it almost daily this past week. All I have to do is click off of PM and use another app for a short period of time and come back to PM. I don't even minimize the PM window, it's just open in the background and I get the "getting sort data" message in the status bar and am forced to wait for it to be responsive again when I come back. Hope this clarifies it.

Thank you!

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 18507
    • View Profile
    • Camera Bits, Inc.
Alex,

It happened several times since this morning and happens every time I use PM. I've been using it almost daily this past week. All I have to do is click off of PM and use another app for a short period of time and come back to PM. I don't even minimize the PM window, it's just open in the background and I get the "getting sort data" message in the status bar and am forced to wait for it to be responsive again when I come back. Hope this clarifies it.

If you switch to Filename sorting does the problem go away?  How many items are in the folder that you're browsing?

-Kirk

Offline alexz59

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Hi Kirk,

I just uninstalled and reinstalled PM and reset all of the settings by deleting the preferences files and that seemed to have fixed the problem. I was working with about 15k files in one folder and switching to sorting by filename wasn't fixing it before. Seems to be better now though!

Thank you!