Author Topic: Help - XMP misery  (Read 708 times)

Offline Pavel

  • Jr. Member
  • **
  • Posts: 82
    • View Profile
Help - XMP misery
« on: March 14, 2018, 12:17:50 pm »
I used to have it set up where photomechanic did not create separate xmp files next to the photo.  Now every time I make a change in photomechanic it creates this file and I've spent so much time trying to stop this and I just can't remember how it's done.  This drives me absolutely crazy.  What do I need to do so that these sidecar files and not created.  What am I doing wrong? Thanks.   

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 18403
    • View Profile
    • Camera Bits, Inc.
Re: Help - XMP misery
« Reply #1 on: March 14, 2018, 12:24:53 pm »
Pavel,

I used to have it set up where photomechanic did not create separate xmp files next to the photo.  Now every time I make a change in photomechanic it creates this file and I've spent so much time trying to stop this and I just can't remember how it's done.  This drives me absolutely crazy.  What do I need to do so that these sidecar files and not created.  What am I doing wrong? Thanks.

Your settings look good for your desired goal.  That said, if an image already has an XMP sidecar file, PM will continue to update the sidecar file when metadata changes are made.  If you start with a fresh set of images that don't have existing XMP sidecar files, does PM create them when you change metadata on your images with PM?

-Kirk

Offline Pavel

  • Jr. Member
  • **
  • Posts: 82
    • View Profile
Re: Help - XMP misery
« Reply #2 on: March 14, 2018, 12:28:40 pm »
I have gone and deleted every single sidecar and any time I use PM to, for example, rate the photo with a star or to change the color class - a sidecar appears. 

Could this "always update xmp label" be causing this?

I've been prescribed medication which makes me really confused, so I presume I'm looking straight at "it" but things aren't making any sense.  :(
« Last Edit: March 14, 2018, 12:32:15 pm by Pavel »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 18403
    • View Profile
    • Camera Bits, Inc.
Re: Help - XMP misery
« Reply #3 on: March 14, 2018, 04:04:49 pm »
Pavel,

We cannot reproduce the problem with the current build (19252) and your settings on NEF or CR2 files.  What build are you using, and what type of RAW files are you working with?

Thanks,

-Kirk

Offline Soizic

  • Full Member
  • ***
  • Posts: 240
    • View Profile
Re: Help - XMP misery
« Reply #4 on: March 15, 2018, 12:34:14 am »
"Could this "always update xmp label" be causing this?"

Yes I suppose. I have not checked this box and I have never XMP files.
Soizic (France)