Author Topic: Smugmug uploader broken?  (Read 142 times)

Offline joemahoney

  • Newcomer
  • *
  • Posts: 11
    • View Profile
    • I-News Network
Smugmug uploader broken?
« on: June 13, 2018, 10:19:21 pm »
Update: Problem happens in ver 5.0, build 19252 (b2467f1), too

Smugmug uploader has stopped working. I've used it consistenly on my own account for quite a while, but today it failed with with this error: "private method `gsub' called for nil:NilClass"

I'm using Photo Mechanic Version 5.0, build 19395 (69a3200)

Trying to upload an image to an old gallery (the only one in the menu) gives this: Unable to upload because: Have not received gallery list from server.

Very strange. When I get back home, I'll see what is happening with my desktop machine and back-up laptop. (Just to rule out a local machine issue -- this is a newly built laptop, but again, it worked great all last week.)

Hopefully, their acquisition of Flickr isn't knackering things... Thanks, Joe M.
« Last Edit: June 14, 2018, 01:12:26 pm by joemahoney »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 18265
    • View Profile
    • Camera Bits, Inc.
Re: Smugmug uploader broken?
« Reply #1 on: June 14, 2018, 01:54:18 pm »
We're working on a fix.  They stopped honoring the older SmugMug API that we were using a few days ago.

-Kirk

Offline joemahoney

  • Newcomer
  • *
  • Posts: 11
    • View Profile
    • I-News Network
Re: Smugmug uploader broken?
« Reply #2 on: June 14, 2018, 06:22:54 pm »
Yes, just got an email with that message when I told them it was broken. Thanks.