Author Topic: PM Navigation Agent Non-Responsive Application  (Read 972 times)

Offline bpatoc

  • Newcomer
  • *
  • Posts: 2
    • View Profile
PM Navigation Agent Non-Responsive Application
« on: June 19, 2018, 12:20:20 AM »
For the past few weeks Photo Mechanic has been running quite slow when I try to move/copy files from one place to another. My mac freezes up momentarily and indicates "PM Navigation Agent" as a non-responsive application.

The ingest dialog is also painfully slow... takes me several minutes to start an ingest or even open the IPTC stationary window.

I haven't done any major updates since this issue has started. Plenty of storage on my mac, although the issue doesn't seem to to be as bad when I'm working with files on an external drive.

Mac / High Sierra / 10.13.4

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21745
    • View Profile
    • Camera Bits, Inc.
Re: PM Navigation Agent Non-Responsive Application
« Reply #1 on: June 19, 2018, 08:48:18 AM »
In the Preferences dialog, go to the Accessibility section.  In that panel uncheck the box labeled "Run Navigation Services dialogs in a separate process"

http://wiki.camerabits.com/en/index.php/User_Manual_Flat_View#Accessibility_Preferences

-Kirk

Offline bpatoc

  • Newcomer
  • *
  • Posts: 2
    • View Profile
Re: PM Navigation Agent Non-Responsive Application
« Reply #2 on: June 21, 2018, 05:40:14 AM »
Thanks. This removed the non-responsive message I was receiving but PM is still lagging significantly when I'm trying to perform certain functions... especially when I'm selecting the target destination when ingesting or copy/moving files on my mac.

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21745
    • View Profile
    • Camera Bits, Inc.
Re: PM Navigation Agent Non-Responsive Application
« Reply #3 on: June 21, 2018, 08:04:42 AM »
Thanks. This removed the non-responsive message I was receiving but PM is still lagging significantly when I'm trying to perform certain functions... especially when I'm selecting the target destination when ingesting or copy/moving files on my mac.

For a problem like this, I suggest contacting our support folks at:

By email: support@camerabits.com

By phone: +1 503.547.2800 option 2

Hours: Mon-Fri, 9:00am-5:00pm [PST/PDT]