Author Topic: No thumbnails for videos  (Read 393 times)

Offline bentoni

  • Newcomer
  • *
  • Posts: 13
    • View Profile
No thumbnails for videos
« on: August 05, 2018, 10:34:53 pm »
I am running Photo Mechanic Version 5.0, build 19695 (4a8c3fe) on a Mac with OS X 10.13.5.  I have been shooting 4K video lately and while I used to see thumbnail images for these files, now I see black frames with the message, "unable to render image." The video files are 4K .mov files with H.265 compression. They are typically about 5 gb in size. Is there something I can do to fix this?  Thank you very much.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 18513
    • View Profile
    • Camera Bits, Inc.
Re: No thumbnails for videos
« Reply #1 on: August 06, 2018, 07:45:21 am »
I am running Photo Mechanic Version 5.0, build 19695 (4a8c3fe) on a Mac with OS X 10.13.5.  I have been shooting 4K video lately and while I used to see thumbnail images for these files, now I see black frames with the message, "unable to render image." The video files are 4K .mov files with H.265 compression. They are typically about 5 gb in size. Is there something I can do to fix this?  Thank you very much.

Probably not.  PM5 is using an old QuickTime framework and it isn't being kept up to date by Apple any longer.  PM6 (in development) uses AVFoundation which Apple is currently maintaining so I expect that PM6 (on macOS) will both show thumbnails and allow you to play the videos in the Preview window.

If you could shoot a very short one and post it here, then I can check to see if it will be supported.  Use the 'Attachments and other options' link when you're composing your reply to this message and there you'll be able to upload your video file.

Thanks,

-Kirk

Offline bentoni

  • Newcomer
  • *
  • Posts: 13
    • View Profile
Re: No thumbnails for videos
« Reply #2 on: August 07, 2018, 02:56:14 pm »
unfortunately, even the shortest clip is larger than the maximum allowed for upload here. I am happy to send you a short sample some other way if that will help you.

Randall Benton
Rbenton@sacbee.com

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 18513
    • View Profile
    • Camera Bits, Inc.
Re: No thumbnails for videos
« Reply #3 on: August 07, 2018, 05:24:57 pm »
Randall,

unfortunately, even the shortest clip is larger than the maximum allowed for upload here. I am happy to send you a short sample some other way if that will help you.

Sure, you could provide a link to it on some server where you've uploaded the sample.  DropBox is a popular service for such things.

-Kirk

Offline bentoni

  • Newcomer
  • *
  • Posts: 13
    • View Profile
Re: No thumbnails for videos
« Reply #4 on: August 11, 2018, 05:24:01 pm »
here is a link to a short video clip that could not be rendered in PM.:

https://www.dropbox.com/s/1ed7i6xgqe3st3s/Untitled.mov?dl=0

I hope this helps.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 18513
    • View Profile
    • Camera Bits, Inc.
Re: No thumbnails for videos
« Reply #5 on: August 11, 2018, 08:58:31 pm »
here is a link to a short video clip that could not be rendered in PM.:

https://www.dropbox.com/s/1ed7i6xgqe3st3s/Untitled.mov?dl=0

I hope this helps.

Thanks for the video link.  My 10.11.6 system can't play that video at all.  Must require 10.13, I suppose.  I will test your video against PM6 on 10.13 soon.

Thanks,

-Kirk

Offline bentoni

  • Newcomer
  • *
  • Posts: 13
    • View Profile
Re: No thumbnails for videos
« Reply #6 on: August 17, 2018, 10:57:36 am »
I may have found the reason for my problem. The videos that do not render are videos made with H.265 compression codec, also called High Efficiency Video Coding (HEVC) I changed my camera's preferences to record using the H.264 codec, and they render just fine.
I hope this helps you.

Randall Benton