Author Topic: Very bad performance with PM6 on Mojave  (Read 9111 times)

Online Matthew

  • Member
  • **
  • Posts: 63
    • View Profile
    • matt-horwood.com
Re: Very bad performance with PM6 on Mojave
« Reply #90 on: April 10, 2019, 06:44:49 AM »
I don't have a developer account with Apple but it would be interesting to know if PM6 still runs sluggishly on affected machines with the the latest Beta of Mojave 10.14.5.

https://www.macrumors.com/2019/04/09/apple-seeds-macos-mojave-10-14-5-public-beta-2/

Offline Roland1234

  • Newcomer
  • *
  • Posts: 1
    • View Profile
Re: Very bad performance with PM6 on Mojave
« Reply #91 on: April 12, 2019, 06:27:04 AM »
Here it is slow too. Installed the last Version of PM6, it´s unusable. I use PM5 now.

Offline gb_eh

  • Newcomer
  • *
  • Posts: 3
    • View Profile
Re: Very bad performance with PM6 on Mojave
« Reply #92 on: April 16, 2019, 02:30:26 PM »
I wanted to upgrade, but it sounds as if this isn't an upgrade for many/most Mac OS users due to speed issues. Back through the thread (Apr-04) there was mention of a new build release, but one that wouldn't fix the speed issue. Has this or is this still an issue? Do I pull the trigger and upgrade or hold off?  Is this still being addressed by devs?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20034
    • View Profile
    • Camera Bits, Inc.
Re: Very bad performance with PM6 on Mojave
« Reply #93 on: April 16, 2019, 03:18:26 PM »
I wanted to upgrade, but it sounds as if this isn't an upgrade for many/most Mac OS users due to speed issues. Back through the thread (Apr-04) there was mention of a new build release, but one that wouldn't fix the speed issue. Has this or is this still an issue? Do I pull the trigger and upgrade or hold off?  Is this still being addressed by devs?

The issue has not been solved at this time.  We are investigating possible solutions and have been in contact with Apple on the issue.

-Kirk

Offline arcterex

  • Newcomer
  • *
  • Posts: 1
    • View Profile
Re: Very bad performance with PM6 on Mojave
« Reply #94 on: April 16, 2019, 04:20:59 PM »
I have to jump in here as well.  I tried the PM5 and found it amazing but never bought or committed the time to it, now that 6 is out I really want to jump on the fast-culling bandwagon but the performance isn't nearly what I've been led to believe it is, and matches up with what people here are saying.

I'm on a macbook pro 2019, 16G ram, 512 SSD, importing maybe 300 photos at a go and running the latest version of Mojave if that helps at all.

Offline PFloyd

  • Newcomer
  • *
  • Posts: 1
    • View Profile
Re: Very bad performance with PM6 on Mojave
« Reply #95 on: April 17, 2019, 04:48:11 PM »
I have not read through this entire thread, but this reminds of a problem I had when I tried installing the ThinkorSwim app from TD AmeriTrade ... Everything was unbearably slow on my MacBook Pro, just trying to install it, yet it installed and ran fine on my friend's MacBook. Turns out the problem was an app called "Magnet" that I had installed on my MacBook. Perhaps some people have Magnet or some other app installed that is conflicting with PM 6? Simply posting system info would not necessarily reveal this. Just sayin' . . .

Offline gregoire

  • Member
  • **
  • Posts: 52
    • View Profile
    • www.emilegregoire.com
Re: Very bad performance with PM6 on Mojave
« Reply #96 on: April 18, 2019, 03:06:59 PM »
I have not read through this entire thread, but this reminds of a problem I had when I tried installing the ThinkorSwim app from TD AmeriTrade ... Everything was unbearably slow on my MacBook Pro, just trying to install it, yet it installed and ran fine on my friend's MacBook. Turns out the problem was an app called "Magnet" that I had installed on my MacBook. Perhaps some people have Magnet or some other app installed that is conflicting with PM 6? Simply posting system info would not necessarily reveal this. Just sayin' . . .

It's not Magnet. PM is running fast on my 2017 MBP and I have Magnet installed. But good thinking, nifty programs like these that interfere (in a good way) with the way an OS usually works can cause major headache.

Offline LarsSmook

  • Newcomer
  • *
  • Posts: 31
    • View Profile
Re: Very bad performance with PM6 on Mojave
« Reply #97 on: April 23, 2019, 12:59:54 AM »
The issue has not been solved at this time.  We are investigating possible solutions and have been in contact with Apple on the issue.

-Kirk

Any update on this?

I tried to change the monitor profile to sRGB, this makes a difference like you mentioned, but it has not the same performance as PM5. You mentioned in previous post that most users will use the 'Color-LCD' profile, in my case (and I think many other professional users as well), the monitor (built-in Retina screen) uses a custom profile made by a monitor calibration device (Spyder5Pro). Changing to sRGB or another pre-installed profile is not an option for permanent use, because this give incorrect colors.
I also want to mention that sRGB gives a better performance on a Retina MacBook in comparison to a custom profile, but when I scroll trough the images using the left/right arrow keys it's still 2/3 images behind on the 'clicks'. With the custom profile it can be 10/15 images behind. On PM5 it's instant on all the profiles I tried.

Cheers,
Lars

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20034
    • View Profile
    • Camera Bits, Inc.
Re: Very bad performance with PM6 on Mojave
« Reply #98 on: April 23, 2019, 06:34:45 AM »
Lars,

The issue has not been solved at this time.  We are investigating possible solutions and have been in contact with Apple on the issue.

Any update on this?

I tried to change the monitor profile to sRGB, this makes a difference like you mentioned, but it has not the same performance as PM5. You mentioned in previous post that most users will use the 'Color-LCD' profile, in my case (and I think many other professional users as well), the monitor (built-in Retina screen) uses a custom profile made by a monitor calibration device (Spyder5Pro). Changing to sRGB or another pre-installed profile is not an option for permanent use, because this give incorrect colors.
I also want to mention that sRGB gives a better performance on a Retina MacBook in comparison to a custom profile, but when I scroll trough the images using the left/right arrow keys it's still 2/3 images behind on the 'clicks'. With the custom profile it can be 10/15 images behind. On PM5 it's instant on all the profiles I tried.

Apple has been less than helpful.  We still do not have a solution for this problem.

-Kirk

Offline imagetic

  • Newcomer
  • *
  • Posts: 13
    • View Profile
    • willduncan.com
Re: Very bad performance with PM6 on Mojave
« Reply #99 on: April 24, 2019, 02:00:02 PM »
It's probably zero help at this point since you're aware of the issue, but if it helps push Apple to show you have a user base of people who are experiencing the issue and get them to look more seriously.

Directly after install I built an auto ingest and pulled over a small number of photos from 2 days.  One contained 6 photos, the other 1300. Both folders run slow when scrolling or clicking on images.  But the one with 6 images is MUCH faster than the one with 1300. Lots of beachball time, not just lag feeling.

Model: iMac (18,3 - Retina 5K, 27-inch, 2017)
Processor: 4.2 GHz Intel Core i7
Memory: 64GB 2400 MHz DDR4
Graphics: Radeon Pro 580 8 GB

When I stop on an image and it takes a second to render it out, the PM process jumps from 25% to 100+%

If I leave the app and come back I'm beach balling for 3-5 seconds if I had recently scrolled through images.
www.willduncan.com

Model: iMac (18,3 - Retina 5K, 27-inch, 2017)
Processor: 4.2 GHz Intel Core i7
Memory: 64GB 2400 MHz DDR4
Graphics: Radeon Pro 580 8 GB

Offline mountaingazer

  • Newcomer
  • *
  • Posts: 3
    • View Profile
Re: Very bad performance with PM6 on Mojave
« Reply #100 on: April 24, 2019, 02:08:55 PM »
Also, see ing very slow performance here in PM6 with Mojave (10.14.3) on an MBP 16 GB RAM Core i7 Processor.  Totally unusable even when it eventually opens and if you leave the program to go another program, might as well close it and start over.  I have gone back to PM5 with none of the issues I have been seeing in PM6.

Offline bfeinzimer

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Very bad performance with PM6 on Mojave
« Reply #101 on: April 26, 2019, 04:44:57 PM »
I really wish we had some sort of workaround. It's frustrating paying for the PM6 update and it being completely unusable and seems as if this issue is in the "since Apple won't help we're stuck bin" without any resolution in sight.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20034
    • View Profile
    • Camera Bits, Inc.
Re: Very bad performance with PM6 on Mojave
« Reply #102 on: April 26, 2019, 05:19:19 PM »
I really wish we had some sort of workaround. It's frustrating paying for the PM6 update and it being completely unusable and seems as if this issue is in the "since Apple won't help we're stuck bin" without any resolution in sight.

No. I've given up waiting on Apple and will have to come up with my own solution, rewriting our image drawing pipeline to solve the issue.  This issue was unforeseen and did not show up in our testing.  It will likely take a week or two for me to get the new method working.

-Kirk

Offline timforbes

  • Newcomer
  • *
  • Posts: 13
    • View Profile
Re: Very bad performance with PM6 on Mojave
« Reply #103 on: May 02, 2019, 07:01:58 AM »
I'm on PM 6 and 10.14.5 (18F127a Public Beta) and it's working nice and fast now.

Offline Dominik Pluess

  • Member
  • **
  • Posts: 81
    • View Profile
Re: Very bad performance with PM6 on Mojave
« Reply #104 on: May 09, 2019, 10:05:02 AM »
any News on this task?