Author Topic: Custom uploaders no longer work in PM6  (Read 456 times)

Offline nick.lagalle

  • Newcomer
  • *
  • Posts: 20
    • View Profile
Custom uploaders no longer work in PM6
« on: March 30, 2019, 06:39:45 PM »
Hi there,

I have been testing PM6 and i now get an error on my custom uploader modules that worked fine in PM5.

The error that comes up is:

Template /Users/xxxxx/PM Files/Uploaders/pmp upload failed to compile. The error was: #<SyntaxError: (eval):2851: syntax error, unexpected ',', expecting ')'                 login = get_child_text (node, "login")                                              ^ (eval):2851: syntax error, unexpected ')', expecting keyword_end                 login = get_child_text (node, "login")                                                       ^ (eval):2855: syntax error, unexpected ',', expecting ')' ....set_text get_child_text (node, "name") ...                               ^ (eval):2855: syntax error, unexpected ')', expecting keyword_end ...t get_child_text (node, "name") ...                               ^ (eval):2856: syntax error, unexpected ',', expecting ')' ....set_text get_child_text (node, "server") ...                               ^ (eval):2856: syntax error, unexpected ')', expecting keyword_end ...get_child_text (node, "server") ...                               ^ (eval):2858: syntax error, unexpected ( arg, expecting keyword_do or '{' or '(' ...xt anon ? "" : get_child_text (node, "password") ...                               ^ (eval):2858: syntax error, unexpected ')', expecting keyword_end ...t_child_text (node, "password") ...                               ^ (eval):2860: syntax error, unexpected ',', expecting ')' ....set_text get_child_text (node, "destfolder") ...                               ^ (eval):2860: syntax error, unexpected ')', expecting keyword_end ...child_text (node, "destfolder") ...                               ^ (eval):2864: syntax error, unexpected ',', expecting ')' ....set_text get_child_text (node, "port").empty? ? "21" : get_... ...                               ^ (eval):2864: syntax error, unexpected ')', expecting keyword_end ...t get_child_text (node, "port").empty? ? "21" : get_child_te... ...                               ^ (eval):2864: syntax error, unexpected ( arg, expecting keyword_do or '{' or '(' ...mpty? ? "21" : get_child_text (node, "port") ...                               ^ (eval):2864: syntax error, unexpected ')', expecting keyword_end ...: get_child_text (node, "port") ...                               ^ (eval):3019: syntax error, unexpected ( arg, expecting keyword_end       c << @send_news_size_static.layout (104, c.base, 200, sh*4)                                           ^ (eval):3019: syntax error, unexpected ',', expecting :: or '[' or '.'       c << @send_news_size_static.layout (104, c.base, 200, sh*4)                                                            ^ (eval):3019: syntax error, unexpected ')', expecting keyword_end       c << @send_news_size_static.layout (104, c.base, 200, sh*4)                                                                  ^>     <main>:955:in `eval'     <main>:955:in `block in compile_template'


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: Custom uploaders no longer work in PM6
« Reply #1 on: March 30, 2019, 06:57:12 PM »
Hi there,

I have been testing PM6 and i now get an error on my custom uploader modules that worked fine in PM5.

The error that comes up is:

Template /Users/xxxxx/PM Files/Uploaders/pmp upload failed to compile. The error was: #<SyntaxError: (eval):2851: syntax error, unexpected ',', expecting ')'                 

Can you share your custom template with me so I can investigate?

The ruby version used in PM6 is now 2.0.0 versus the 1.8.4 used in PM5 so there are some differences in the two interpreters.  It should be easy to get it working again.

If you'd rather not share it publicly, click on my name to the left of this message and send me a personal message and we'll arrange a more private transfer.

Thanks,

-Kirk

Offline nick.lagalle

  • Newcomer
  • *
  • Posts: 20
    • View Profile
Re: Custom uploaders no longer work in PM6
« Reply #2 on: March 30, 2019, 07:20:06 PM »
thanks Kirk,

Have sent you a PM

Cheers...