Author Topic: PM 6 is significantly slower than PM 5  (Read 1505 times)

Offline Hobbo

  • Newcomer
  • *
  • Posts: 1
    • View Profile
PM 6 is significantly slower than PM 5
« on: March 26, 2019, 10:55:50 AM »
Hello,

I'm not enthusiastic about the speed. I have build 6R2725 running as a demo here and it is much slower than the last 5 version (build 5R19749). If I click through images with a resolution of about 12 Mio pixels in the 5er version, it works without any dropouts. If I do the same in the 6er version, the pictures come slower one after the other and the last ones are without sharp representation.


It was promised that the 6er version is "Faster, Faster, Faster". I can't confirm that.

I'm a bit disappointed and won't buy the 6 version for now. The version should be at least as fast as the 5.

By the way, the search field is missing. To search in the catalog or in the whole data system I fan very helpful. It's a pity that the function has been omitted.

Best regards, Holger

Mac OS Mojave, iMac 27", 2017, 4.2 GHz, Radeon Pro 580, 40 GB RAM, Photos from SSD

Offline Bill Kelly

  • Software Developer
  • Camera Bits Staff
  • Member
  • *****
  • Posts: 59
    • View Profile
    • Camera Bits, Inc.
Re: PM 6 is significantly slower than PM 5
« Reply #1 on: March 26, 2019, 01:42:21 PM »
Hi,

I'm not enthusiastic about the speed. I have build 6R2725 running as a demo here and it is much slower than the last 5 version (build 5R19749). If I click through images with a resolution of about 12 Mio pixels in the 5er version, it works without any dropouts. If I do the same in the 6er version, the pictures come slower one after the other and the last ones are without sharp representation.

We've seen a handful of reports of PM6 being unexpectedly slow. Identifying and fixing the problem is a top priority.

Related threads, for reference:

  http://forums.camerabits.com/index.php?topic=11907.msg58148#msg58148
  http://forums.camerabits.com/index.php?topic=11890.msg58086#msg58086


By the way, the search field is missing. To search in the catalog or in the whole data system I fan very helpful. It's a pity that the function has been omitted.

Related topic:

  http://forums.camerabits.com/index.php?topic=11900.msg58122#msg58122


Regards,

Bill



Offline Pompo

  • Member
  • **
  • Posts: 66
    • View Profile
    • Alfonso Bresciani
Re: PM 6 is significantly slower than PM 5
« Reply #2 on: March 26, 2019, 07:21:09 PM »
yes, here too! I have  a new 10 core with 64 gigs of RAM but....

 Hardware Overview:

  Model Name:   iMac Pro
  Model Identifier:   iMacPro1,1
  Processor Name:   Intel Xeon W
  Processor Speed:   3 GHz
  Number of Processors:   1
  Total Number of Cores:   10
  L2 Cache (per Core):   1 MB
  L3 Cache:   13.8 MB
  Memory:   64 GB
  Boot ROM Version:   220.240.2.0.0 (iBridge: 16.16.3133.0.0,0)
  Serial Number (system):   C02VT0L8JLCN
  Hardware UUID:   7FFA2669-2332-5C16-853A-55068971FD1F



Hello,

I'm not enthusiastic about the speed. I have build 6R2725 running as a demo here and it is much slower than the last 5 version (build 5R19749). If I click through images with a resolution of about 12 Mio pixels in the 5er version, it works without any dropouts. If I do the same in the 6er version, the pictures come slower one after the other and the last ones are without sharp representation.


It was promised that the 6er version is "Faster, Faster, Faster". I can't confirm that.

I'm a bit disappointed and won't buy the 6 version for now. The version should be at least as fast as the 5.

By the way, the search field is missing. To search in the catalog or in the whole data system I fan very helpful. It's a pity that the function has been omitted.

Best regards, Holger

Mac OS Mojave, iMac 27", 2017, 4.2 GHz, Radeon Pro 580, 40 GB RAM, Photos from SSD

Offline Bob350

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Re: PM 6 is significantly slower than PM 5
« Reply #3 on: March 26, 2019, 09:52:37 PM »
On my system, PM 6 opens faster than PM 5. Also, display of thumbnails after selecting a folder is much faster. Double click a thumbnail to opens the larger view much faster. Then moving from image to image using arrow keys is also much faster. Have not yet tested all program functionality, but thought these observations might help pin down what is going on for others.

Windows 10 Pro 64-bit (10.0, Build 17134)
Processor: Intel(R) Core(TM) i7-4930K CPU @ 3.40GHz (12 CPUs), ~3.4GHz
Memory: 32768MB RAM
Card name: NVIDIA Quadro K2000D
Current Mode: 1600 x 1024 (32 bit) (60Hz)

Offline Perttis

  • Newcomer
  • *
  • Posts: 19
    • View Profile
Re: PM 6 is significantly slower than PM 5
« Reply #4 on: March 30, 2019, 06:17:25 AM »
I did small test to compare PM5 to PM6.
I have external drive , there is folder and 21 subfolders. That folder structure contains 12000 pictures(mix of NEF raw and JPG)

Having settings at PM´s same, using sort order "capture time"
 
Opening with PM5 takes about 5 min (several runs)
Opening with PM6 takes about 22 seconds (several runs)
(clear caches between doesn´t affect much PM6, but PM 5 doubles the time)
I think this is quite impressive gains.

Offline retief

  • Newcomer
  • *
  • Posts: 34
    • View Profile
Re: PM 6 is significantly slower than PM 5
« Reply #5 on: March 30, 2019, 10:53:34 AM »
I have just installed on 1 desktop, 1 Microsoft Surface 2017 and one HP Laptop. 

The Desktop is a Cell XPS 8900, i7-6700 with 16GB Ram.  I believe the Surface and Laptop are i5 with 8GB.  The Surface and Laptop connect wi-fi to my network, using mapped drives to the Desktop.

All 3 are much faster than PM5, most noticeable when browsing images over the network.

Windows versions 10.0.17134

Offline timesnaps

  • Newcomer
  • *
  • Posts: 33
    • View Profile
Re: PM 6 is significantly slower than PM 5
« Reply #6 on: March 31, 2019, 11:43:46 AM »
I think this is quite impressive gains.

I would like to royally agree! increase in speed is ...well, INSANE. I am in the process of organising over 35000 images, and need them all open at once.They are in numerous subfolders (about 25 in total). PM5 was taking around 5-15min to just have them all ready for display (after the initial opening of the sheet). It was also painfully slow when going back to thumbnails after I had to open one image full size. Took again around 5min or so to just be able to scroll through more thumbnails.

Obviously it seems the speed increase is not being noticed by everyone. But I can tell you it's there, once the bugs are resolved