Author Topic: PM6 isn't erasing Source Disk after Ingest  (Read 826 times)

Offline antpix2000

  • Newcomer
  • *
  • Posts: 5
    • View Profile
PM6 isn't erasing Source Disk after Ingest
« on: April 04, 2019, 04:27:08 PM »
Hi,

Liking PM 6 however I've found that it's not erasing the source disk after ingest, even though the button is checked.

I did a confirmation on my still installed PM5, build 19742 (41dbaeb) which has erased the same cards after PM6 build 2725 (1d89a41), didn't, several times.

Not seen any other reports of this, so it might be my set up, however it is repeatable on my machine, OS 10.12.6 (16G1815), MacBook Air (11-inch, Early 2015), 2.2 GHz Intel Core i7, Intel HD Graphics 6000 1536 MB, using Sandisk 32GB, two different CF cards on two different readers, same problem

Any suggestions?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21337
    • View Profile
    • Camera Bits, Inc.
Re: PM6 isn't erasing Source Disk after Ingest
« Reply #1 on: April 04, 2019, 04:40:23 PM »
Hi,

Liking PM 6 however I've found that it's not erasing the source disk after ingest, even though the button is checked.

I did a confirmation on my still installed PM5, build 19742 (41dbaeb) which has erased the same cards after PM6 build 2725 (1d89a41), didn't, several times.

Not seen any other reports of this, so it might be my set up, however it is repeatable on my machine, OS 10.12.6 (16G1815), MacBook Air (11-inch, Early 2015), 2.2 GHz Intel Core i7, Intel HD Graphics 6000 1536 MB, using Sandisk 32GB, two different CF cards on two different readers, same problem

Any suggestions?

I'd like to see your Photo Mechanic log.  In Photo Mechanic go to the Help menu and choose "Reveal Support Data..." and moments later a Finder window will come forward with the zipped log file selected.  Use the 'Attachments and other options' link when you're composing your reply to this message and there you'll be able to upload your zipped PM log file.

Thanks,

-Kirk

Offline antpix2000

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: PM6 isn't erasing Source Disk after Ingest
« Reply #2 on: April 04, 2019, 11:40:16 PM »
Kirk,

Thanks for the quick reply.

See attached.

Cheers

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21337
    • View Profile
    • Camera Bits, Inc.
Re: PM6 isn't erasing Source Disk after Ingest
« Reply #3 on: April 05, 2019, 06:34:24 PM »
Looks like a permissions problem.  Are you able to delete files on the card yourself?  If you can't delete them then neither will PM be able to do so.

-Kirk

Offline antpix2000

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: PM6 isn't erasing Source Disk after Ingest
« Reply #4 on: April 05, 2019, 10:08:55 PM »
Not tried that as I was able to get PM5 to delete the files automatically, so I'm pretty sure its a PM6 issue, rather than a Card Permissions issue if that is what you are thinking.

Also when I Alt-Tab between Applications, although PM6 is the front application, if another PM window is open, the Browser Grid window doesn't show and has to be called up via the Window Menu. The Tasks window does show as expected but not the Browser. This also happens when I select PM via the Task Bar in the OS.

Cmd - Tilde doesn't bring up the Browser Grid either.

Again this appears to be different behaviour to PM5.

Cheers

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21337
    • View Profile
    • Camera Bits, Inc.
Re: PM6 isn't erasing Source Disk after Ingest
« Reply #5 on: April 05, 2019, 10:29:36 PM »
Not tried that as I was able to get PM5 to delete the files automatically, so I'm pretty sure its a PM6 issue, rather than a Card Permissions issue if that is what you are thinking.

Also when I Alt-Tab between Applications, although PM6 is the front application, if another PM window is open, the Browser Grid window doesn't show and has to be called up via the Window Menu. The Tasks window does show as expected but not the Browser. This also happens when I select PM via the Task Bar in the OS.

Cmd - Tilde doesn't bring up the Browser Grid either.

Is the Contact Sheet window (I think this is what you're calling a Browser Grid) obscured by another window or is it just missing?

-Kirk

Offline antpix2000

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: PM6 isn't erasing Source Disk after Ingest
« Reply #6 on: April 06, 2019, 10:03:31 AM »
OK, I don't seem to be able to reproduce that at the moment!!! However previously, it was just missing, just the upload progress window, if it had been open before and I'd have to call it up via the Window Menu.

Sorry if it has been a red herring, I'll let you know if it happens again

Do you any info on the erasing on ingest issue? Which is actually the main issue for me. Thanks

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21337
    • View Profile
    • Camera Bits, Inc.
Re: PM6 isn't erasing Source Disk after Ingest
« Reply #7 on: April 06, 2019, 10:41:43 AM »
OK, I don't seem to be able to reproduce that at the moment!!! However previously, it was just missing, just the upload progress window, if it had been open before and I'd have to call it up via the Window Menu.

Sorry if it has been a red herring, I'll let you know if it happens again

Do you any info on the erasing on ingest issue? Which is actually the main issue for me. Thanks

We'll need to find a way to reproduce it locally.

-Kirk

Offline antpix2000

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: PM6 isn't erasing Source Disk after Ingest
« Reply #8 on: April 06, 2019, 11:51:48 AM »
Thanks for looking into it, much appreciated.

Cheers