Author Topic: PM6+ slideshow stops on some images  (Read 609 times)

Offline Warren B

  • Jr. Member
  • **
  • Posts: 58
    • View Profile
PM6+ slideshow stops on some images
« on: May 10, 2019, 10:56:12 PM »
Select 12 or 15 images to be viewed in slideshow with Slideshow Settings: {captions}, Number of Lines 2, Font size: 14, Font: Arial, Alignment: Center, Transitions: Fade In/Pop Out, 7 Seconds. Previous images perform o.k. but the slideshow stops at these two images (attached) IMG_2048A, IMG_2113A each time. PM6+ Log File with reported errors attached as well.

Warren
Win 10, i7-8086K, 16GB RAM, PM6+ Build 3126

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 19755
    • View Profile
    • Camera Bits, Inc.
Re: PM6+ slideshow stops on some images
« Reply #1 on: May 11, 2019, 06:56:29 AM »
Warren,

Select 12 or 15 images to be viewed in slideshow with Slideshow Settings: {captions}, Number of Lines 2, Font size: 14, Font: Arial, Alignment: Center, Transitions: Fade In/Pop Out, 7 Seconds. Previous images perform o.k. but the slideshow stops at these two images (attached) IMG_2048A, IMG_2113A each time. PM6+ Log File with reported errors attached as well.

Stops as in: Crashes?  Exits?

-Kirk

Offline Warren B

  • Jr. Member
  • **
  • Posts: 58
    • View Profile
Re: PM6+ slideshow stops on some images
« Reply #2 on: May 12, 2019, 01:24:16 PM »
Warren,

Select 12 or 15 images to be viewed in slideshow with Slideshow Settings: {captions}, Number of Lines 2, Font size: 14, Font: Arial, Alignment: Center, Transitions: Fade In/Pop Out, 7 Seconds. Previous images perform o.k. but the slideshow stops at these two images (attached) IMG_2048A, IMG_2113A each time. PM6+ Log File with reported errors attached as well.

Stops as in: Crashes?  Exits?

-Kirk

Image hangs, slideshow will not advance any further.

Warren
Win 10, i7-8086K, 16GB RAM, PM+ Build 3126

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 19755
    • View Profile
    • Camera Bits, Inc.
Re: PM6+ slideshow stops on some images
« Reply #3 on: May 12, 2019, 02:13:49 PM »
Warren,

Select 12 or 15 images to be viewed in slideshow with Slideshow Settings: {captions}, Number of Lines 2, Font size: 14, Font: Arial, Alignment: Center, Transitions: Fade In/Pop Out, 7 Seconds. Previous images perform o.k. but the slideshow stops at these two images (attached) IMG_2048A, IMG_2113A each time. PM6+ Log File with reported errors attached as well.

Stops as in: Crashes?  Exits?

Image hangs, slideshow will not advance any further.

Warren
Win 10, i7-8086K, 16GB RAM, PM+ Build 3126

If you press the right arrow key to advance, will it continue?

-Kirk

Offline Warren B

  • Jr. Member
  • **
  • Posts: 58
    • View Profile
Re: PM6+ slideshow stops on some images
« Reply #4 on: May 13, 2019, 01:43:12 AM »
Warren,

Select 12 or 15 images to be viewed in slideshow with Slideshow Settings: {captions}, Number of Lines 2, Font size: 14, Font: Arial, Alignment: Center, Transitions: Fade In/Pop Out, 7 Seconds. Previous images perform o.k. but the slideshow stops at these two images (attached) IMG_2048A, IMG_2113A each time. PM6+ Log File with reported errors attached as well.

Stops as in: Crashes?  Exits?

Image hangs, slideshow will not advance any further.

Warren
Win 10, i7-8086K, 16GB RAM, PM+ Build 3126

If you press the right arrow key to advance, will it continue?

-Kirk

No, I tried that and the photo just hangs, it won't budge, left or right. Occasionally when starting a slideshow a white square on a black screen will appear (see attached photo) and the slideshow will not proceed.

I've changed fade-in's, etc. that doesn't seem to make a difference either. Photo's taken with the same model camera seem to work flawlessly, but mixed camera models get stuck, at least that's what's happening here.

Warren
Win 10, i7-8086K, 16GB RAM, PM+ Build 3126

Offline Warren B

  • Jr. Member
  • **
  • Posts: 58
    • View Profile
Re: PM6+ slideshow stops on some images
« Reply #5 on: May 13, 2019, 02:38:57 AM »
Warren,

Select 12 or 15 images to be viewed in slideshow with Slideshow Settings: {captions}, Number of Lines 2, Font size: 14, Font: Arial, Alignment: Center, Transitions: Fade In/Pop Out, 7 Seconds. Previous images perform o.k. but the slideshow stops at these two images (attached) IMG_2048A, IMG_2113A each time. PM6+ Log File with reported errors attached as well.

Stops as in: Crashes?  Exits?

Image hangs, slideshow will not advance any further.

Warren
Win 10, i7-8086K, 16GB RAM, PM+ Build 3126

If you press the right arrow key to advance, will it continue?

-Kirk

No, I tried that and the photo just hangs, it won't budge, left or right. Occasionally when starting a slideshow a white square on a black screen will appear (see attached photo) and the slideshow will not proceed.

I've changed fade-in's, etc. that doesn't seem to make a difference either. Photo's taken with the same model camera seem to work flawlessly, but mixed camera models get stuck, at least that's what's happening here.

Warren
Win 10, i7-8086K, 16GB RAM, PM+ Build 3126

Correction: Though an image that is hung in PM6+'s slideshow will not advance by using the keyboard right-arrow key, it will in most cases go back to the previous image using the left-arrow key. At least that's the way it is here.

Warren
Win 10, i7-8086K, 16GB RAM, PM+ Build 3126

Offline Warren B

  • Jr. Member
  • **
  • Posts: 58
    • View Profile
Re: PM6+ slideshow stops on some images
« Reply #6 on: May 13, 2019, 03:47:55 AM »
Warren,

Select 12 or 15 images to be viewed in slideshow with Slideshow Settings: {captions}, Number of Lines 2, Font size: 14, Font: Arial, Alignment: Center, Transitions: Fade In/Pop Out, 7 Seconds. Previous images perform o.k. but the slideshow stops at these two images (attached) IMG_2048A, IMG_2113A each time. PM6+ Log File with reported errors attached as well.

Stops as in: Crashes?  Exits?

Image hangs, slideshow will not advance any further.

Warren
Win 10, i7-8086K, 16GB RAM, PM+ Build 3126

If you press the right arrow key to advance, will it continue?

-Kirk

FWIW: PM6 (not Plus) slideshow works flawlessly, even the left and right keyboard arrow keys work without fail.

Warren
Win 10, i7-8086K, 16GB RAM, PM+ Build 3126

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 19755
    • View Profile
    • Camera Bits, Inc.
Re: PM6+ slideshow stops on some images
« Reply #7 on: May 13, 2019, 08:25:07 PM »
Warren,

I have downloaded and mixed your two photos in with some of my photos and the slideshow plays all of the images without fail--slideshow makes it to the end and exits normally.

Perhaps if I had one of your other images that lead into these two, then I could get the problem to happen?

Thanks,

-Kirk

Offline Warren B

  • Jr. Member
  • **
  • Posts: 58
    • View Profile
Re: PM6+ slideshow stops on some images
« Reply #8 on: May 14, 2019, 09:16:36 PM »
Warren,

I have downloaded and mixed your two photos in with some of my photos and the slideshow plays all of the images without fail--slideshow makes it to the end and exits normally.

Perhaps if I had one of your other images that lead into these two, then I could get the problem to happen?

Thanks,

-Kirk

Hi Kirk,

Attached are two more photos that hang in my PM6+ slideshow, they will probably work just fine on your system but they don't on mine. The two photos and all of my other photos work fine in my PM 6.0 (not Plus) slideshow. So I've also attached my PM-log.zip file which shows, I think, what may be causing the problem on my computer system.

Thanks,

Warren
Win 10, i7-8086K, 16GB RAM, PM+ Build 3126

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 19755
    • View Profile
    • Camera Bits, Inc.
Re: PM6+ slideshow stops on some images
« Reply #9 on: May 14, 2019, 11:43:54 PM »
Warren,

I have downloaded and mixed your two photos in with some of my photos and the slideshow plays all of the images without fail--slideshow makes it to the end and exits normally.

Perhaps if I had one of your other images that lead into these two, then I could get the problem to happen?

Attached are two more photos that hang in my PM6+ slideshow, they will probably work just fine on your system but they don't on mine. The two photos and all of my other photos work fine in my PM 6.0 (not Plus) slideshow. So I've also attached my PM-log.zip file which shows, I think, what may be causing the problem on my computer system.

There is nothing in your PM.log related to the slideshow.  Those iTXt: CRC errors are just warnings and shouldn't affect the slideshow.

The latest PM6 build is now using the same slideshow as PM6+ so I expect the problem you're having will now happen on PM6.

-Kirk

Offline LarsN

  • Newcomer
  • *
  • Posts: 17
    • View Profile
Re: PM6+ slideshow stops on some images
« Reply #10 on: May 15, 2019, 01:25:54 AM »
Kirk,

I have the same problem on my iMac; OS10.14.4; PM6+ beta 3, and now also with the new build of PM6 (3143).

Yesterday I tested on both programs with no problem with PM6. With the new build I have problem with the same files as I had yesterday with PM6+.

Running a slide show with raw files is working 100%. Some of the jpg files from these same raw files hang. The jpg files are mostly developed in DxO PhotoLab 2

Lars
« Last Edit: May 15, 2019, 03:09:33 AM by LarsN »

Offline bazography

  • Full Member
  • ***
  • Posts: 142
    • View Profile
Re: PM6+ slideshow stops on some images
« Reply #11 on: May 17, 2019, 04:28:17 PM »
macOS Mojave
MacBook Pro (mid 2012)

I've also found multiple slideshow issues in PM6+ and PM6.

1. Same as discussed above with slideshow not advancing using right arrow. Will usually go back with left arrow, but not always.
2. Occasionally when clicking START, the screen will go black but no pictures come up at all.
3. During a slideshow, if I press the F key to leave full-screen mode, the photo displays correctly but any metadata I've chosen to display will disappear. Then, if I press F again to go to full-screen mode, I get a tiny image with some partly-visible text (samples attached).
4. On 1 occasion PM6+ crashed (quit completely) while testing the above.
5. Minor detail here... but if I remember correctly from PM5, wasn't the START button highlighted when you brought up the slideshow pop-up? That was nice as it allows you to very quickly just hit Command-L + Enter to start a slideshow rather than mousing over to the START button.

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 19755
    • View Profile
    • Camera Bits, Inc.
Re: PM6+ slideshow stops on some images
« Reply #12 on: May 17, 2019, 05:48:21 PM »
macOS Mojave
MacBook Pro (mid 2012)

I've also found multiple slideshow issues in PM6+ and PM6.

1. Same as discussed above with slideshow not advancing using right arrow. Will usually go back with left arrow, but not always.
2. Occasionally when clicking START, the screen will go black but no pictures come up at all.
3. During a slideshow, if I press the F key to leave full-screen mode, the photo displays correctly but any metadata I've chosen to display will disappear. Then, if I press F again to go to full-screen mode, I get a tiny image with some partly-visible text (samples attached).

The transition from full screen to windowed could certainly be improved.

4. On 1 occasion PM6+ crashed (quit completely) while testing the above.[/quote]

Please provide me a set of images that reproduces the problem.  I will be more than happy to fix the problem.

5. Minor detail here... but if I remember correctly from PM5, wasn't the START button highlighted when you brought up the slideshow pop-up? That was nice as it allows you to very quickly just hit Command-L + Enter to start a slideshow rather than mousing over to the START button.

Because we made it easy to enter multiple lines, the keyboard shortcut to start the slideshow had to be changed.  If you hover your mouse over the button then you'll see the new keyboard shortcut.  Command-Option-L will bypass the dialog completely and start the Slideshow straight away.

Thanks,

-Kirk

Offline Warren B

  • Jr. Member
  • **
  • Posts: 58
    • View Profile
Re: PM6+ slideshow stops on some images
« Reply #13 on: May 18, 2019, 06:34:33 AM »
macOS Mojave
MacBook Pro (mid 2012)

I've also found multiple slideshow issues in PM6+ and PM6.

1. Same as discussed above with slideshow not advancing using right arrow. Will usually go back with left arrow, but not always.
2. Occasionally when clicking START, the screen will go black but no pictures come up at all.
3. During a slideshow, if I press the F key to leave full-screen mode, the photo displays correctly but any metadata I've chosen to display will disappear. Then, if I press F again to go to full-screen mode, I get a tiny image with some partly-visible text (samples attached).
4. On 1 occasion PM6+ crashed (quit completely) while testing the above.
5. Minor detail here... but if I remember correctly from PM5, wasn't the START button highlighted when you brought up the slideshow pop-up? That was nice as it allows you to very quickly just hit Command-L + Enter to start a slideshow rather than mousing over to the START button.

The slideshow in the first PM6+ beta worked perfectly for me. I rated and color classed approx. 5 hundred images while the slideshow was running and it was a great timesaver. It functioned perfectly without any problems whatsoever. I don't recall using it in beta 2 so I can't comment on that.

It was when beta 3 was introduced that things changed for the worse and became dysfunctional for me. Sometimes on launching slideshow just a plain black window appears and it just hangs. Other times upon launch the same black window with a large white square in the upper-left section of the windows appears and then hangs. I uploaded a small screenshot of that in one of my previous posts. Then when the slideshow does run the problems with the images hanging, etc. as we've described occur.

I still use PM6 (not Plus) and purposely have not updated to the new build. The slideshow PM6 build 3023 works beautifully, with no problems whatsoever. All of my images that stalled in PM6+ do not hang in PM6. Not being able to rate, color class or tag images while operating is its only liability.

Warren
Win 10, i7-8086K, 16GB RAM, PM6+ Build 3126


Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 19755
    • View Profile
    • Camera Bits, Inc.
Re: PM6+ slideshow stops on some images
« Reply #14 on: May 18, 2019, 07:24:17 AM »
Warren,

macOS Mojave
MacBook Pro (mid 2012)

I've also found multiple slideshow issues in PM6+ and PM6.

1. Same as discussed above with slideshow not advancing using right arrow. Will usually go back with left arrow, but not always.
2. Occasionally when clicking START, the screen will go black but no pictures come up at all.
3. During a slideshow, if I press the F key to leave full-screen mode, the photo displays correctly but any metadata I've chosen to display will disappear. Then, if I press F again to go to full-screen mode, I get a tiny image with some partly-visible text (samples attached).
4. On 1 occasion PM6+ crashed (quit completely) while testing the above.
5. Minor detail here... but if I remember correctly from PM5, wasn't the START button highlighted when you brought up the slideshow pop-up? That was nice as it allows you to very quickly just hit Command-L + Enter to start a slideshow rather than mousing over to the START button.

The slideshow in the first PM6+ beta worked perfectly for me. I rated and color classed approx. 5 hundred images while the slideshow was running and it was a great timesaver. It functioned perfectly without any problems whatsoever. I don't recall using it in beta 2 so I can't comment on that.

It was when beta 3 was introduced that things changed for the worse and became dysfunctional for me. Sometimes on launching slideshow just a plain black window appears and it just hangs. Other times upon launch the same black window with a large white square in the upper-left section of the windows appears and then hangs. I uploaded a small screenshot of that in one of my previous posts. Then when the slideshow does run the problems with the images hanging, etc. as we've described occur.

I still use PM6 (not Plus) and purposely have not updated to the new build. The slideshow PM6 build 3023 works beautifully, with no problems whatsoever. All of my images that stalled in PM6+ do not hang in PM6. Not being able to rate, color class or tag images while operating is its only liability.

Warren
Win 10, i7-8086K, 16GB RAM, PM6+ Build 3126

If you have some time next week, I'll get you some builds with logging in them to try and find out what's going on.  I can't undo the changes made to the Slideshow because they address some crashing issues that some users were experiencing.  But it should be possible to address the new problem that you're having.

Please let me know if you can help, Warren.

-Kirk