Author Topic: Two Problems: Unmount source disk and apply metadata template  (Read 432 times)

Offline photobear

  • Newcomer
  • *
  • Posts: 25
    • View Profile
I am using Photo Mechanic Version 6.0, build 3143 (3bc32e6) with Mac Mojave 10.14.5. I have always have "unmount source disk after ingest" and "apply Metadata template on photos" checked in the ingest panel. Now all of a sudden, the source disk is not being unmounted after ingest, and the metadate is not being applied to my photos on ingest.

Any help?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: Two Problems: Unmount source disk and apply metadata template
« Reply #1 on: May 29, 2019, 08:38:15 AM »
I am using Photo Mechanic Version 6.0, build 3143 (3bc32e6) with Mac Mojave 10.14.5. I have always have "unmount source disk after ingest" and "apply Metadata template on photos" checked in the ingest panel. Now all of a sudden, the source disk is not being unmounted after ingest, and the metadate is not being applied to my photos on ingest.

Any help?

What kind of camera card are you working with?

-Kirk

Offline photobear

  • Newcomer
  • *
  • Posts: 25
    • View Profile
Re: Two Problems: Unmount source disk and apply metadata template
« Reply #2 on: May 29, 2019, 10:49:50 AM »
SanDisk Extreme Pro, 32GB, UDMA 7.  Same card I always use.

Offline photobear

  • Newcomer
  • *
  • Posts: 25
    • View Profile
Re: Two Problems: Unmount source disk and apply metadata template
« Reply #3 on: May 29, 2019, 11:44:34 AM »
Here's what's happening. When I insert my disc into my computer via the card reader, nothing happens. I open PM6 and go to ingest, and ingest the photos. A contact sheet opens, but the disc does not unmount, the template doesn't get applied to the images and no folder with my images is created on the desktop. So, the images are showing on the contact sheet but they aren't actually being downloaded.

When I try to manually unmount the disc by dragging the disk icon to the trash, I get this warning, where it says "the disc couldn't be ejected because Photo Mechanic 6 is using it."

Then, if I just remove the disc from the card reader, I get this warning: "Disc Not Ejected Properly" and the images disappear from the contact sheet.

When I reinsert the disc into the card reader, the contact sheet opens, a folder is created with the images, and the source disc is unmounted automatically, which it should have done in the first place.

I've been using PM for years, and I have no idea why this is happening. It just started.

Offline photobear

  • Newcomer
  • *
  • Posts: 25
    • View Profile
Re: Two Problems: Unmount source disk and apply metadata template
« Reply #4 on: May 29, 2019, 12:58:07 PM »
Kirk,

Found out what the problem is! If I mount the disc and then launch PM, the ingest doesn't work properly for me, as shown above. But if I launch PM first and THEN mount the disc, then do a manual ingest, it works fine.

Not sure why, but as long it's working now I'm good.

Thanks!

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: Two Problems: Unmount source disk and apply metadata template
« Reply #5 on: May 29, 2019, 01:35:05 PM »
SanDisk Extreme Pro, 32GB, UDMA 7.  Same card I always use.

Is it a CFast, Compact Flash, SD, etc.?  Which type of card is it?

-Kirk

Offline photobear

  • Newcomer
  • *
  • Posts: 25
    • View Profile
Re: Two Problems: Unmount source disk and apply metadata template
« Reply #6 on: May 29, 2019, 02:28:55 PM »
CompactFlash