Author Topic: Problem with Navigator and External Drive  (Read 644 times)

Offline JamesG

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Problem with Navigator and External Drive
« on: June 02, 2019, 12:49:21 PM »
Hello. I upgraded from Version 5 to Photo Mechanic Version 6.0, build 3143 (3bc32e6) on my iMac running MacOS Mojave 10.14.5 (18F132) and have encountered a problem with the PM Navigator. When attempting to access my photo files (/Photos-Media/My Pictures) on my external drive, I click on the down arrow to expand the view and the list of subfolders flashes and disappears. The system worked great with Version 5. If I use the drop-down window menu to "Open Recent" I can open listed subfolders and view their content. If I use Navigator to select and access folders, subfolders and files on the iMac's internal drive, it works fine. But it's the external drive that's an issue. I've reinstalled Version 6 with no change in behavior. Any ideas?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20622
    • View Profile
    • Camera Bits, Inc.
Re: Problem with Navigator and External Drive
« Reply #1 on: June 02, 2019, 02:42:06 PM »
Hello. I upgraded from Version 5 to Photo Mechanic Version 6.0, build 3143 (3bc32e6) on my iMac running MacOS Mojave 10.14.5 (18F132) and have encountered a problem with the PM Navigator. When attempting to access my photo files (/Photos-Media/My Pictures) on my external drive, I click on the down arrow to expand the view and the list of subfolders flashes and disappears. The system worked great with Version 5. If I use the drop-down window menu to "Open Recent" I can open listed subfolders and view their content. If I use Navigator to select and access folders, subfolders and files on the iMac's internal drive, it works fine. But it's the external drive that's an issue. I've reinstalled Version 6 with no change in behavior. Any ideas?

I'd like to see your Photo Mechanic log.  In Photo Mechanic go to the Help menu and choose "Reveal Support Data..." and moments later a Finder window will come forward with the zipped log file selected.  Use the 'Attachments and other options' link when you're composing your reply to this message and there you'll be able to upload your zipped PM log file.

Thanks,

-Kirk

Offline JamesG

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Problem with Navigator and External Drive
« Reply #2 on: June 02, 2019, 04:54:34 PM »
Thanks! Attached is my PM Support Data; I made an attempt to access the problematic external drive and immediately created the support file.  -- JG

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20622
    • View Profile
    • Camera Bits, Inc.
Re: Problem with Navigator and External Drive
« Reply #3 on: June 02, 2019, 05:27:25 PM »
Thanks! Attached is my PM Support Data; I made an attempt to access the problematic external drive and immediately created the support file.  -- JG

Unfortunately nothing specific to your problem was logged.

OK.  I'm going to have you turn on some additional logging.  You need to create a plain text file named PMDebug.txt and it has to be in PM's Preferences folder.

PM's Preferences folder will be in the following location:

~/Library/Preferences/com.camerabits.PhotoMechanic/

Unfortunately Apple decided a few OS versions ago to hide the Library folder within your home folder.  You can still get there though by using the "Go to Folder..." command on the Go menu in the finder.  Enter the path above in the dialog that appears.

Create your PMDebug.txt file there and make it have the following contents:

SHOW_NAV_FAV_DIRSCAN_FILTER ON
FILESYSTEMCACHE_LOGGING ON
NAVIGATOR_LOGGING ON
NAVIGATOR_VOLUME_LOGGING ON

Save the file and relaunch PM6 and try to expand the My Pictures folder.  You can then use the "Reveal Support Data..." command on the Help menu to get the updated zipped log file.  Please post the file here.

Thanks,

-Kirk

Offline JamesG

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Problem with Navigator and External Drive
« Reply #4 on: June 02, 2019, 05:47:31 PM »
Okay, here's the latest, hopefully with debug info....

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20622
    • View Profile
    • Camera Bits, Inc.
Re: Problem with Navigator and External Drive
« Reply #5 on: June 02, 2019, 08:41:47 PM »
James,

Interesting.  What kind of disk is Photos Media?

It's acting like each time PM checks for the modification date of the various folders, they're always changing and must be read again.  Do you happen to have more than one thousand folders in that My Pictures folder?

-Kirk

Offline JamesG

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Problem with Navigator and External Drive
« Reply #6 on: June 03, 2019, 06:42:20 AM »
Hello again.

The external drive is a LaCie Porsche Design model. It has worked well through PM Version 5. When the PM issue cropped up, I ran Apple's Disk Utility and encountered no issues.

The drive holds 1,371 subfolders containing my photographic image files.

There are more than 64,000 image files.

-- JG

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20622
    • View Profile
    • Camera Bits, Inc.
Re: Problem with Navigator and External Drive
« Reply #7 on: June 03, 2019, 09:08:20 AM »
James,

The external drive is a LaCie Porsche Design model. It has worked well through PM Version 5. When the PM issue cropped up, I ran Apple's Disk Utility and encountered no issues.

The drive holds 1,371 subfolders containing my photographic image files.

Thanks.  I now know for certain what the problem is and will fix it.  Would you be willing to try a non-official build and see if it fixes your problem?

-Kirk

Offline JamesG

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Problem with Navigator and External Drive
« Reply #8 on: June 03, 2019, 11:24:26 AM »
Yes, I would be happy to try that; PM is much more useful to me when the Navigator is working!

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20622
    • View Profile
    • Camera Bits, Inc.
Re: Problem with Navigator and External Drive
« Reply #9 on: June 03, 2019, 05:31:29 PM »
James,

Please try this build: https://www.camerabits.com/download/PhotoMechanic6R3233.dmg

Thanks,

-Kirk

Offline JamesG

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Problem with Navigator and External Drive
« Reply #10 on: June 03, 2019, 05:48:49 PM »
Yes! That resolved the issue! Thank you so much for fixing this; I love PhotoMechanic and I'm delighted to have the updated version working the way it should! -- JamesG

Question: Will this fix be incorporated in future releases or should I watch out for updates that might break it again?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20622
    • View Profile
    • Camera Bits, Inc.
Re: Problem with Navigator and External Drive
« Reply #11 on: June 03, 2019, 06:01:26 PM »
James,

Yes! That resolved the issue! Thank you so much for fixing this; I love PhotoMechanic and I'm delighted to have the updated version working the way it should! -- JamesG

Question: Will this fix be incorporated in future releases or should I watch out for updates that might break it again?

The fix is definitely going to be in the next release and all subsequent releases.

Thanks for testing and responding so quickly!

-Kirk

Offline JamesG

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Problem with Navigator and External Drive
« Reply #12 on: June 03, 2019, 07:13:11 PM »
Excellent! Good to know. Thanks, again. -- JamesG