Author Topic: Proxie images not colour managed  (Read 748 times)

Offline bazography

  • Full Member
  • ***
  • Posts: 189
    • View Profile
Proxie images not colour managed
« on: June 03, 2019, 04:39:56 PM »
While testing PM+ I’ve been keeping images on a networked drive and the catalog located locally, and to see how the proxies worked I shut the drive off. The proxies take over as expected but the colour is nasty. It seems that proxies are not colour managed. In my Preferences, colour manage thumbnails and previews are both turned on.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21350
    • View Profile
    • Camera Bits, Inc.
Re: Proxie images not colour managed
« Reply #1 on: June 03, 2019, 05:15:36 PM »
While testing PM+ I’ve been keeping images on a networked drive and the catalog located locally, and to see how the proxies worked I shut the drive off. The proxies take over as expected but the colour is nasty. It seems that proxies are not colour managed. In my Preferences, colour manage thumbnails and previews are both turned on.

Screenshot, please?

Also, what color profile do you have set as default for images that do not have an embedded profile?  (Preferences->Color Management)

Use the 'Attachments and other options' link when you're composing your reply to this message and there you'll be able to upload your JPEG format screenshot.

Thanks,

-Kirk

Offline bazography

  • Full Member
  • ***
  • Posts: 189
    • View Profile
Re: Proxie images not colour managed
« Reply #2 on: June 04, 2019, 01:27:47 AM »
While testing PM+ I’ve been keeping images on a networked drive and the catalog located locally, and to see how the proxies worked I shut the drive off. The proxies take over as expected but the colour is nasty. It seems that proxies are not colour managed. In my Preferences, colour manage thumbnails and previews are both turned on.

Screenshot, please?

Also, what color profile do you have set as default for images that do not have an embedded profile?  (Preferences->Color Management)

Use the 'Attachments and other options' link when you're composing your reply to this message and there you'll be able to upload your JPEG format screenshot.

Thanks,

-Kirk

The default ICC profile preference is set to "no default profile". I can change it but it doesn't really solve the issue. If I set the default to "Adobe RGB" and I happen to be looking at proxies for images that have an Adobe RGB profile, then the colour looks correct. But then images that use a different profile don't display properly.

I see that proxies are not saved with an embedded profile... shouldn't they retain the profile of the original image?

Here's a screenshot with the actual images, and one with the proxies.

(PM+ 3215, MacBook Pro, Mojave)

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21350
    • View Profile
    • Camera Bits, Inc.
Re: Proxie images not colour managed
« Reply #3 on: June 04, 2019, 05:57:27 PM »
It turns out that proxy images were not color managed at all.  The next build will convert all images to the sRGB color space and then they will be matched to your monitor's profile.  This will add a slight amount of time to proxy generation, but the result will be that proxy images should look consistent across all color managed displays.

Existing catalogs will have to be rebuilt/proxies regenerated.

-Kirk