Author Topic: Color class removed on photos  (Read 1818 times)

Offline TimCaseyPhoto

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Color class removed on photos
« on: June 13, 2019, 07:50:45 AM »
Using Photo Mechanic Version 5.0, build 19749 (20d085a) on a Mac running OS X El Capitan Version 10.11.6

I've been running into a problem lately. The Color Class rating is missing on a lot of photos in my archive. I almost always edit/rate on a laptop, then move the photos to an iMac using a portable SSD or hard drive, then move them to an external desktop RAID drive.

Sometimes, the dark blue (7) color rating remains.

We starting using Photoshelter's Libris platform. That uses star ratings, not color class, so we remap the colors to be stars. If the color rating disappeared, I can remap it back the other way.

Any idea why this is happening and what I can do to prevent it and maybe even restore the missing colors?

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2550
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: Color class removed on photos
« Reply #1 on: June 13, 2019, 08:04:25 AM »
Looks like your new workflow messes with the colour classes. For instance when you say you map colour class to star rating, you will loose anything above 5 since the max is 5 stars. That may be the case with your dark blue (7) colour class disappearing. If you are lucky, the colour class is still present in the special PhotoMechanic Prefs tag in the metadata. From there it could be recoverable with some exiftool trickery.

Can you share a picture with the issue so we can have a look?
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline TimCaseyPhoto

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: Color class removed on photos
« Reply #2 on: June 20, 2019, 09:03:54 AM »
It's not when I map color class to star rating that I lose the color classes -- it's after I copy the photos from an external drive/laptop to an iMac. The star ratings (if there) will remain, but all colors 1-5 disappear.

I attached a screenshot of what it looks like after copying photos over. (All photos originally had color classes before transferring to iMac.)

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24172
    • View Profile
    • Camera Bits, Inc.
Re: Color class removed on photos
« Reply #3 on: June 20, 2019, 09:15:36 AM »
Tim,

It's not when I map color class to star rating that I lose the color classes -- it's after I copy the photos from an external drive/laptop to an iMac. The star ratings (if there) will remain, but all colors 1-5 disappear.

I attached a screenshot of what it looks like after copying photos over. (All photos originally had color classes before transferring to iMac.)

Could you please share one of your images before and after they're copied?  I'd like to see how the files are changing.

But one quick thing to check: are you applying a Metadata (IPTC) Template during the copy?  If so, are you using the Color Class field in the Template unintentionally?  That could definitely clear them out.

-Kirk

Offline TimCaseyPhoto

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: Color class removed on photos
« Reply #4 on: June 20, 2019, 09:40:41 AM »
This is what images appear like before they're copied. We do not apply anything during the copy, just transferring files between portable drives/laptops/iMacs.

Not sure if something in the PhotoMechanic update is causing the color classes to disappear -- it's just very strange.

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24172
    • View Profile
    • Camera Bits, Inc.
Re: Color class removed on photos
« Reply #5 on: June 20, 2019, 10:22:49 AM »
Tim,

I need an actual file before and after it is copied.  Screenshots are nice but they won't help me fix the problem for you.  The content of the photo is not important--you can take a photo with the lens cap on if you want.

Thanks,

-Kirk