Author Topic: Preview image not matching thumbnail  (Read 436 times)

Offline rcohn

  • Member
  • **
  • Posts: 91
    • View Profile
Preview image not matching thumbnail
« on: July 01, 2019, 09:50:49 AM »
I've never seen this before. In the Preview window 17 images in a folder of 160 images are not matching the thumbnail. I have attached a screenshot. How can I get PM to regenerate previews, or another fix?

Troubleshooting info: In the Mac Finder the thumbnails (for both raw and JPG) are correct. Just before noticing this I add some iPhone files to this folder, however these are mixed in with images later in the folder that are previewing correctly. Also, I am currently updating a NeoFinder catalog (my DAM) for the entire hard drive that includes these files. Did not think about conflicts, but this folder is the most recent. No change after I restarted PM. I spot checked other image folders and did not find any errors.

Photo Mechanic Version 6.0, build 3331 (38ae33c), Mac OS 10.14.5. MacBook Pro (Retina, 15-inch, Mid 2015).


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20507
    • View Profile
    • Camera Bits, Inc.
Re: Preview image not matching thumbnail
« Reply #1 on: July 01, 2019, 09:55:13 AM »
I've never seen this before. In the Preview window 17 images in a folder of 160 images are not matching the thumbnail. I have attached a screenshot. How can I get PM to regenerate previews, or another fix?

Troubleshooting info: In the Mac Finder the thumbnails (for both raw and JPG) are correct. Just before noticing this I add some iPhone files to this folder, however these are mixed in with images later in the folder that are previewing correctly. Also, I am currently updating a NeoFinder catalog (my DAM) for the entire hard drive that includes these files. No change after I restarted PM. I spot checked other image folders and did not find any errors.

Photo Mechanic Version 6.0, build 3331 (38ae33c), Mac OS 10.14.5. MacBook Pro (Retina, 15-inch, Mid 2015).

I've never seen this behavior before.  I don't have a solution for you.  Can you share a set of images that reproduces the problem?

Thanks,

-Kirk

Offline rcohn

  • Member
  • **
  • Posts: 91
    • View Profile
Re: Preview image not matching thumbnail
« Reply #2 on: July 01, 2019, 09:57:30 AM »
Thanks Kirk,\

"Can you share a set of images that reproduces the problem?" How would I do that?

Ric

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20507
    • View Profile
    • Camera Bits, Inc.
Re: Preview image not matching thumbnail
« Reply #3 on: July 01, 2019, 10:45:45 AM »
Ric,

"Can you share a set of images that reproduces the problem?" How would I do that?

You can use one of the many cloud-based services like Dropbox, or if you know how to use an FTP client then I can get you the server info for our FTP server and you can upload the images (zip them up first) there.

-Kirk

Offline rcohn

  • Member
  • **
  • Posts: 91
    • View Profile
Re: Preview image not matching thumbnail
« Reply #4 on: July 01, 2019, 11:41:08 AM »
Kirk,

FYI, I just tried it in PM 5 and the images are correct. I also tried it in an older version of PM 6 (6.0, build 3143 (3bc32e6)) and it displays the images in the same incorrect way. Maybe this will help for trouble shooting?

The Zipped folder is 4.52GB. Bigger than the 2 GB limit on my usual file sharing app. I haven't shared on Dropbox in so long that I forget how to do this.

Maybe FTP would be best?

Thanks!

Ric

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20507
    • View Profile
    • Camera Bits, Inc.
Re: Preview image not matching thumbnail
« Reply #5 on: July 01, 2019, 11:45:11 AM »
Ric,

FYI, I just tried it in PM 5 and the images are correct. I also tried it in an older version of PM 6 (6.0, build 3143 (3bc32e6)) and it displays the images in the same incorrect way. Maybe this will help for trouble shooting?

The Zipped folder is 4.52GB. Bigger than the 2 GB limit on my usual file sharing app. I haven't shared on Dropbox in so long that I forget how to do this.

Is there a smaller set of images that will reproduce the problem that you can share?  Hopefully it doesn't take 4GB of images to reproduce the problem.

Thanks,

-Kirk

Offline rcohn

  • Member
  • **
  • Posts: 91
    • View Profile
Re: Preview image not matching thumbnail
« Reply #6 on: July 01, 2019, 01:06:14 PM »
Kirk,

That is interesting. I duplicated a set of images (using the Finder to Option-Drag the files), that included the problem ones, into a new folder. When I looked at these in PM they preview correctly! Then I wondered if the files were "fixed" somehow in the copying process, and I Archived the same images directly. When I decompressed that file these images displayed in the same incorrect way!

Perhaps I should just replace the offending files (or even just the .xmp files to see what happens?)? Just in case it could make a difference: the original folder also includes a CaptureOne session folder.

Perhaps copying and replacing the files is the solution?

Via WeTransfer, I sent the set that includes the images that don't Preview correctly to support@. Let me know if that's not correct.

Best,
Ric

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20507
    • View Profile
    • Camera Bits, Inc.
Re: Preview image not matching thumbnail
« Reply #7 on: July 01, 2019, 01:08:09 PM »
Ric,

That is interesting. I duplicated a set of images (using the Finder to Option-Drag the files), that included the problem ones, into a new folder. When I looked at these in PM they preview correctly! Then I wondered if the files were "fixed" somehow in the copying process, and I Archived the same images directly. When I decompressed that file these images displayed in the same incorrect way!

Perhaps I should just replace the offending files (or even just the .xmp files to see what happens?)? Just in case it could make a difference: the original folder also includes a CaptureOne session folder.

Perhaps copying and replacing the files is the solution?

Via WeTransfer, I sent the set that includes the images that don't Preview correctly to support@. Let me know if that's not correct.

That will take a little longer (I don't get those emails) so using the forum "Personal Message" feature (click on my name to send me a personal message) would be faster.

Thanks,

-Kirk

Offline rcohn

  • Member
  • **
  • Posts: 91
    • View Profile
Re: Preview image not matching thumbnail
« Reply #8 on: July 01, 2019, 05:57:35 PM »
I worked with Kirk offline and want to report what I found in case anyone else experiences this.

The problem has to do with having "Enable RAW Rending" checked and using the Adobe DNG Converter (Preferences > Render Cache). I finally solved it by clicking "Empty Now" to remove the Cache and having PM re-render. It must be very rare if no one else has reported this. I only turned this on a few months ago to solve a different problem (the small size of the embedded jpegs in Sony .arw files).

Thanks to Kirk for helping me figure this out!