Author Topic: Bug with folder name with special characters  (Read 7915 times)

Offline xluthi

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Bug with folder name with special characters
« on: April 10, 2007, 03:21:31 AM »
Hi,

I'm trying version 4.5 of Photo Mechanic on Windows XP but it seems I have an issue with pictures located in folders with special characters inside their names.  The "Rename Photos" command did not work at all for all these photos.

The folder name is: "D:\DATA\photos\Baptême - photos".
The error message is: An error occurred  while renaming photo 12121.jpg.  The operation will be cancelled, and the original filenames will be restored.

If I remove the accent on the "e" into the folder name, Photo Mechanic is able to rename my photos.

Is this a known bug or did I do anything wrong?


If this bug is solved, I will perhaps adopt PM ;-)
« Last Edit: April 10, 2007, 05:04:00 AM by xluthi »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20582
    • View Profile
    • Camera Bits, Inc.
Re: Bug with folder name with special characters
« Reply #1 on: April 10, 2007, 06:50:47 AM »
Hi,

I'm trying version 4.5 of Photo Mechanic on Windows XP but it seems I have an issue with pictures located in folders with special characters inside their names.  The "Rename Photos" command did not work at all for all these photos.

The folder name is: "D:\DATA\photos\Baptême - photos".
The error message is: An error occurred  while renaming photo 12121.jpg.  The operation will be cancelled, and the original filenames will be restored.

If I remove the accent on the "e" into the folder name, Photo Mechanic is able to rename my photos.

Is this a known bug or did I do anything wrong?

I'll try to reproduce the issue on my system.  It should just work since 4.5 is a Unicode application.  If I can reproduce it, I will fix it in the first update to 4.5.

-Kirk

Offline xluthi

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Re: Bug with folder name with special characters
« Reply #2 on: April 10, 2007, 07:06:02 AM »
I'll try to reproduce the issue on my system.  It should just work since 4.5 is a Unicode application.  If I can reproduce it, I will fix it in the first update to 4.5.

-Kirk


Hi Kirk,

Thanks for your support!

If I can provide you with traces, debug output or anything else, feel free to ask :-)

Xavier

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20582
    • View Profile
    • Camera Bits, Inc.
Re: Bug with folder name with special characters
« Reply #3 on: April 10, 2007, 07:08:30 AM »
Xavier,

I'll try to reproduce the issue on my system.  It should just work since 4.5 is a Unicode application.  If I can reproduce it, I will fix it in the first update to 4.5.

-Kirk


Thanks for your support!

If I can provide you with traces, debug output or anything else, feel free to ask :-)

One thing that would help is: how do I type that character on a Windows PC?  I know I can look it up somewhere, but you'll save me time...

-Kirk

Offline archer69

  • Full Member
  • ***
  • Posts: 249
    • View Profile
    • JH-Photography
Re: Bug with folder name with special characters
« Reply #4 on: April 10, 2007, 08:49:24 AM »

One thing that would help is: how do I type that character on a Windows PC?  I know I can look it up somewhere, but you'll save me time...

-Kirk


Kirk,

Don't know the Alt+Number combination, but you can start the Windows Character Map (start->all programs->accessories->system tools->chracter map), select the carater and copy/past it itno the folder name where needed during renaming.

Perhaps that helps.

Archer
Regards,
Juerg H.
www.jh-photography.net

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20582
    • View Profile
    • Camera Bits, Inc.
Re: Bug with folder name with special characters
« Reply #5 on: April 10, 2007, 09:58:56 AM »
Archer,


One thing that would help is: how do I type that character on a Windows PC?  I know I can look it up somewhere, but you'll save me time...


Don't know the Alt+Number combination, but you can start the Windows Character Map (start->all programs->accessories->system tools->chracter map), select the carater and copy/past it itno the folder name where needed during renaming.

Yeah, I know about that thing, but I was hoping to avoid it.

Thanks,

-Kirk

Offline xluthi

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Re: Bug with folder name with special characters
« Reply #6 on: April 10, 2007, 11:37:30 PM »
Xavier,

(...)

One thing that would help is: how do I type that character on a Windows PC?  I know I can look it up somewhere, but you'll save me time...

-Kirk


Hi Kirk,

I've a French keyboard, so it's easy for me to type that kind of character ;-)  However, on a QWERTY keyboard, I think you've to type SHIFT + 6  and then "e".

Thanks for your support!
Xavier

Offline xluthi

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Re: Bug with folder name with special characters
« Reply #7 on: April 13, 2007, 08:10:26 AM »

I'll try to reproduce the issue on my system.  It should just work since 4.5 is a Unicode application.  If I can reproduce it, I will fix it in the first update to 4.5.

-Kirk


Kirk,

Do you succeed in reproducing my issue?

Thanks for your feedback!

Xavier

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20582
    • View Profile
    • Camera Bits, Inc.
Re: Bug with folder name with special characters
« Reply #8 on: April 13, 2007, 08:59:01 AM »
Xavier,


I'll try to reproduce the issue on my system.  It should just work since 4.5 is a Unicode application.  If I can reproduce it, I will fix it in the first update to 4.5.

Do you succeed in reproducing my issue?

I haven't had a chance yet.  I'm rewriting the Navigator right now and it is consuming all of my time.

-Kirk

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20582
    • View Profile
    • Camera Bits, Inc.
Re: Bug with folder name with special characters
« Reply #9 on: April 15, 2007, 08:31:26 AM »
Xavier,

I'm trying version 4.5 of Photo Mechanic on Windows XP but it seems I have an issue with pictures located in folders with special characters inside their names.  The "Rename Photos" command did not work at all for all these photos.

The folder name is: "D:\DATA\photos\Baptême - photos".
The error message is: An error occurred  while renaming photo 12121.jpg.  The operation will be cancelled, and the original filenames will be restored.

If I remove the accent on the "e" into the folder name, Photo Mechanic is able to rename my photos.

Is this a known bug or did I do anything wrong?


If this bug is solved, I will perhaps adopt PM ;-)

I have reproduced the bug you have described.  I have fixed it in a development version.

Thanks for the heads-up.

-Kirk