Author Topic: Closed: Filter selection lost when applying contact sheet colour class filter  (Read 405 times)

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2479
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
When applying a contact sheet filter (e.g. the colour classes) makes you lose your selected filter settings.

Steps:
1. Build a filter, selecting a number of criteria in one or more categories.
2. Deselect one of the colour classes in the contact sheet colour class filter (buttons on top right of the contact sheet) and apply this filter (arrows button).
3. Depending on how many categories you had chosen, you already immediately see one or more of the filter criteria disappear as selected.
4. Moving your mouse of the still marked as selected criteria, removes the marking of those too though.

Required outcome: set up filter criteria should not be lost when applying contact sheet filters.

Note: This issue is likely related to Tag/Rating/Colour filters should be applied directly to catalog sheet
« Last Edit: September 25, 2019, 02:00:56 AM by Hayo Baan »
Hayo Baan - Photography
Web: www.hayobaan.nl

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20635
    • View Profile
    • Camera Bits, Inc.
Hayo,

When applying a contact sheet filter (e.g. the colour classes) makes you lose your selected filter settings.

Steps:
1. Build a filter, selecting a number of criteria in one or more categories.
2. Deselect one of the colour classes in the contact sheet colour class filter (buttons on top right of the contact sheet) and apply this filter (arrows button).
3. Depending on how many categories you had chosen, you already immediately see one or more of the filter criteria disappear as selected.
4. Moving your mouse of the still marked as selected criteria, removes the marking of those too though.

Required outcome: set up filter criteria should not be lost when applying contact sheet filters.

Note: This issue is likely related to Tag/Rating/Colour filters should be applied directly to catalog sheet

Could you please post a series of screen shots that illustrate the problem?

Thanks,

-Kirk

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2479
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
It's really easy, if you follow the steps I mentioned you'll see the issue right away.

I've attached the relevant screenshots after each step.
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2479
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
This is fixed in B9 (Build 3719)
Hayo Baan - Photography
Web: www.hayobaan.nl