Author Topic: Errors during applying IPTC information  (Read 2151 times)

Offline kclaar

  • Newcomer
  • *
  • Posts: 44
    • View Profile
Errors during applying IPTC information
« on: September 09, 2019, 12:08:25 PM »
Photo Mechanic Plus Builds: R3635, R3663
Windows 10 Version: Home 1903, Build 18362.295 (08/2019)

When applying IPTC information (single or group), get error "Error writing IPTC info" (single) or "There were errors during the apply to selected operation" (group).

The re-application works but when doing groups, deletes IPTC information from the first slide in the group.

Is there a tool to search for specific IPTC fields to check whether the field contains data?

Thanks,
Ken Claar

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20730
    • View Profile
    • Camera Bits, Inc.
Re: Errors during applying IPTC information
« Reply #1 on: September 09, 2019, 12:22:23 PM »
Ken,

Photo Mechanic Plus Builds: R3635, R3663
Windows 10 Version: Home 1903, Build 18362.295 (08/2019)

When applying IPTC information (single or group), get error "Error writing IPTC info" (single) or "There were errors during the apply to selected operation" (group).

The re-application works but when doing groups, deletes IPTC information from the first slide in the group.

What kind of files are you working with and where are they located?  (what kind of drive: internal, external, network disk)

Is there a tool to search for specific IPTC fields to check whether the field contains data?

The Find panel will find specific data, but not whether or not any data exists.  You have to know what you're looking for.  There is no other tool that will find images that don't have any data in a specific field.  The Browse tab in the Organizer of Photo Mechanic Plus will show how many images have nothing for a specific field (<none>) is the entry, but if the image(s) you're interested in finding haven't been added to your catalog then they won't be shown when you click on the <none> entry.

-Kirk

Offline kclaar

  • Newcomer
  • *
  • Posts: 44
    • View Profile
Re: Errors during applying IPTC information
« Reply #2 on: September 09, 2019, 01:04:11 PM »
Kirk,

They are all Nikon RAW (.NEF) files from a D700. Drive is local (C:).

Did not have the issue at all until R3635. Nothing else has changed or been updated.

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20730
    • View Profile
    • Camera Bits, Inc.
Re: Errors during applying IPTC information
« Reply #3 on: September 09, 2019, 01:31:20 PM »
Kirk,

They are all Nikon RAW (.NEF) files from a D700. Drive is local (C:).

Did not have the issue at all until R3635. Nothing else has changed or been updated.

Are you using XMP sidecar files or are you embedding metadata into your NEFs?

Feel free to take a screen shot of your IPTC/XMP preferences and post them here if you're unsure.  Use the 'Attachments and other options' link when you're composing your reply to this message and there you'll be able to upload your JPEG format screenshot.

Thanks,

-Kirk

Offline kclaar

  • Newcomer
  • *
  • Posts: 44
    • View Profile
Re: Errors during applying IPTC information
« Reply #4 on: September 09, 2019, 02:35:37 PM »
Embedding. Some of the images have quite a bit of info in the caption field, but it also happens when those images are not in the mix. Reboots also didn't make a difference.

Brings up a question on embedding and sidecar files... when I upgraded from PM5 to PM6, it was using XMP sidecar files. Not sure what changed, but PM6 was embedding before I started using PM6+. How does one switch it?

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20730
    • View Profile
    • Camera Bits, Inc.
Re: Errors during applying IPTC information
« Reply #5 on: September 09, 2019, 05:06:08 PM »
Embedding. Some of the images have quite a bit of info in the caption field, but it also happens when those images are not in the mix. Reboots also didn't make a difference.

Brings up a question on embedding and sidecar files... when I upgraded from PM5 to PM6, it was using XMP sidecar files. Not sure what changed, but PM6 was embedding before I started using PM6+. How does one switch it?

In the IPTC/XMP settings in the Preferences dialog.  Or do you mean how does it spontaneously change?  It shouldn't.

I'd like to see your Photo Mechanic log.  In Photo Mechanic go to the Help menu and choose "Reveal Support Data..." and moments later a Windows Explorer window will come forward with the zipped log file selected.  Use the 'Attachments and other options' link when you're composing your reply to this message and there you'll be able to upload your zipped PM log file.

Thanks,

-Kirk

Offline kclaar

  • Newcomer
  • *
  • Posts: 44
    • View Profile
Re: Errors during applying IPTC information
« Reply #6 on: September 10, 2019, 08:37:30 AM »
Zip file attached.

After another reboot (power off and power on), I have not been able to replicate the problem. What I did notice when I was experiencing the problem was that a progress dialog box appeared stating that PM was reading/gathering metadata, then the apply progress dialog box would appear, then the error message. When the reading/gathering progress dialog box did not appear, the apply progress dialog box appeared immediately and no errors occurred. Don't know if that helps or not.

Thank you very much for your help!
-- Ken

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20730
    • View Profile
    • Camera Bits, Inc.
Re: Errors during applying IPTC information
« Reply #7 on: September 10, 2019, 10:46:20 AM »
Ken,

Zip file attached.

After another reboot (power off and power on), I have not been able to replicate the problem. What I did notice when I was experiencing the problem was that a progress dialog box appeared stating that PM was reading/gathering metadata, then the apply progress dialog box would appear, then the error message. When the reading/gathering progress dialog box did not appear, the apply progress dialog box appeared immediately and no errors occurred. Don't know if that helps or not.

For a period of time several files could not be opened for read/write access (files of the form NNN_Philadelphia_2019-09-07.NEF) due to a permissions problem.  Did any error dialog appear telling you what the problem was and give you a chance to fix it?

Thanks,

-Kirk

Offline kclaar

  • Newcomer
  • *
  • Posts: 44
    • View Profile
Re: Errors during applying IPTC information
« Reply #8 on: September 10, 2019, 12:03:14 PM »
Just the PM error dialog. No Windows error messages. The reading metadata dialog appeared (it typically does not appear), then the apply dialog, then about a 2-3 second pause, then the PM error dialog.

PM was the only application running; disk access was normal (I did check Task Manager), and memory (8G) was around 64%. I'm working on them again today, and no issues. Windows issue? Wait and see if it happens again?

This is a group of about 90 images I was working with when the errors occurred. The images were not yet cataloged.

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20730
    • View Profile
    • Camera Bits, Inc.
Re: Errors during applying IPTC information
« Reply #9 on: September 10, 2019, 12:10:10 PM »
Ken,

Just the PM error dialog. No Windows error messages. The reading metadata dialog appeared (it typically does not appear), then the apply dialog, then about a 2-3 second pause, then the PM error dialog.

PM was the only application running; disk access was normal (I did check Task Manager), and memory (8G) was around 64%. I'm working on them again today, and no issues. Windows issue? Wait and see if it happens again?

This is a group of about 90 images I was working with when the errors occurred. The images were not yet cataloged.

If it does happen again, could you please take a screenshot of the Photo Mechanic error dialog and post it here?

Thanks,

-Kirk

Offline kclaar

  • Newcomer
  • *
  • Posts: 44
    • View Profile
Re: Errors during applying IPTC information
« Reply #10 on: September 10, 2019, 12:16:15 PM »
Kirk,

Will do. Thank you for all your help. I've been using PM since PM4, and am very excited about the catalog. I've been living in the program restructuring my photo storage design to best use the catalog.

-- Ken

Offline kclaar

  • Newcomer
  • *
  • Posts: 44
    • View Profile
Re: Errors during applying IPTC information
« Reply #11 on: September 22, 2019, 07:14:37 PM »
Kirk,

These errors occurred again. Attached are screen captures and the log file with debugging turned on. This is the most recent version of PM+.

-- Ken Claar

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20730
    • View Profile
    • Camera Bits, Inc.
Re: Errors during applying IPTC information
« Reply #12 on: September 23, 2019, 09:05:26 AM »
Ken,

These errors occurred again. Attached are screen captures and the log file with debugging turned on. This is the most recent version of PM+.

Thanks for the log file.

From your log:
[Sun Sep-22-2019 22:07:30.108][00002794][0760844] CBFileIO.cpp:692 Could not open "C:\Users\Ken\Pictures\0. NEW\118_2019-09-21.NEF" for "r+b" access.  Sleeping 500ms and trying again.

PM+ tried repeatedly to open your file so that it could update it.  It failed each time and eventually gave up.  Please check and fix the permissions on that file and potentially its parent directory.

-Kirk

Offline kclaar

  • Newcomer
  • *
  • Posts: 44
    • View Profile
Re: Errors during applying IPTC information
« Reply #13 on: September 23, 2019, 10:03:13 AM »
Kirk,

Not sure how the read only attribute is being set, but obviously on my end. Fixed the files and is working fine.

Followup questions: If the file is read-only, and PM+ is timing out, why is the IPTC information erased in read-only file? Also, is it possible to tell the user in the error message which file it is (I remember this being asked for by another member)? Once PM+ encounters the error during a group apply, does the remainder of the group not get updated?

Thanks,
-- Ken

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20730
    • View Profile
    • Camera Bits, Inc.
Re: Errors during applying IPTC information
« Reply #14 on: September 23, 2019, 10:32:48 AM »
Ken,

Not sure how the read only attribute is being set, but obviously on my end. Fixed the files and is working fine.

Good.

Followup questions: If the file is read-only, and PM+ is timing out, why is the IPTC information erased in read-only file?

I'm not sure what you mean by 'erased'?

Also, is it possible to tell the user in the error message which file it is (I remember this being asked for by another member)? Once PM+ encounters the error during a group apply, does the remainder of the group not get updated?

The error reporting could be improved for sure.  When an error occurs during a bulk application of metadata, the operation stops with the failed image.  Continuing would throw off any use of the {sequence} variable.

-Kirk