Author Topic: PM 5 and mac OS Catalina 10.15 are not in harmony  (Read 299 times)

Offline marc1

  • Newcomer
  • *
  • Posts: 15
    • View Profile
PM 5 and mac OS Catalina 10.15 are not in harmony
« on: October 09, 2019, 10:31:21 AM »
I still use PM 5, this version is not compatible with mac OS Catalina 10.15 - according to Apple, also my current Photoshop Version won't be compatible. I use Adobe Photoshop CS6 Version, in combination with Adobe Bridge CS6 - in order to use Camera RAW.
I'm shooting for Getty Images, and PM still works - instead of the Getty-Software FOCUS. I would like to stay with PM.
The problem is, if I make a software update for the mac I can no longer use PS and PM.

Greetings from Bonn/Germany

Offline MickO

  • Camera Bits Staff
  • Sr. Member
  • *****
  • Posts: 316
    • View Profile
    • Camera Bits
Re: PM 5 and mac OS Catalina 10.15 are not in harmony
« Reply #1 on: October 09, 2019, 10:35:03 AM »
You have come upon one of the many different reasons that Photo Mechanic 6 was created! This new product was completely re-done specifically to be 64-bit compatible. If you want to upgrade to Catalina and use Photo Mechanic, then PM6 is the way to go.  If you stay on Mojave, you can use Photo Mechanic 5 for as long as your machine will run. :-)

-Mick
----------------------
Mick O
Camera Bits