Author Topic: Updated Keywords Not Showing in Catalog Panel  (Read 395 times)

Offline kclaar

  • Newcomer
  • *
  • Posts: 41
    • View Profile
Updated Keywords Not Showing in Catalog Panel
« on: November 04, 2019, 10:20:16 AM »
Kirk,

Windows 10 and PM6+ Build 3938

When updating keywords and keyword structure, 2 sets out of 3 did not show up. I checked Tasks, and all catalog updates had completed. I used Find and Replace to change the keywords. Screenshot is attached.

It seems it is a panel refresh issue as everything showed upon PM shutdown and restart.

-- Ken

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20513
    • View Profile
    • Camera Bits, Inc.
Re: Updated Keywords Not Showing in Catalog Panel
« Reply #1 on: November 04, 2019, 04:50:32 PM »
Ken,

Windows 10 and PM6+ Build 3938

When updating keywords and keyword structure, 2 sets out of 3 did not show up. I checked Tasks, and all catalog updates had completed. I used Find and Replace to change the keywords. Screenshot is attached.

It seems it is a panel refresh issue as everything showed upon PM shutdown and restart.

What did your Find and Replace panel look like?

Thanks,

-Kirk

Offline kclaar

  • Newcomer
  • *
  • Posts: 41
    • View Profile
Re: Updated Keywords Not Showing in Catalog Panel
« Reply #2 on: November 04, 2019, 06:02:59 PM »
Kirk,

I changed the keyword structure from Fairmount Camera Club | Monthly Photo Shoot | 08-2019 Fairmount Park to Fairmount Camera Club | Monthly Photo Shoot | 2019 | 08 Fairmount Park.

The Find and Replace panel changed 08-2019 Fairmount Park to 2019 | 08 Fairmount Park.

I did this for the months 08, 09 and 10. As you can see from the snapshot, the IPTC panel is correct, but the info in the Organizer panel is not. It lists a count of 0 for Fairmount Park Camera Club, even though there is a sub group showing with a count greater than 0.

Each of the Find and Replace tasks completed with no errors.

Attached is the last Find and Replace...

-- Ken

Offline kclaar

  • Newcomer
  • *
  • Posts: 41
    • View Profile
Re: Updated Keywords Not Showing in Catalog Panel
« Reply #3 on: November 05, 2019, 09:34:07 PM »
Kirk,

I ran another test. The end result is that I started with 3 structured keywords. As I changed the structure, the Find and Replace worked correctly, but the count in the Organizer panel showing the keywords and counts were not updating properly - they were decrementing until after the third and final restructure the count was 0. After an exit of PM+ and a restart, everything was fine and the counts were correct.

This may be the same issue in another post where the counts were reported being incorrect, but were fine after an exit and startup.

This is new behavior for this build as I have been doing many structured keyword changes over the last few months.

Attached ate a number of screen shots -- I took a screen shot each step of the way.

-- Ken