Author Topic: PM6 & PM6+ very slow  (Read 444 times)

Offline bazography

  • Full Member
  • ***
  • Posts: 174
    • View Profile
PM6 & PM6+ very slow
« on: November 14, 2019, 02:58:57 PM »
I upgraded to Mojave some months back, reinstalling the OS and all software from scratch. I upgraded to PM6/PM6+ around that same time, so unfortunately I can’t compare to how PM5 ran on Mojave. My last build on this machine was PM5 on El Capitan, which was always speedy.

Most basic functions seem sluggish (lots of spinning beachballs) but a big issue seems to be loading thumbnails. A folder of 265 TIF files, roughly 100MB each, took almost 7 minutes for all the thumbnails (not previously cached) to appear and for all the filenames to turn from red to white. (All the examples I give here are for local files, not on a server.) Same results with PM6 and PM6+.

And during this time that thumbnails are loading PM really slows to a crawl. I have to avoid using the Filter tab because it initially tries to load my entire catalog, which bogs everything down. For example, if I click “+” it can take 10 seconds for the next filter to appear.

Another example; I was changing colour codes on a batch of 280 images. It started slowly but got much worse as it progressed. By the halfway point it was taking about 12 seconds per image (yikes!). I discovered that if I select just a few dozen images at a time and wait for the thumbnails to load first, the colour change runs faster, although still not even close to the speed of PM5. Even selecting just one image and changing the colour sometimes causes a spinning beachball.

I've also noticed that converting a batch of TIFs into JPGs using my usual "Save As" snapshot takes at least 2 or 3 times longer than I'm used to with PM5.

I’ve kept Activity Monitor running lately, and PM's % of CPU ranges from 50 to 160, and memory typically runs from 800MB to 1.5GB, but I’ve seen it as high as 3.9GB. I don’t really know what “normal” is though. Once, Activity Monitor showed "Photo Mechanic (not responding)" off and on, although the task did eventually complete.

I do not have RAW rendering enabled. I attached screenshots of cache settings and system specs.

Can I install a copy of PM5 and run that to compare, or will that mess up the PM6 installation?

Thanks.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20601
    • View Profile
    • Camera Bits, Inc.
Re: PM6 & PM6+ very slow
« Reply #1 on: November 14, 2019, 03:36:42 PM »
Can I install a copy of PM5 and run that to compare, or will that mess up the PM6 installation?

They can both coexist on the same system.

-Kirk