Author Topic: Issues with ' and " in PM6  (Read 607 times)

Offline Rick Ulreich

  • Newcomer
  • *
  • Posts: 1
    • View Profile
Issues with ' and " in PM6
« on: November 29, 2019, 03:09:42 PM »
When I use the ' or the " in my captioning with Photo Mechanic 6 I am being told that the file is coming over with symbols instead of the actual characters when the photos are sent via fTP to my clients server.  I can't find any settings that would cause that to happen.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20736
    • View Profile
    • Camera Bits, Inc.
Re: Issues with ' and " in PM6
« Reply #1 on: November 30, 2019, 07:59:19 AM »
When I use the ' or the " in my captioning with Photo Mechanic 6 I am being told that the file is coming over with symbols instead of the actual characters when the photos are sent via fTP to my clients server.  I can't find any settings that would cause that to happen.

If you're on macOS, there is a setting that inserts "Smart Quotes" that are fancier characters than what you've typed.  See the attached photo. Right-clicking in the text field brings up the menu.

HTH,

-Kirk

Offline PJ

  • Newcomer
  • *
  • Posts: 34
    • View Profile
Re: Issues with ' and " in PM6
« Reply #2 on: January 14, 2020, 06:41:51 PM »
Kirk,
I just saw your reply about using straight or smart quotes in captions. I  followed your instructions, unchecked smarten quotes, then saved the IPTC template. When I loaded it again, smart quotes is still checked. Any way to get it to remain unchecked??

Thanks.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20736
    • View Profile
    • Camera Bits, Inc.
Re: Issues with ' and " in PM6
« Reply #3 on: January 15, 2020, 09:17:53 AM »
I just saw your reply about using straight or smart quotes in captions. I  followed your instructions, unchecked smarten quotes, then saved the IPTC template. When I loaded it again, smart quotes is still checked. Any way to get it to remain unchecked??

I know of no way to make your choice there persist at this time.

You may want to try turning off smart quotes system-wide.  In the Keyboard System Preferences pane, click on the Text tab, then uncheck "Use smart quotes and dashes"

HTH,

-Kirk