Author Topic: Wrong date after loading an IPTC template  (Read 194 times)

Offline aeschi

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Wrong date after loading an IPTC template
« on: November 30, 2019, 02:37:46 AM »
Dear all,

I just realized that I get sometimes a wrong IPTC date when I load an IPTC template (XMP file) with a specific date set.
What I foud out is the following: I clear the IPTC template. When the field Date is set to Capture Time and I load the external IPTC template then the date is set to 16.10.2017. When the field Date is set to Date then I get the right date, e.g. 30.11.2019.

Any ideas? Is this a bug?

I work with Photo Mechanic Version 6.0, build 3954 (158b808) on a MacBook Air (early 2015) and Catalina 10.15.1.

Regards,
Markus

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20596
    • View Profile
    • Camera Bits, Inc.
Re: Wrong date after loading an IPTC template
« Reply #1 on: November 30, 2019, 08:13:18 AM »
Markus,

I just realized that I get sometimes a wrong IPTC date when I load an IPTC template (XMP file) with a specific date set.
What I foud out is the following: I clear the IPTC template. When the field Date is set to Capture Time and I load the external IPTC template then the date is set to 16.10.2017. When the field Date is set to Date then I get the right date, e.g. 30.11.2019.

Any ideas? Is this a bug?

I work with Photo Mechanic Version 6.0, build 3954 (158b808) on a MacBook Air (early 2015) and Catalina 10.15.1.

Please post your "external IPTC template".  Use the 'Attachments and other options' link when you're composing your reply to this message and there you'll be able to upload your file.

Thanks,

-Kirk

Offline aeschi

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: Wrong date after loading an IPTC template
« Reply #2 on: December 02, 2019, 01:02:33 PM »
Thank you, Kirk. See attached file.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20596
    • View Profile
    • Camera Bits, Inc.
Re: Wrong date after loading an IPTC template
« Reply #3 on: December 02, 2019, 04:38:37 PM »
Thank you, Kirk. See attached file.

Thank you for the sample file.  I'm able to reproduce the bug and I'm working on a fix.

-Kirk