Author Topic: Problems with refreshing  (Read 5011 times)

Offline sbihlmaier

  • Newcomer
  • *
  • Posts: 2
    • View Profile
Problems with refreshing
« on: December 10, 2019, 06:52:48 AM »
Hi,

I’m having an issue in Photo Mechanic 6 with refreshing a contact sheet. I’m basically just organizing and moving photos on the contact sheet by dragging them into various folders on navigator panel. It’s the same workflow I’ve used in Photo Mechanic for years. After upgrading to Photo Mechanic 6, the contact sheet no longer automatically refreshes to reflect that the file has been moved. It will update if I click out of the program and back in, or if I manually rescan using “ command + / " (simply refreshing does not work).

I do have my preferences set to automatically rescan when folder contents change. That being selected seems to make no difference to its behavior. It has the same behavior whether I’m working from a server or locally from my hard drive. My coworkers also just upgraded to Photo Mechanic 6, and theirs behaves as expected. As I’m moving and reorganizing hundreds of photos, it is extremely disruptive to have to stop and refresh/rescan after every move.

I’m running Photo Mechanic 6.0, build 3954, on a Mac OS Mojave 10.14.6, 3.4 GHz Intel Core i5

Thanks for your help!

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24382
    • View Profile
    • Camera Bits, Inc.
Re: Problems with refreshing
« Reply #1 on: December 10, 2019, 08:04:12 AM »
I’m having an issue in Photo Mechanic 6 with refreshing a contact sheet. I’m basically just organizing and moving photos on the contact sheet by dragging them into various folders on navigator panel. It’s the same workflow I’ve used in Photo Mechanic for years. After upgrading to Photo Mechanic 6, the contact sheet no longer automatically refreshes to reflect that the file has been moved. It will update if I click out of the program and back in, or if I manually rescan using “ command + / " (simply refreshing does not work).

I do have my preferences set to automatically rescan when folder contents change. That being selected seems to make no difference to its behavior. It has the same behavior whether I’m working from a server or locally from my hard drive. My coworkers also just upgraded to Photo Mechanic 6, and theirs behaves as expected. As I’m moving and reorganizing hundreds of photos, it is extremely disruptive to have to stop and refresh/rescan after every move.

I’m running Photo Mechanic 6.0, build 3954, on a Mac OS Mojave 10.14.6, 3.4 GHz Intel Core i5

Thanks for your help!

This will be addressed in the next build of Photo Mechanic 6.

-Kirk

Offline sbihlmaier

  • Newcomer
  • *
  • Posts: 2
    • View Profile
Re: Problems with refreshing
« Reply #2 on: December 10, 2019, 08:13:41 AM »
Thanks so much for the quick response! I'm not familiar with how often you guys come out with builds. Is there a rough estimate on when I could expect that? Thanks again, I appreciate it!

Offline markfink67

  • Newcomer
  • *
  • Posts: 10
    • View Profile
    • mfpix.com
Re: Problems with refreshing
« Reply #3 on: December 10, 2019, 09:50:11 AM »
Same problem here.  I wasn't expecting this. Nice glitch.  Please fix as soon as possible this is annoying.  Can I just delete and reload? 

What happened to the upload button in the top panel?
Virginia Photographer - Mark Finkenstaedt

Editorial, Corporate, Advertising

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24382
    • View Profile
    • Camera Bits, Inc.
Re: Problems with refreshing
« Reply #4 on: December 11, 2019, 07:24:23 PM »
Thanks so much for the quick response! I'm not familiar with how often you guys come out with builds. Is there a rough estimate on when I could expect that? Thanks again, I appreciate it!

We are planning a new PM6 build next week (December 16th-20th).

-Kirk

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24382
    • View Profile
    • Camera Bits, Inc.
Re: Problems with refreshing
« Reply #5 on: December 18, 2019, 05:49:37 PM »
Please get the new Photo Mechanic 6 build 4150: http://forums.camerabits.com/index.php?topic=13046.0

-Kirk

Offline Adam H

  • Newcomer
  • *
  • Posts: 3
    • View Profile
Re: Problems with refreshing
« Reply #6 on: April 11, 2020, 06:27:17 PM »
I seem to be having the same issue

I'm using:
* Mac OS X 10.15.4
* PhotoMechanic 6 Build 4484

Steps to reproduce

* Open a folder that contains subfolders of images
* rename one of the parent folders
* Double click on the child folder and the contact sheet will not open

Manually refresh or rescan the sidebar and it will not work as expected.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24382
    • View Profile
    • Camera Bits, Inc.
Re: Problems with refreshing
« Reply #7 on: April 12, 2020, 08:24:35 AM »
Adam,

I seem to be having the same issue

I'm using:
* Mac OS X 10.15.4
* PhotoMechanic 6 Build 4484

Steps to reproduce

* Open a folder that contains subfolders of images
* rename one of the parent folders
* Double click on the child folder and the contact sheet will not open

Manually refresh or rescan the sidebar and it will not work as expected.

Sounds like a different issue to me.  When you say "Open a folder that contains subfolders of images" do you mean to open that folder as a Contact Sheet or are you simply expanding that part of the Navigator/Favorites tree?

Could you please take some screenshots and illustrate exactly what you're talking about?  Use the 'Attachments and other options' link when you're composing your reply to this message and there you'll be able to upload your JPEG format screenshots.

Thanks,

-Kirk

Offline Adam H

  • Newcomer
  • *
  • Posts: 3
    • View Profile
Re: Problems with refreshing
« Reply #8 on: April 15, 2020, 05:10:28 PM »
Hi,

I meant expand...

Here are some more complete steps, the folders don't even need to contain images to reproduce the problem

  • Right-click and create a new folder in the navigation pane called "Parent"
  • Right-click on Parent and select "New folder inside this folder" call it "Child"
  • Double click on Child in the navigator and a new tab will open called "Child"
  • Close the tab for Child
  • Right-click on "Parent" in the navigator and rename it "Parent2"
  • Double click on Child in the navigator and it will not open the correct tab, if child contains images you will not see them
  • Right-click on the parent of "Parent" and select Refresh
  • Double click on Child in the navigator and it will open the correct tab, if child contains images you will see them

I can add screenshots if you want but I'm not sure they'll add much.



Offline Adam H

  • Newcomer
  • *
  • Posts: 3
    • View Profile
Re: Problems with refreshing
« Reply #9 on: April 20, 2020, 03:39:05 PM »
Another issue, which I'm guessing is related, is that when I create new folders via the Finder they are not displayed in the navigator.

* Mac OS X 10.15.4
* PhotoMechanic 6 4538 (I've updated since my original issue but no improvement)

Steps to reproduce
* Open PhotoMechanic
* Expand any directory in the Navigator so you can see it's contents/subfolders. We'll call this parent from now on
* Right-click on "parent" and select "Reveal in Finder" or command-tab to the finder and navigate to "parent"
* Right click inside "parent" and select "New Folder"
* Enter any name e.g. "X"
* Switch back to PM
* X will not be visible in the navigator
* Right-click on "parent" and select "refresh"
* X will now be display in the navigator as a subfolder in "parent"

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24382
    • View Profile
    • Camera Bits, Inc.
Re: Problems with refreshing
« Reply #10 on: April 20, 2020, 04:05:46 PM »
Another issue, which I'm guessing is related, is that when I create new folders via the Finder they are not displayed in the navigator.

* Mac OS X 10.15.4
* PhotoMechanic 6 4538 (I've updated since my original issue but no improvement)

Steps to reproduce
* Open PhotoMechanic
* Expand any directory in the Navigator so you can see it's contents/subfolders. We'll call this parent from now on
* Right-click on "parent" and select "Reveal in Finder" or command-tab to the finder and navigate to "parent"
* Right click inside "parent" and select "New Folder"
* Enter any name e.g. "X"
* Switch back to PM
* X will not be visible in the navigator
* Right-click on "parent" and select "refresh"
* X will now be display in the navigator as a subfolder in "parent"

Photo Mechanic does not monitor all of your folders for changes.  You'll have to refresh as needed or create your folders inside Photo Mechanic.  We were able to reproduce your earlier problem and addressed it in build 4538.  If it's still broken, then help me reproduce your issue.

-Kirk