Author Topic: Variables entry by clicking on list not working correctly. Leads to app crash.  (Read 379 times)

Offline Slylandro

  • Newcomer
  • *
  • Posts: 9
    • View Profile
PhotoMechanic 6 build 3954; windows7 64bit latest update

In Preferences>Contact Sheet Thumbnails section Label 2 after clicking Variables... button unable to select anything - it just dings and doesn't do anything when arrow over Variables pop-up.  Arrow keys do nothing.  To get out, you have to select Preferences window, close it then the Variables pop-up selection works.  Clicking around the variables selections I then get a BugSplat message.  Filled it out and sent.  The only way to close the Variables pop-up is by first closing the Preferences window first.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20713
    • View Profile
    • Camera Bits, Inc.
PhotoMechanic 6 build 3954; windows7 64bit latest update

In Preferences>Contact Sheet Thumbnails section Label 2 after clicking Variables... button unable to select anything - it just dings and doesn't do anything when arrow over Variables pop-up.  Arrow keys do nothing.  To get out, you have to select Preferences window, close it then the Variables pop-up selection works.  Clicking around the variables selections I then get a BugSplat message.  Filled it out and sent.  The only way to close the Variables pop-up is by first closing the Preferences window first.

Hmm.  I'm unable to reproduce by following your steps.  Could you record a video and post a link to it showing the problem being reproduced?

Thanks,

-Kirk

Offline Slylandro

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Attached is the video requested.  You can't hear the bell as I click on the non responsive Variables list but it is dinging and not doing anything.  As you can see, I can close the Prefs window without closing the Variables pop-up which I believe should not be possible without closing the pop-up first.  Once the Prefs is closed, you can see I can click several Variables items until it crashes the app.

The Variables list seems to work everywhere else so it's just the Prefs window.

Sorry the MP- should be PM.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20713
    • View Profile
    • Camera Bits, Inc.
Attached is the video requested.  You can't hear the bell as I click on the non responsive Variables list but it is dinging and not doing anything.  As you can see, I can close the Prefs window without closing the Variables pop-up which I believe should not be possible without closing the pop-up first.  Once the Prefs is closed, you can see I can click several Variables items until it crashes the app.

The Variables list seems to work everywhere else so it's just the Prefs window.

In that run, had you used the Variables panel somewhere else prior to using it in the Preferences dialog?  If so, where?

Thanks,

-Kirk

Offline Slylandro

  • Newcomer
  • *
  • Posts: 9
    • View Profile
No.  I had just started it prior to recording the video.

Some observations:

In Prefs>Contact Sheet I can open the Variables list without first putting the cursor in a field  and can click items.  I can put cursor in a field and double click an item and it will appear in the field at cursor.  Can close Variables list then close Prefs by hitting cancel.  I can double click on different Variables items then close then open Variables and repeat several times.  So issue is not always the same or is intermittent.

I can close the Prefs using Cancel and the Variables list stays up which I think is incorrect (usually programs complain when you try to close a parent window without closing a child first).  After closing the Variables list box last I then go back into Prefs>Contact Sheet then open Variables list and I then can't select anything or close and it dings with every mouse click.  Close the Prefs then you can close the Variables list box.  So, I believe the trick is to close the Prefs first using Cancel then close the Variables list box and go back in and it'll do it as I've described here.  I've tried this several times and it seems consistent.  I don't think this is how I initially found this problem though so it may happen randomly without closing Prefs first.

Incidentally I'm using the demo timed version for evaluation.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20713
    • View Profile
    • Camera Bits, Inc.
No.  I had just started it prior to recording the video.

OK, the reason I asked is that when your Variables panel appeared, it was already scrolled a few lines from the top and I was wondering how it had got that way on initial open.  So had you opened and closed it a few times from the Preferences dialog prior to reproducing the crash?

Some observations:

In Prefs>Contact Sheet I can open the Variables list without first putting the cursor in a field  and can click items.  I can put cursor in a field and double click an item and it will appear in the field at cursor.  Can close Variables list then close Prefs by hitting cancel.  I can double click on different Variables items then close then open Variables and repeat several times.  So issue is not always the same or is intermittent.

I can close the Prefs using Cancel and the Variables list stays up which I think is incorrect (usually programs complain when you try to close a parent window without closing a child first).  After closing the Variables list box last I then go back into Prefs>Contact Sheet then open Variables list and I then can't select anything or close and it dings with every mouse click.  Close the Prefs then you can close the Variables list box.  So, I believe the trick is to close the Prefs first using Cancel then close the Variables list box and go back in and it'll do it as I've described here.  I've tried this several times and it seems consistent.  I don't think  this is how I initially found this problem though so it may happen randomly without closing Prefs first.

Thanks, I'll play around with it some more.  When we get a reproducible case, I'll fix it.

Incidentally I'm using the demo timed version for evaluation.

Good to note though there is no difference in functionality during the trial period other than it eventually expires and won't run without an actual license activation.

-Kirk

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20713
    • View Profile
    • Camera Bits, Inc.
Thanks for the help.  I have reproduced the problem and have fixed it.  The next build of PM6 will have the fix in it.

-Kirk

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20713
    • View Profile
    • Camera Bits, Inc.
Please get the new Photo Mechanic 6 build 4150: http://forums.camerabits.com/index.php?topic=13046.0

-Kirk