Author Topic: Auto advance stops after changing folder  (Read 2417 times)

Offline rienvanham

  • Member
  • **
  • Posts: 55
    • View Profile
Auto advance stops after changing folder
« on: December 31, 2019, 03:43:45 AM »
Hello,

I'm using the "Automatically advance to next photo when"... and that works pretty well. But, after changing the directory (double click on another folder) it stops moving to the next photo.

Is this a bug or am I doing something wrong?

Thanks in advance,

Rien van Ham

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23143
    • View Profile
    • Camera Bits, Inc.
Re: Auto advance stops after changing folder
« Reply #1 on: December 31, 2019, 10:04:39 AM »
Sounds like a bug.  If we can reproduce it, then we can fix it.

Please list the steps needed to reproduce the problem.

-Kirk

Offline rienvanham

  • Member
  • **
  • Posts: 55
    • View Profile
Re: Auto advance stops after changing folder
« Reply #2 on: January 01, 2020, 02:19:23 AM »
Hi Kirk,

1: Open PM
2: set the colorclass of phot's
3: In the folder-tree in the left: doubleclick a folder where you want to set the colorclass of photo's
4: auto-advance isn't working anymore (at least on my machine).

Thanks in advance!

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23143
    • View Profile
    • Camera Bits, Inc.
Re: Auto advance stops after changing folder
« Reply #3 on: January 01, 2020, 01:48:01 PM »
Hi Kirk,

1: Open PM
2: set the colorclass of phot's
3: In the folder-tree in the left: doubleclick a folder where you want to set the colorclass of photo's
4: auto-advance isn't working anymore (at least on my machine).

Thanks in advance!

Is this on macOS or Windows?  Which OS version number?

Thanks,

-Kirk

Offline rienvanham

  • Member
  • **
  • Posts: 55
    • View Profile
Re: Auto advance stops after changing folder
« Reply #4 on: January 02, 2020, 12:12:57 AM »
Hi Kirk,

Windows 10 Pro, Dutch edition, version 1909 (build 18363.535).

Rien.

Offline Bob Russell

  • Camera Bits Staff
  • Full Member
  • *****
  • Posts: 137
    • View Profile
    • Camera Bits, Inc.
Re: Auto advance stops after changing folder
« Reply #5 on: January 02, 2020, 11:41:23 AM »
Hi Rien,

  I tested your workflow on my W10 PCs and so far the Preview window's auto advance when adding a color label, rating or tag is working correctly.  When you add a label in the Preview window and Photo Mechanic does not auto advance to the next image, does the label get applied to the matching thumbnail on the contact sheet?    If Photo Mechanic is unable to write the label, then that could be why it is not auto advancing in the Preview window.  What type of files are you working with and are they on an internal or external drive?

Thanks,

--Bob

Offline rienvanham

  • Member
  • **
  • Posts: 55
    • View Profile
Re: Auto advance stops after changing folder
« Reply #6 on: January 02, 2020, 02:13:17 PM »
Hi Bob,

Perhaps it has something to do with the use of 2 monitors:

I think that I found out when it doesn't work:

1: Start PM (on my right monitor)
2: Click a photo
3: Colorise the photo (e.g. 2): no advance takes place.

What works for me:
1: Doubleclick a photo so that a large preview is shown on my second (left) monitor;
2: Select a thumbnail in the bottom part of the (left) monitor;
3: Colorise the photo (e.g. 2): advance takes place!


So:
Colorizing in the contactsheet doesn't work; in the previewmode it does!

Thanks in advance!


Rien.


« Last Edit: January 02, 2020, 11:58:57 PM by rienvanham »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23143
    • View Profile
    • Camera Bits, Inc.
Re: Auto advance stops after changing folder
« Reply #7 on: January 05, 2020, 01:01:10 AM »
Rien,

Perhaps it has something to do with the use of 2 monitors:

I think that I found out when it doesn't work:

1: Start PM (on my right monitor)
2: Click a photo
3: Colorise the photo (e.g. 2): no advance takes place.

What works for me:
1: Doubleclick a photo so that a large preview is shown on my second (left) monitor;
2: Select a thumbnail in the bottom part of the (left) monitor;
3: Colorise the photo (e.g. 2): advance takes place!


So:
Colorizing in the contactsheet doesn't work; in the previewmode it does!

The advancement feature only occurs when changing rating/tag/color class from the Preview window, not the Contact Sheet window.

If you're changing the color class in the Contact Sheet window (grid of images) then no advancement will occur.  This expected.

-Kirk

Offline rienvanham

  • Member
  • **
  • Posts: 55
    • View Profile
Re: Auto advance stops after changing folder
« Reply #8 on: January 05, 2020, 03:14:20 AM »
Hi Kirk,

Thanks for your reply. I can live with that but please consider a consequent behavior through all modes.

Cheers,
Rien.

Offline rienvanham

  • Member
  • **
  • Posts: 55
    • View Profile
Re: Auto advance stops after changing folder
« Reply #9 on: January 05, 2020, 03:18:24 AM »
Hi Kirk,

Perhaps I found an issue:

If the View Crop (P) is turned on no automatic advance takes place.

Is this by design or perhaps an issue?

Thank you!


Rien

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23143
    • View Profile
    • Camera Bits, Inc.
Re: Auto advance stops after changing folder
« Reply #10 on: January 05, 2020, 08:40:10 PM »
Rien,

Perhaps I found an issue:

If the View Crop (P) is turned on no automatic advance takes place.

Is this by design or perhaps an issue?

View Crop is a modal state, no color class, tagging or rating can occur while in this mode.

-Kirk