Author Topic: PM6 swallowing letters  (Read 6229 times)

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21430
    • View Profile
    • Camera Bits, Inc.
Re: PM6 swallowing letters
« Reply #30 on: June 24, 2019, 06:13:42 PM »
Joel,

Any joy on replicating this at the Camerabits end?
I was tagging photos "1" and "2" the other day and half the 1s weren't registering. Might be me going out of my mind but I was doing this to images stored locally and expected immediate responses so at first I put this down to sluggishness but no, I'd hit it again and then it'd respond.
Thanks.

No, we have not been able to reproduce this problem on any of our systems.  If you can come up with a set of steps/conditions that fairly reliably reproduces the problem then that would be most appreciated.

Thanks,

-Kirk

Offline photosbyrob

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: PM6 swallowing letters
« Reply #31 on: January 21, 2020, 09:21:49 AM »
I am still having this issue and have been using PM5 for the last 10 months even though I purchased PM6. It is kind of a bummer that I can't use PM6.

I have continued testing on my side. It happens on my RAID and my SSD. One of the weird things that I noticed is that it is not picking up the initial keypress but, if I continue to hold the key, subsequent keystrokes are registered. For example, if I press right sometimes nothing happens but if I keep holding right, after that 1 second delay the images will start advancing. Really weird right? So it knows I pressed a key, it just doesn't register what I am telling it to do. For me, this only happens with arrow keys and my rating keys (1 and 0).

Does anyone have anything else that I can try? Is there a fix for this somewhere that I don't know about?

I do have one work-around. If I put the Navigator on one monitor and the Preview on my second monitor and then click on the image in the Navigator and use my left / right / 1 / 0 keys in that window - they don't get swallowed. You lose functionality like 'auto-advance' but you CAN use PM6 and it is SO much better than PM5. I hope this helps someone.
« Last Edit: January 21, 2020, 09:37:49 AM by photosbyrob »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21430
    • View Profile
    • Camera Bits, Inc.
Re: PM6 swallowing letters
« Reply #32 on: January 21, 2020, 10:04:00 AM »
Rob,

I am still having this issue and have been using PM5 for the last 10 months even though I purchased PM6. It is kind of a bummer that I can't use PM6.

I have continued testing on my side. It happens on my RAID and my SSD. One of the weird things that I noticed is that it is not picking up the initial keypress but, if I continue to hold the key, subsequent keystrokes are registered. For example, if I press right sometimes nothing happens but if I keep holding right, after that 1 second delay the images will start advancing. Really weird right? So it knows I pressed a key, it just doesn't register what I am telling it to do. For me, this only happens with arrow keys and my rating keys (1 and 0).

Does anyone have anything else that I can try? Is there a fix for this somewhere that I don't know about?

I do have one work-around. If I put the Navigator on one monitor and the Preview on my second monitor and then click on the image in the Navigator and use my left / right / 1 / 0 keys in that window - they don't get swallowed. You lose functionality like 'auto-advance' but you CAN use PM6 and it is SO much better than PM5. I hope this helps someone.

That's some new information that makes me think that somehow the Preview window loses focus until keyboard repeat events come in?  If when you notice the Preview window isn't responding, rather than holding down the key, could you try and see what UI element has keyboard focus?  Pressing the Tab key should move keyboard focus from one UI element to the next (you may then be able to see what UI element is highlighted).  Also, if you use your mouse to click on the photo (instead of holding the key down), do the keys start working again?

We have been unable to reproduce this problem in house.  If I can reproduce a problem then I can usually fix it in short order.

Thanks,

-Kirk

Offline photosbyrob

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: PM6 swallowing letters
« Reply #33 on: January 21, 2020, 12:08:08 PM »
That's some new information that makes me think that somehow the Preview window loses focus until keyboard repeat events come in?  If when you notice the Preview window isn't responding, rather than holding down the key, could you try and see what UI element has keyboard focus?  Pressing the Tab key should move keyboard focus from one UI element to the next (you may then be able to see what UI element is highlighted).  Also, if you use your mouse to click on the photo (instead of holding the key down), do the keys start working again?

We have been unable to reproduce this problem in house.  If I can reproduce a problem then I can usually fix it in short order.

Thanks,

-Kirk

Kirk,

So, to replicate this on my system I just clicked on the preview window. I started pressing the left arrow key until I had a key-press and the image didn't move. I let go of the left arrow key and pressed tab - nothing happened. The preview window has focus but pressing tab doesn't change anything that I can see.

The very next keypress after a "dead key press" or an "eaten key press" works. Just continuing to hold the key after the "dead key press" or "eaten key press" works - it just ignores the "first press" and then keeps on as if nothing is wrong.

Would it help if I recorded a video of what is happening with my keyboard in the foreground and the preview pane in the background?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21430
    • View Profile
    • Camera Bits, Inc.
Re: PM6 swallowing letters
« Reply #34 on: January 21, 2020, 12:53:39 PM »
That's some new information that makes me think that somehow the Preview window loses focus until keyboard repeat events come in?  If when you notice the Preview window isn't responding, rather than holding down the key, could you try and see what UI element has keyboard focus?  Pressing the Tab key should move keyboard focus from one UI element to the next (you may then be able to see what UI element is highlighted).  Also, if you use your mouse to click on the photo (instead of holding the key down), do the keys start working again?

We have been unable to reproduce this problem in house.  If I can reproduce a problem then I can usually fix it in short order.

Thanks,

-Kirk

Kirk,

So, to replicate this on my system I just clicked on the preview window. I started pressing the left arrow key until I had a key-press and the image didn't move. I let go of the left arrow key and pressed tab - nothing happened. The preview window has focus but pressing tab doesn't change anything that I can see.

The very next keypress after a "dead key press" or an "eaten key press" works. Just continuing to hold the key after the "dead key press" or "eaten key press" works - it just ignores the "first press" and then keeps on as if nothing is wrong.

Would it help if I recorded a video of what is happening with my keyboard in the foreground and the preview pane in the background?

Possibly.  We received one like you described but the quality was so low as to make it impossible to quite tell what was going on.  Can you tell me more about your system?

Thanks,

-Kirk

Offline photosbyrob

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: PM6 swallowing letters
« Reply #35 on: January 21, 2020, 01:03:23 PM »
Possibly.  We received one like you described but the quality was so low as to make it impossible to quite tell what was going on.  Can you tell me more about your system?

Thanks,

-Kirk

I am running Windows 10 with the latest update. I am using a wired keyboard and a wired mouse. I can use PM5 without the "dead key" or the "eaten key" issue. I have been working quite a while using the Navigator and it has been working perfectly I am only getting the "dead key" / "eaten key" issue in the Preview window. I am going to try and setup a little camera, should I just link to it here or send it to you directly?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21430
    • View Profile
    • Camera Bits, Inc.
Re: PM6 swallowing letters
« Reply #36 on: January 21, 2020, 01:18:00 PM »
Possibly.  We received one like you described but the quality was so low as to make it impossible to quite tell what was going on.  Can you tell me more about your system?

I am running Windows 10 with the latest update. I am using a wired keyboard and a wired mouse. I can use PM5 without the "dead key" or the "eaten key" issue. I have been working quite a while using the Navigator and it has been working perfectly I am only getting the "dead key" / "eaten key" issue in the Preview window.

When you say "using the Navigator", what part of the UI are you talking about?  The thumbnail strip in the Preview window?  The filesystem tree in the Contact Sheet window (named Navigator), or the Contact Sheet (grid of thumbnails)?

I am going to try and setup a little camera, should I just link to it here or send it to you directly?

Probably best if you put it somewhere like Dropbox and send me a link privately.

Thanks,

-Kirk

Offline photosbyrob

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: PM6 swallowing letters
« Reply #37 on: January 21, 2020, 04:00:30 PM »
When you say "using the Navigator", what part of the UI are you talking about?  The thumbnail strip in the Preview window?  The filesystem tree in the Contact Sheet window (named Navigator), or the Contact Sheet (grid of thumbnails)?

I am going to try and setup a little camera, should I just link to it here or send it to you directly?

Probably best if you put it somewhere like Dropbox and send me a link privately.

Thanks,

-Kirk

Kirk,

Thank you for being so patient with me - even though I have been using PM for years and I am still amateur status. So, for my workflow, I use the Contact Sheet (the grid) and the Preview Window. When I was referencing the "Navigator" I should have said the contact sheet.

I will put together a little video tomorrow so that you can see what I am seeing. I will include a clip of the workaround but keeping the focus on the Contact Sheet which doesn't eat the keypresses like the Preview window does.

Thank you for sticking with this to try and get us a fix, I really appreciate it!

Offline photosbyrob

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: PM6 swallowing letters
« Reply #38 on: January 22, 2020, 07:56:23 AM »
Kirk,

Ok, I set up my cell to record the screen and my keyboard this morning. I might need to setup my camera as the quality on this might not be good enough for you to see what is going on - you just tell me what you need.

Here is a link to the issue happening on my end. It took about a minute. https://drive.google.com/open?id=1ECQ4PCkZzyJa9Zlyho54OVQRg4Lgfy3H

Let me know if you need a higher quality video, if I can show you a different angle, or if you want to know more about my hardware.

*edit to link to the high-resolution video

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21430
    • View Profile
    • Camera Bits, Inc.
Re: PM6 swallowing letters
« Reply #39 on: January 22, 2020, 02:30:48 PM »
Thank you for the video, Rob.

While I can't spot why the problem is happening to you, I have made a build that removes some code that may affect the problem.  I'd like for you to try it out:

https://www.camerabits.com/download/PM6SetupR4201_876ccb12.msi

Please install this version and see if the problem persists.  Note: some features like "Reverse Geocoding" and "Send Photos via Email" may not work correctly in this build but the Preview window and Contact Sheet should work fine.

Thanks,

-Kirk

Offline photosbyrob

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: PM6 swallowing letters
« Reply #40 on: January 22, 2020, 06:06:22 PM »
Thank you for the video, Rob.

While I can't spot why the problem is happening to you, I have made a build that removes some code that may affect the problem.  I'd like for you to try it out:

https://www.camerabits.com/download/PM6SetupR4201_876ccb12.msi

Please install this version and see if the problem persists.  Note: some features like "Reverse Geocoding" and "Send Photos via Email" may not work correctly in this build but the Preview window and Contact Sheet should work fine.

Thanks,

-Kirk

On it sir!