Author Topic: {fbas}  (Read 2508 times)

Offline Goos van der Veen

  • Member
  • **
  • Posts: 59
    • View Profile
    • www.goosvanderveen.com
{fbas}
« on: May 05, 2020, 08:37:37 AM »
Often (but not always) when I type {fbas}, spelling control kicks in and removes the f. Not a big deal, but still a bit annoying...

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24220
    • View Profile
    • Camera Bits, Inc.
Re: {fbas}
« Reply #1 on: May 05, 2020, 08:59:16 AM »
Often (but not always) when I type {fbas}, spelling control kicks in and removes the f. Not a big deal, but still a bit annoying...

Which OS are you running Photo Mechanic on?

-Kirk

Offline Goos van der Veen

  • Member
  • **
  • Posts: 59
    • View Profile
    • www.goosvanderveen.com
Re: {fbas}
« Reply #2 on: May 06, 2020, 03:26:58 AM »
Mojave, but it happened many times before in previous versions, and I think also in PM5. I was too lazy to report it earlier, but a couple of days ago it got me in serious trouble.
My OS is in Dutch, and 'bas' is a common word in Dutch (means 'bass'), so that may be the culprit.

UPDATE!
I found the solution: If you open Edit / Spelling / Show Spelling and Grammar you can add words to the thesaurus by typing the word and click the learn button. So I just learned Spelling to accept fbas, and it seems to work everywhere now.

But:
The reason I had not found this option before is that, when you have the Metadata (IPTC) screen open and you open the Show Spelling and Grammar dialog, the latter opens BEHIND the Metadata (IPTC) screen. This gives the user the impression you can't use it when the Metadata (IPTC) screen is active. My advice: the latest pop-up screen should always be on top.


Offline Graham1

  • Full Member
  • ***
  • Posts: 147
    • View Profile
Re: {fbas}
« Reply #3 on: May 13, 2020, 04:15:56 PM »
Quote
The reason I had not found this option before is that, when you have the Metadata (IPTC) screen open and you open the Show Spelling and Grammar dialog, the latter opens BEHIND the Metadata (IPTC) screen. This gives the user the impression you can't use it when the Metadata (IPTC) screen is active. My advice: the latest pop-up screen should always be on top.

It seems there is a similar issue with the Mac version, and it is not just the Windows version with one window opening behind another, as I thought might be the case.  I have recently made a support request in relation to the Metadata (IPTC) window opening behind the Structured Keywords panel.  I agree that the latest window to be opened should show on top, and more generally any window should be capable of being selected and come to the top of whatever other windows within PM happen to be open at the time.

Graham