Author Topic: PM6 hanging/not responding when switching from other programs - Windows10  (Read 722 times)

Offline erchdk

  • Newcomer
  • *
  • Posts: 6
    • View Profile
I usually leave my PM6 running at all times, with 4 contact sheets open (my different photo archives around 1500 photos max in one folder). I often experience that when I have been working in different programs, browsing or emailing and alt+tab back to PM6 to locate a photo, PM6 hangs and write not responding in the appbar. It lasts typically 20s+/- and sometimes the app interface looks at it is scaled down. I run a pretty strong laptop (win10, 64bit, 48gb, i7-8750H cpu, 4k and nvidia GTX 1050 wtih 4gb) so wonder why this happens. I have shut down often and restarted, cleared the cache but still get this behaviour. Any insights to how I can minimize the hangs would be appreciated.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21938
    • View Profile
    • Camera Bits, Inc.
I usually leave my PM6 running at all times, with 4 contact sheets open (my different photo archives around 1500 photos max in one folder). I often experience that when I have been working in different programs, browsing or emailing and alt+tab back to PM6 to locate a photo, PM6 hangs and write not responding in the appbar. It lasts typically 20s+/- and sometimes the app interface looks at it is scaled down. I run a pretty strong laptop (win10, 64bit, 48gb, i7-8750H cpu, 4k and nvidia GTX 1050 wtih 4gb) so wonder why this happens. I have shut down often and restarted, cleared the cache but still get this behaviour. Any insights to how I can minimize the hangs would be appreciated.

It's probably one or more of the following:

1) When you resume PM, the first thing it tries to do is rescan all of the folders open in each of the contact sheets.  If they're slow to scan for new, deleted, or changed files then that will cause a pause.
2) When you resume PM it is possible that while you were using other apps, PM's address space may have been paged out to virtual memory.  This can produce a significant delay.

-Kirk

Offline erchdk

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Thanks Kirk. So any suggestion as to what I can do, or is it just as it is?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21938
    • View Profile
    • Camera Bits, Inc.
Thanks Kirk. So any suggestion as to what I can do, or is it just as it is?

If the problem is #2, you'll need to figure out which of your other applications is using so much memory.
For problem #1, you can turn off the "Rescan on resume" checkbox in the "Contact Sheet" page of the Preferences dialog (Edit->Preferences...).  You will now need to manually force a rescan when you think the contents of the folders you're browsing have changed.  You can do this by choosing the "Rescan" command on the "View" menu.

-Kirk

Offline erchdk

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Thanks again. I do have a system with 48gb, but only 4gb allocated for memory cache size in PM6 preferences. I will try to expand the cache and try the first option and see how that works out for me.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21938
    • View Profile
    • Camera Bits, Inc.
Thanks again. I do have a system with 48gb, but only 4gb allocated for memory cache size in PM6 preferences. I will try to expand the cache and try the first option and see how that works out for me.

A 4GB memory cache is plenty.  Raising it would only increase the likelihood of causing virtual memory paging to occur.

-Kirk