Author Topic: Colour class and ratings settings not showing up in lightroom  (Read 649 times)

Offline Craig_S44

  • Newcomer
  • *
  • Posts: 20
    • View Profile
Colour class and ratings settings not showing up in lightroom
« on: August 17, 2020, 09:33:07 PM »
Hi,

As the subject line says, I can not see the colour classes that I have set in PM6 (build 4851) when I import them into Lightroom Classis (9.3)

I have set the preferences in PM6 to use the appropriate Colour Class option (see screengrab) but it does not show the colours or the star ratings when I import them into Lightroom.

Can anyone help with this?

Thanks,

Craig


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21953
    • View Profile
    • Camera Bits, Inc.
Re: Colour class and ratings settings not showing up in lightroom
« Reply #1 on: August 18, 2020, 09:21:32 AM »
Craig,

As the subject line says, I can not see the colour classes that I have set in PM6 (build 4851) when I import them into Lightroom Classis (9.3)

I have set the preferences in PM6 to use the appropriate Colour Class option (see screengrab) but it does not show the colours or the star ratings when I import them into Lightroom.

Do your Lightroom Classic color labels match those that you have set in Photo Mechanic?  The settings we provided are the default color label names that Lightroom uses, but if you've changed your Lightroom color label names you'll have to use the same names in Photo Mechanic and not the presets.

-Kirk

Offline Craig_S44

  • Newcomer
  • *
  • Posts: 20
    • View Profile
Re: Colour class and ratings settings not showing up in lightroom
« Reply #2 on: August 20, 2020, 07:17:29 PM »
Hi Kirk,

Thanks for your reply,

The color names in lightroom do appear to match PM - and TBH I don't even know how to change them in LR, but still no luck.  Does not see the colour class or the star ratings.

Any ideas?

Craig

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21953
    • View Profile
    • Camera Bits, Inc.
Re: Colour class and ratings settings not showing up in lightroom
« Reply #3 on: August 20, 2020, 08:59:22 PM »
Craig,

The color names in lightroom do appear to match PM - and TBH I don't even know how to change them in LR, but still no luck.  Does not see the colour class or the star ratings.

Has Lightroom already seen the photos (imported them) before you changed the color labels in PM?  If so, you need to force Lightroom to read the changes (otherwise it relies on the metadata in the database/library).  Select your changed images and then use the "Read Metadata from Files" command on the Metadata menu.

HTH,

-Kirk

Offline Craig_S44

  • Newcomer
  • *
  • Posts: 20
    • View Profile
Re: Colour class and ratings settings not showing up in lightroom
« Reply #4 on: October 22, 2020, 09:41:25 PM »
I had let this go as I could not work it out and while trying to solve another issue - happened upon the solution.  It turns out that an import preset for metadata that I have in lightroom was set to over ride Colour and Rating labels with nothing at all.  Once I unchecked those boxes, it all started to work again.  Thought I would mention it here incase it could help anyone else.

Craig