Author Topic: Topaz DeNoise AI images not displaying  (Read 640 times)

Offline PJ

  • Newcomer
  • *
  • Posts: 38
    • View Profile
Topaz DeNoise AI images not displaying
« on: September 20, 2020, 01:29:43 AM »
Not sure if this is a Topaz problem or an issue with PM (6.0. build 5029). When using Topaz DeNoise AI 2.2.11 as a standalone and processing either a NEF or DNG image, the preview/thumbnail doesn't show up in PM if the saved output choices selected are DNG or JPG (PNG and JPEG will show the thumbnail image correctly in PM).

My preference is to use a DNG image from DeNoise AI, be able to view it in PM and then be able to open it in Photoshop/Camera Raw for processing.

Any idea why the image does not display; it is simply grayed out in the PM window (see attachment).

This is on a Mac running Sierra 10.12.6.

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 22272
    • View Profile
    • Camera Bits, Inc.
Re: Topaz DeNoise AI images not displaying
« Reply #1 on: September 20, 2020, 09:31:05 AM »
Not sure if this is a Topaz problem or an issue with PM (6.0. build 5029). When using Topaz DeNoise AI 2.2.11 as a standalone and processing either a NEF or DNG image, the preview/thumbnail doesn't show up in PM if the saved output choices selected are DNG or JPG (PNG and JPEG will show the thumbnail image correctly in PM).

My preference is to use a DNG image from DeNoise AI, be able to view it in PM and then be able to open it in Photoshop/Camera Raw for processing.

Any idea why the image does not display; it is simply grayed out in the PM window (see attachment).

This is on a Mac running Sierra 10.12.6.

I expect that those DNG files do not contain JPEG previews in them.  Photo Mechanic uses the embedded JPEG previews found in most DNGs to show you what the DNG looks like.  Check the preferences in the Topaz app and see if it has a setting that will cause it to provide previews/thumbnails in the DNGs it produces.

HTH,

-Kirk

Offline PJ

  • Newcomer
  • *
  • Posts: 38
    • View Profile
Re: Topaz DeNoise AI images not displaying
« Reply #2 on: September 22, 2020, 03:03:08 PM »
Thanks Kirk.

Here's the reply I got from Topaz (which indicates a small jpeg should be in the file):

"We don't test or support anything in particular with PhotoMechanic, so I'm not 100% sure what might be happening, but in other places were a JPG preview is needed, our files will show one. The dimensions are also included in the exif data. Usually 270 x 180 or so. It varies. As far as controls, there are no particular settings within the program itself to control this behavior I'm afraid."


They asked if I had another program I could test it on and unfortunately I don't. I may just have to settle for using a jpeg rather than a dng.

pj

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 22272
    • View Profile
    • Camera Bits, Inc.
Re: Topaz DeNoise AI images not displaying
« Reply #3 on: September 22, 2020, 04:10:09 PM »
Thanks Kirk.

Here's the reply I got from Topaz (which indicates a small jpeg should be in the file):

"We don't test or support anything in particular with PhotoMechanic, so I'm not 100% sure what might be happening, but in other places were a JPG preview is needed, our files will show one. The dimensions are also included in the exif data. Usually 270 x 180 or so. It varies. As far as controls, there are no particular settings within the program itself to control this behavior I'm afraid."


They asked if I had another program I could test it on and unfortunately I don't. I may just have to settle for using a jpeg rather than a dng.

That would be a tiny preview anyway and wouldn't be suitable for anything but a low resolution thumbnail.

You can run DNGs through Adobe's DNG Converter and it will produce new DNGs with up to a full resolution preview.  But that's an added step that I'm sure you'd like to avoid.

-Kirk

Offline mklass

  • Sr. Member
  • ****
  • Posts: 342
    • View Profile
    • Mick Klass Photography
Re: Topaz DeNoise AI images not displaying
« Reply #4 on: September 24, 2020, 04:25:02 AM »
Topaz Ai apps, while very good, also mess up the EXIF data such that information is lost to PM. Topaz really needs to make their apps create files that are more "industry standard". This is either something they have not thought about, or it is not a high priority.