Author Topic: Preview Generation Stuck  (Read 1446 times)

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 22290
    • View Profile
    • Camera Bits, Inc.
Re: Preview Generation Stuck
« Reply #15 on: December 31, 2020, 10:07:18 AM »
Michael,

Without going through all 25,728, it's fair to say none of them are rendering.

To be clear, you've opened the folder containing one or more of these images (not via any interaction with the Catalog UI) in Photo Mechanic Plus (via the Open Contact Sheet... command on the File menu, or by using the Navigator/Favorites, or via drag and drop from the Finder) and the image(s) aren't rendering?

-Kirk

Offline Michael Naylor

  • Newcomer
  • *
  • Posts: 36
    • View Profile
    • Michael Naylor Fine Art Photography
Re: Preview Generation Stuck
« Reply #16 on: December 31, 2020, 10:20:20 AM »
Michael,

Without going through all 25,728, it's fair to say none of them are rendering.

To be clear, you've opened the folder containing one or more of these images (not via any interaction with the Catalog UI) in Photo Mechanic Plus (via the Open Contact Sheet... command on the File menu, or by using the Navigator/Favorites, or via drag and drop from the Finder) and the image(s) aren't rendering?

-Kirk

To be perfectly clear, the files render fine in LR and the Mac Finder.   In PM+ they do not render from Browse/File Type/Unreadable File Format (????), or from Browse/Folder Path/Users/...

Michael

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 22290
    • View Profile
    • Camera Bits, Inc.
Re: Preview Generation Stuck
« Reply #17 on: December 31, 2020, 10:26:16 AM »
Michael,

Without going through all 25,728, it's fair to say none of them are rendering.

To be clear, you've opened the folder containing one or more of these images (not via any interaction with the Catalog UI) in Photo Mechanic Plus (via the Open Contact Sheet... command on the File menu, or by using the Navigator/Favorites, or via drag and drop from the Finder) and the image(s) aren't rendering?

-Kirk

To be perfectly clear, the files render fine in LR and the Mac Finder.   In PM+ they do not render from Browse/File Type/Unreadable File Format (????), or from Browse/Folder Path/Users/...

OK, but I want to know if the non-Catalog portions of Photo Mechanic Plus are able to render your images.  I want you to open the folder containing one or more of those images in a folder-based contact sheet and see if they have problems rendering there too.  I need more information that only you can provide in order to help you further.  Please take one of those images that you see render fine in the Finder and drag and drop it onto the Photo Mechanic Plus icon in the Dock.  The folder containing that image will then be opened and the image dropped should be selected.  Please let me know if it renders or not.  If it does not render, then can you share it with me so that I can find out why our software cannot handle it?

Thanks,

-Kirk

Offline Michael Naylor

  • Newcomer
  • *
  • Posts: 36
    • View Profile
    • Michael Naylor Fine Art Photography
Re: Preview Generation Stuck
« Reply #18 on: December 31, 2020, 10:39:07 AM »
Kirk,

From the non-catalogue Navigator the files render ok.  Drag and drop it onto the Photo Mechanic Plus icon in the Dock also renders ok.
Michael

Offline Michael Naylor

  • Newcomer
  • *
  • Posts: 36
    • View Profile
    • Michael Naylor Fine Art Photography
Re: Preview Generation Stuck
« Reply #19 on: December 31, 2020, 11:50:24 AM »
Kirk,

For your info...  I tried stopping the Preview Generation - it won't.   It seems rjh1007 has a similar problem.

Happy New Year.
Michael

Offline Michael Naylor

  • Newcomer
  • *
  • Posts: 36
    • View Profile
    • Michael Naylor Fine Art Photography
Re: Preview Generation Stuck
« Reply #20 on: December 31, 2020, 11:52:41 AM »
Kirk,

P.S.  Moments later PM+ crashed...

[Thu 20:50:59] Error: ProxyUploadTask.try_spawn_proxy_upload: error: image_resize_batch failed: [:rpc_timeout]
Michael

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 22290
    • View Profile
    • Camera Bits, Inc.
Re: Preview Generation Stuck
« Reply #21 on: December 31, 2020, 01:45:42 PM »
Michael,

From the non-catalogue Navigator the files render ok.  Drag and drop it onto the Photo Mechanic Plus icon in the Dock also renders ok.

Excellent.  Thank you.

I know you're eager to get all of this resolved and we will resolve this issue and the issues others are having with stalled preview generation, missing thumbnails with red titles, etc. when we get back from vacation next week.

-Kirk

Offline SteveMattan

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: Preview Generation Stuck
« Reply #22 on: January 01, 2021, 10:15:27 AM »
It seems the image that did not have a preview created for it is a .psd file from 2006.

The image does appear on the contact sheet, albeit with the filename in red. Attempting to view the image results in an "Unable to Render Image" message.

The image does open in Photoshop (current version). It does not render via Quicklook in the Finder.

The error message under Catalog Status is:

"[Thu 12:43:01] {"cmd"=>"proxy_gen", "file"=>"/Volumes/Derivatives/Derivatives/DRV_0002/Pleiades Occultation/SteveMattan_20060401_8394.psd", "msg"=>"nogvl_bitmap_load_scaled: NRFError: 10"}
[Thu 12:43:01] Error: gen_local_proxy_batch: failed to generate proxy image for: "amdoc://bd8ea719-bc1b-4f0e-42c5-e77dedf1d604/Derivatives/DRV_0002/Pleiades%20Occultation/SteveMattan_20060401_8394.psd" - "/Volumes/Derivatives/Derivatives/DRV_0002/Pleiades Occultation/SteveMattan_20060401_8394.psd" - "nogvl_bitmap_load_scaled: NRFError: 10""

Hope this helps.

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 22290
    • View Profile
    • Camera Bits, Inc.
Re: Preview Generation Stuck
« Reply #23 on: January 01, 2021, 01:52:55 PM »
Steve,

It seems the image that did not have a preview created for it is a .psd file from 2006.

The image does appear on the contact sheet, albeit with the filename in red. Attempting to view the image results in an "Unable to Render Image" message.

The image does open in Photoshop (current version). It does not render via Quicklook in the Finder.

The error message under Catalog Status is:

"[Thu 12:43:01] {"cmd"=>"proxy_gen", "file"=>"/Volumes/Derivatives/Derivatives/DRV_0002/Pleiades Occultation/SteveMattan_20060401_8394.psd", "msg"=>"nogvl_bitmap_load_scaled: NRFError: 10"}
[Thu 12:43:01] Error: gen_local_proxy_batch: failed to generate proxy image for: "amdoc://bd8ea719-bc1b-4f0e-42c5-e77dedf1d604/Derivatives/DRV_0002/Pleiades%20Occultation/SteveMattan_20060401_8394.psd" - "/Volumes/Derivatives/Derivatives/DRV_0002/Pleiades Occultation/SteveMattan_20060401_8394.psd" - "nogvl_bitmap_load_scaled: NRFError: 10""

You'll need to resave that file with "Maximize Compatibility" enabled.  This causes Photoshop to embed a preview for all of the layers/effects in your PSD file so that applications that don't have access to Adobe's proprietary rendering technology (like us and the Finder) can preview the image.

-Kirk

Offline SteveMattan

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: Preview Generation Stuck
« Reply #24 on: January 03, 2021, 07:21:27 AM »
Steve,

... snip previos quoted messages ...

You'll need to resave that file with "Maximize Compatibility" enabled.  This causes Photoshop to embed a preview for all of the layers/effects in your PSD file so that applications that don't have access to Adobe's proprietary rendering technology (like us and the Finder) can preview the image.

-Kirk

Thanks. Done and fixed. And thanks for replying while you're supposed to be on holiday break.

Note that the Catalog Status window still reports the error, even after re-syncing and resolving the preview issue.

And of course there is the initial issue of the preview generation stalling multiple times that I know you are looking into. Let me know if you need any additional info on that from me.

Stay well.

SteveM

Offline Michael Naylor

  • Newcomer
  • *
  • Posts: 36
    • View Profile
    • Michael Naylor Fine Art Photography
Re: Preview Generation Stuck
« Reply #25 on: January 09, 2021, 01:57:23 AM »
For more than 24 hours the Preview Generation has been stuck at 2555 batches remaining (0.2/sec, set. 2.9 hours).  If this is not a PM+ bug, could this have something to do with some of my images (size, corruption, etc) and how can I figure out which ones?
Does the New Unofficial Build 5465 address this issue?  For at the moment, I don't have the confidence to begin using PM+ in earnest.
Michael

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 22290
    • View Profile
    • Camera Bits, Inc.
Re: Preview Generation Stuck
« Reply #26 on: January 09, 2021, 07:16:45 AM »
Michael,

For more than 24 hours the Preview Generation has been stuck at 2555 batches remaining (0.2/sec, set. 2.9 hours).  If this is not a PM+ bug, could this have something to do with some of my images (size, corruption, etc) and how can I figure out which ones?
Does the New Unofficial Build 5465 address this issue?  For at the moment, I don't have the confidence to begin using PM+ in earnest.

No, it does not.  We still need help reproducing the problem.  Would it be possible for you to share the images that cause PM Plus to stall when generating previews?

-Kirk

Offline Michael Naylor

  • Newcomer
  • *
  • Posts: 36
    • View Profile
    • Michael Naylor Fine Art Photography
Re: Preview Generation Stuck
« Reply #27 on: January 09, 2021, 07:30:38 AM »
Michael,

For more than 24 hours the Preview Generation has been stuck at 2555 batches remaining (0.2/sec, set. 2.9 hours).  If this is not a PM+ bug, could this have something to do with some of my images (size, corruption, etc) and how can I figure out which ones?
Does the New Unofficial Build 5465 address this issue?  For at the moment, I don't have the confidence to begin using PM+ in earnest.

No, it does not.  We still need help reproducing the problem.  Would it be possible for you to share the images that cause PM Plus to stall when generating previews?

-Kirk
It would be possible if PM+ produced a log.
Michael

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 22290
    • View Profile
    • Camera Bits, Inc.
Re: Preview Generation Stuck
« Reply #28 on: January 09, 2021, 10:30:43 AM »
Michael,

For more than 24 hours the Preview Generation has been stuck at 2555 batches remaining (0.2/sec, set. 2.9 hours).  If this is not a PM+ bug, could this have something to do with some of my images (size, corruption, etc) and how can I figure out which ones?
Does the New Unofficial Build 5465 address this issue?  For at the moment, I don't have the confidence to begin using PM+ in earnest.

No, it does not.  We still need help reproducing the problem.  Would it be possible for you to share the images that cause PM Plus to stall when generating previews?

It would be possible if PM+ produced a log.

If you turn on CATALOG_DEBUG_LOGGING, it should produce a substantial log.

-Kirk

Offline Michael Naylor

  • Newcomer
  • *
  • Posts: 36
    • View Profile
    • Michael Naylor Fine Art Photography
Re: Preview Generation Stuck
« Reply #29 on: January 10, 2021, 03:12:20 AM »
Michael,

For more than 24 hours the Preview Generation has been stuck at 2555 batches remaining (0.2/sec, set. 2.9 hours).  If this is not a PM+ bug, could this have something to do with some of my images (size, corruption, etc) and how can I figure out which ones?
Does the New Unofficial Build 5465 address this issue?  For at the moment, I don't have the confidence to begin using PM+ in earnest.

No, it does not.  We still need help reproducing the problem.  Would it be possible for you to share the images that cause PM Plus to stall when generating previews?

It would be possible if PM+ produced a log.

If you turn on CATALOG_DEBUG_LOGGING, it should produce a substantial log.

-Kirk
This was something I did for you last week, so I'll do it again with a new catalog.

I deleted the old catalog, closed PM, and deleted the contents of /Users/mike/Library/Caches/Photo Mechanic, because there were cached TIFF files that (in my opinion) shouldn't have been there, having just deleted the catalog.

After an macOS Restart and disabling energy saving for good measure, I started a Scan to Catalog around 21:20 to a new catalog.  When I checked for progress around 00:45 there were 2579 previews to go.  The next morning around 09:45 there were still 2579 waiting.  In other words, PM was busy doing nothing more than filling up the logs - it was in a continuous loop and going nowhere.

The dyn.log records the first [ERR!] at [2021-01-09 23:34:19.403 Sat] and mentions a missing comma.  I'll leave it to you to decipher it.  I checked the previous batch of images and all render just fine in LR and Quickview.

Lastly, why is PM.log saying it can't open /Users/mike/Pictures/Photos Library.photoslibrary/' due to ERRNO:1 ?  Why does it even want to?  I didn't ask it to. Very odd.

AT THIS POINT in drafting the above text in TextEdit, I launched PM+ again to see if it would continue rendering. It didn't, so I closed PM+.  However, I noticed it had created another log file called din.1.log, so I opened it in TextEdit.  This cause TextEdit to go unresponsive using 100% CPU time.  After awhile I decided to Force Quit TextEdit.  It would appear PM+ had left a process running and was continuing to write the log - consuming more disk space.

If you think I'm becoming pissed off, you'd be right.  After 15 years of development, I did expect something better than this.  However, I will stick with you for a little while longer, but I've better things to do with my time than spend hours, days and weeks reporting bugs.
Michael