Author Topic: How to exclude PM XMP file when using Copy Function  (Read 689 times)

Offline FritzImages

  • Newcomer
  • *
  • Posts: 8
    • View Profile
How to exclude PM XMP file when using Copy Function
« on: September 07, 2021, 08:32:09 AM »
I would like to simply copy only my Raw .NEF images to another folder.  Currently for some reason the PM XMP file is also being copied.  The PM XMP info is not relevant for my work flow.  How can I disable/exclude this file from being included and sent when I select and choose copy raw NEF files.

thanks
« Last Edit: September 07, 2021, 09:01:55 AM by Kirk Baker »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23356
    • View Profile
    • Camera Bits, Inc.
Re: How to exclude PM XMP file when using Copy Function
« Reply #1 on: September 07, 2021, 09:02:34 AM »
I would like to simply copy only my Raw .NEF images to another folder.  Currently for some reason the PM XMP file is also being copied.  The PM XMP info is not relevant for my work flow.  How can I disable/exclude this file from being included and sent when I select and choose copy raw NEF files.

It's not possible to exclude this file.  It contains the metadata that you've applied to your RAW file.  Without it, all of the metadata is lost.

-Kirk

Offline FritzImages

  • Newcomer
  • *
  • Posts: 8
    • View Profile
Re: How to exclude PM XMP file when using Copy Function
« Reply #2 on: September 07, 2021, 10:10:03 AM »
Yes it is possible.... Not sure what is why this is an issue.  I have been using PM for 12 years and this has never been a problem. I have never had sidecar xmp files included with copy command in PM.

IN PM, if I copy a Raw NEF to another folder.  The Raw NEF file moves to the folder. and nothing else, only the NEF shows. This raw NEF file has the camera's XMP .

If however, I use PM and tag that file with a color class then when I copy that file to another folder.  I now get the original NEF file and a sidecar XMP file that includes what I presume is added PM XMP info re: color class.

If I delete this PM XMP sidecar file, then open the raw NEF in capture NX-D, (the best/only raw convertor I have ever used in 15 years) I have all my camera data available.

So somewhere along the line are you dumping/appending info into and creating this new XMP file? And then why do you presume I want this PM info as a sidecar ?

So, again I ask, is there a way the copy function can disabled/exclude the PM XMP sidecar file ? 

thanks
« Last Edit: September 07, 2021, 11:17:38 AM by Kirk Baker »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23356
    • View Profile
    • Camera Bits, Inc.
Re: How to exclude PM XMP file when using Copy Function
« Reply #3 on: September 07, 2021, 11:17:15 AM »
Yes it is possible.... Not sure what is why this is an issue.  I have been using PM for 12 years and this has never been a problem. I have never had sidecar xmp files included with copy command in PM.

IN PM, if I copy a Raw NEF to another folder.  The Raw NEF file moves to the folder. and nothing else, only the NEF shows. This raw NEF file has the camera's XMP .

If however, I use PM and tag that file with a color class then when I copy that file to another folder.  I now get the original NEF file and a sidecar XMP file that includes what I presume is added PM XMP info re: color class.

If I delete this PM XMP sidecar file, then open the raw NEF in capture NX-D, (the best/only raw convertor I have ever used in 15 years) I have all my camera data available.

So somewhere along the line are you dumping/appending info into and creating this new XMP file? And then why do you presume I want this PM info as a sidecar ?

So, again I ask, is there a way the copy function can disabled/exclude the PM XMP sidecar file ? 

No, not if the XMP sidecar file is present.  You can prevent the XMP sidecar file from being produced by Photo Mechanic in the first place though and then there will be no file that needs to be excluded.  It won't exist at all, unless you use some other tools like Adobe software (the XMP sidecar file concept originated with Adobe.)

You will have to change your IPTC/XMP preferences.  In the Photo Mechanic Preferences dialog, use the popup menu near the top of the window and select "IPTC/XMP".  Look in the bottom right-corner for the snapshot button (it has a lightning bolt on it).  Click on it and choose the "[Nikon Capture NX/NX2]" item.  Click the OK button.

Now when you make any metadata changes, they'll be stored as XMP inside the NEF file.  Note: most programs don't have problem with embedded XMP, but some do.

This should fix the issue of having XMP sidecar files being created when making edits to NEF files in Photo Mechanic.  But if you have existing XMP sidecar files, you'll need to remove them.  Doing so without updating the metadata in the NEF file will cause those edits to be lost when the XMP sidecar files are removed.  You can make a simple change like applying a metadata template to add some data to a field (you can clear it later if you'd like) before you remove the XMP sidecar files.

-Kirk


Offline FritzImages

  • Newcomer
  • *
  • Posts: 8
    • View Profile
Re: How to exclude PM XMP file when using Copy Function
« Reply #4 on: September 07, 2021, 11:37:47 AM »
Perfect, That's what I was looking for !   Thanks for understanding my issue, the detailed response and pointing me to a solution.  Even after using PM all these many years, I'm still enjoying learning a thing or two.  Thanks for the your support !!!  :)

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23356
    • View Profile
    • Camera Bits, Inc.
Re: How to exclude PM XMP file when using Copy Function
« Reply #5 on: September 07, 2021, 11:55:35 AM »
You're welcome.

-Kirk