Author Topic: Color label advances very slowly?  (Read 898 times)

Offline nycska

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Color label advances very slowly?
« on: September 13, 2021, 03:53:44 PM »
I switched my focus culling workflow to PM6 for the speed over Lightroom, but have an issue.

Every time I leave the PM6 window, eg to check my email in a browser, all the thumbnails reload when I return to PM6. This causes extremely slow advance time after color labeling an image. Normally advancing to the next image is immediate.

If I scroll through the contact sheet (thousands of images) they all reload and color labeling starts to advance immediately again in the Preview window. This is a deal breaker if I can't get color labeling to advance to the next image without hanging for a few seconds, and I can't very well wait for all the thumbnails to reload after each time leaving the PM6 window.

Please advise. :) I took video if anyone needs a visual lol.

v6.0, build 6026
Win10
« Last Edit: September 13, 2021, 04:24:31 PM by nycska »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23356
    • View Profile
    • Camera Bits, Inc.
Re: Color label advances very slowly?
« Reply #1 on: September 13, 2021, 04:26:33 PM »
I switched my focus culling workflow to PM6 for the speed over Lightroom, but have an issue.

Every time I leave the PM6 window, eg to check my email in a browser, all the thumbnails reload when I return to PM6. This causes extremely slow advance time after color labeling an image. Normally advancing to the next image is immediate.

If I scroll through the contact sheet (thousands of images) they all reload and color labeling starts to advance immediately again in the Preview window. This is a deal breaker if I can't get color labeling to advance to the next image without hanging for a few seconds, and I can't very well wait for all the thumbnails to reload after each time leaving the PM6 window.

Where are the images stored?  Are you changing any files or adding/removing files in the folder that you're browsing while you're switched out of PM?

Note: you can set PM not to rescan the folders being browsed on resume (I expect that this is what is interfering in your workflow).  In the Contact Sheet page of the Preferences dialog, uncheck the "Rescan on resume" checkbox.

-Kirk

Offline nycska

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: Color label advances very slowly?
« Reply #2 on: September 13, 2021, 04:36:43 PM »
Images on a local SSD, no changes to anything. I literally just check my email and when I get back, adding a color label takes like 2 seconds to advance instead of immediately. Waiting an undetermined amount of time in the Preview window eventually allows the advance speed to go back to normal.

I tried that rescan option before I hit send here, and issue persists after relaunching PM6. If I sit here for 20 minutes without touching anything, the labeling advance speed will be immediate again.

Edit: Left Preview window open, went and took a shower. Came back and advance is immediate now lol.
« Last Edit: September 13, 2021, 04:58:34 PM by nycska »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23356
    • View Profile
    • Camera Bits, Inc.
Re: Color label advances very slowly?
« Reply #3 on: September 13, 2021, 04:58:21 PM »
Images on a local SSD, no changes to anything. I literally just check my email and when I get back, adding a color label takes like 2 seconds to advance instead of immediately. Waiting an undetermined amount of time in the Preview window eventually allows the advance speed to go back to normal.

I tried that rescan option before I hit send here, and issue persists after relaunching PM6. If I sit here for 20 minutes without touching anything, the labeling advance speed will be immediate again.

I'd like to see your Photo Mechanic log.  In Photo Mechanic go to the Help menu and choose "Reveal Support Data..." and moments later a Windows Explorer window will come forward with the zipped log file selected.  Use the 'Attachments and other options' link when you're composing your reply to this message and there you'll be able to upload your zipped PM log file.

Thanks,

-Kirk

Offline nycska

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: Color label advances very slowly?
« Reply #4 on: September 13, 2021, 04:59:59 PM »
Log attached.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23356
    • View Profile
    • Camera Bits, Inc.
Re: Color label advances very slowly?
« Reply #5 on: September 13, 2021, 05:44:57 PM »
Log attached.

It looks like you may be affected by virtual memory paging on your system.  I see that your memory cache is 16GB and that your disk cache may also be quite large.  How much memory does your system have?

More isn't always better.  A few hundred MB of memory cache will be better than 16GB of memory cache if your system ends up doing virtual memory paging in order to provide the space in memory.

-Kirk

Offline nycska

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: Color label advances very slowly?
« Reply #6 on: September 13, 2021, 05:54:39 PM »
Interesting. 32gb total. I'll bring those numbers down and see what happens.

Offline nycska

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: Color label advances very slowly?
« Reply #7 on: September 13, 2021, 06:01:34 PM »
The crazy thing is that it starts working if I just sit here in Preview and do nothing, but often times slows down again if I click out to a browser, another program, etc. Does kind of sound like a memory thing.

Thumbnails also reload every launch? Each one happens very quickly but I work with huge volume in each folder. Example image attached where some haven't loaded yet. Is that normal behavior?

Offline nycska

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: Color label advances very slowly?
« Reply #8 on: September 13, 2021, 06:23:54 PM »
Once all those thumbnails are fully loaded, which only happens if I slowly scroll the entire folder, THEN advancing becomes immediate after color labeling in Preview.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23356
    • View Profile
    • Camera Bits, Inc.
Re: Color label advances very slowly?
« Reply #9 on: September 13, 2021, 07:21:04 PM »
Thumbnails also reload every launch? Each one happens very quickly but I work with huge volume in each folder. Example image attached where some haven't loaded yet. Is that normal behavior?

If you have the disk cache set to empty on quit, then yes, the thumbnails will be rebuilt on subsequent launches.

-Kirk

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23356
    • View Profile
    • Camera Bits, Inc.
Re: Color label advances very slowly?
« Reply #10 on: September 13, 2021, 07:24:16 PM »
Once all those thumbnails are fully loaded, which only happens if I slowly scroll the entire folder, THEN advancing becomes immediate after color labeling in Preview.

If you don't have both the Contact Sheet and the Preview windows visible at the same time, you can turn off the "Always make current Preview visible in Contact Sheet" checkbox in the Preview page of the Preferences dialog.  This will keep the Contact Sheet from updating as you move through images in the Preview window.

-Kirk