Author Topic: Smugmug upload not working with private Smugmug folders/galleries  (Read 177 times)

Offline Perttis

  • Newcomer
  • *
  • Posts: 21
    • View Profile
Smugmug upload not working with private Smugmug folders/galleries
« on: September 14, 2021, 10:55:33 PM »
Uploading files to SmugMug dont work if at SmugMug folder is private (not public) and contains galleries
Uploader dont see any folders or galleries below private folder.
Oddly you can create new galleries inside of private folder, but uploader dont see those at all.
This used to work about year ago.

Offline Jerry H

  • Camera Bits Staff
  • Full Member
  • *****
  • Posts: 208
    • View Profile
    • Camera Bits, Inc.
Re: Smugmug upload not working with private Smugmug folders/galleries
« Reply #1 on: September 15, 2021, 09:20:26 AM »
I'm unable to recreate the problem that you are having. Private folders and galleries show up fine for me.

Does forcing a reload, clicking the Reload button, resolve the issue?

Are you using any non-ASCII characters for the gallery names?

-Jerry

Offline Perttis

  • Newcomer
  • *
  • Posts: 21
    • View Profile
Re: Smugmug upload not working with private Smugmug folders/galleries
« Reply #2 on: September 15, 2021, 10:42:59 AM »
I am using only ascii chars, and also reload do not help.
I have even deleted the connection to smugmug and recreated it without any change.
I used as an workaround that I uploaded files to new gallery at "root" which is public, then at Smugmug web inteface moved that gallery under privat folder.
About your test with SmugMug, do you have pro account? (You can fine tune access of the folders more than with basic account)

Offline Jerry H

  • Camera Bits Staff
  • Full Member
  • *****
  • Posts: 208
    • View Profile
    • Camera Bits, Inc.
Re: Smugmug upload not working with private Smugmug folders/galleries
« Reply #3 on: September 15, 2021, 11:10:33 AM »
It looks like our test account is a Pro account.

I sent you a personal message with instructions on how to enable additional logging and where to send the log file. With the additional logging enabled, the log file should have enough information about your folders/galleries to help me resolve the issue.

Do not attach the log here.  It would contain personal information.

-Jerry

« Last Edit: September 15, 2021, 12:10:55 PM by Kirk Baker »

Offline Jerry H

  • Camera Bits Staff
  • Full Member
  • *****
  • Posts: 208
    • View Profile
    • Camera Bits, Inc.
Re: Smugmug upload not working with private Smugmug folders/galleries
« Reply #4 on: September 17, 2021, 08:56:05 AM »
Hi Pertti,

Thank you for the log file.

The SmugMug API returned the error, “Not Found”, yet the Private node clearly exists. I found nothing wrong with the request that Photo Mechanic made to the API. This suggests to me that Photo Mechanic doesn’t have the permissions it needs to access the folder.

I recommend that you check your SmugMug account settings, using your favorite Web Browser, and make certain that Photo Mechanic has Full access to your account. That setting can be found in:
Account Settings -> Privacy -> Authorized Services. The Photo Mechanic 6 service needs to have Full access with Modify permissions.

You can delete the PMDebug.txt, PM.log and PM_log.zip files now.

HTH,
Jerry