Author Topic: Find and replace quit working suddenly  (Read 521 times)

Offline Richard Bledsoe

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Find and replace quit working suddenly
« on: September 21, 2021, 03:09:01 PM »
I am running PM6 Plus build 6026 (6de4cla) on Win10 64 bit (Ver 21H1). I am a new catalog and keyword user. My catalog had over 5000 items and I was reorganizing my keywords to eliminate the similar and redundant. It was going well until I attempted to use find and replace on a group of over 800 selected items. F&R bogged down and quit and I have not been able to resurrect it. I tried all the different settings in the F&R dialog box to no avail. Rebooted computer etc. I then deactivated my computer and reinstalled the app. Nothing. I thought the catalog might be corrupted so I did all the maintenance including re-index, no help. I deleted the catalog and reinstalled the app again and scanned one folder. Still F&R will not find and change a single word.
Screenshots and Zip of the PM Log attached. My best idea at this point is that some file(s) in PM6 Plus got corrupted when F&R hung up and the standard uninstaller is leaving them on my computer, maybe a deep uninstaller like Revo Uninstaller is required to clean out the system.
So please have a look and advise, thank you.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23226
    • View Profile
    • Camera Bits, Inc.
Re: Find and replace quit working suddenly
« Reply #1 on: September 21, 2021, 03:19:57 PM »
Richard,

I see that you're finding in "Selected Items", do you have any photos selected when you begin your find/replace operation?

-Kirk

Offline Richard Bledsoe

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: Find and replace quit working suddenly
« Reply #2 on: September 21, 2021, 04:31:08 PM »
Yes, I do.
And I have tried unselecting and using the "all" function. Same error results. I have checked each box one at a time and in all possible combinations. Same error results.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23226
    • View Profile
    • Camera Bits, Inc.
Re: Find and replace quit working suddenly
« Reply #3 on: September 21, 2021, 04:33:26 PM »
Richard,

Yes, I do.
And I have tried unselecting and using the "all" function. Same error results. I have checked each box one at a time and in all possible combinations.

Does the Find field truly have only the letters: purple
...and nothing else?  If you select all of the text in that field are only six letters highlighted?

-Kirk

Offline Richard Bledsoe

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: Find and replace quit working suddenly
« Reply #4 on: September 21, 2021, 04:48:59 PM »
OK, purple is not the whole search term, so I tried what I think may be the whole search term (with the file selected) and got the same error. The keywords for this file are shown in a screen shot on my original post for your reference.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23226
    • View Profile
    • Camera Bits, Inc.
Re: Find and replace quit working suddenly
« Reply #5 on: September 21, 2021, 04:55:41 PM »
Richard,

You shouldn't need to enter a whole phrase to replace a word.  Let's turn on some logging.  From the Help menu, choose "Edit Debug Settings..." and find the item titled FIND_REPLACE_LOGGING and set its checkbox.  Then click the Close button.  Then restart Photo Mechanic Plus and reproduce the problem.  Then, from the Help menu choose "Reveal Support Data..." and moments later a Windows Explorer window will come forward with the zipped log file selected.  Use the 'Attachments and other options' link when you're composing your reply to this message and there you'll be able to upload your zipped PM log file.

Thanks,

-Kirk

Offline Richard Bledsoe

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: Find and replace quit working suddenly
« Reply #6 on: September 22, 2021, 10:59:07 AM »
Kirk,

This is the panel that results from clicking Help-Edit Debug Settings, there is no box for FIND_REPLACE_LOGGING that I see. Which box should I check?

Richard

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23226
    • View Profile
    • Camera Bits, Inc.
Re: Find and replace quit working suddenly
« Reply #7 on: September 22, 2021, 11:15:28 AM »
Richard,

In the "New debug setting" field, paste: FIND_REPLACE_LOGGING
and click the "Add" button.  It should now appear in the list.  Set its checkbox and continue with the previous instructions.

Thanks,

-Kirk

Offline Richard Bledsoe

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: Find and replace quit working suddenly
« Reply #8 on: September 22, 2021, 11:42:07 AM »
I did it, PM Log attached.  :)

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23226
    • View Profile
    • Camera Bits, Inc.
Re: Find and replace quit working suddenly
« Reply #9 on: September 22, 2021, 12:55:26 PM »
Richard,

I did it, PM Log attached.  :)

Thanks.  It looks like you do have a carriage return after the 'e' in 'purple'.  If you remove it, then I expect things will start working again.

-Kirk

Offline Richard Bledsoe

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: Find and replace quit working suddenly
« Reply #10 on: September 22, 2021, 03:46:55 PM »
Kirk,

I found the carriage return and removed it and the find and replace function is working again. I don't understand all taht I know about this situation but I will certainly check for carriage returns in the search boxes if I ever encounter another problem with F&R.

I appreciate the help, I would not have figured this on my own. Big Thanks!

Richard

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23226
    • View Profile
    • Camera Bits, Inc.
Re: Find and replace quit working suddenly
« Reply #11 on: September 22, 2021, 05:26:39 PM »
You're welcome, Richard.

-Kirk