Author Topic: Fujifilm "Film mode" exif field  (Read 512 times)

Offline TallTrees

  • Newcomer
  • *
  • Posts: 12
    • View Profile
Fujifilm "Film mode" exif field
« on: October 14, 2021, 09:54:46 AM »
Fujifilm cameras output EXIF data fields called "Film Mode" and "Saturation". Does anyone know how I can add these fields as Keywords? I don't see any variables matching these names.

Offline flyingout

  • Newcomer
  • *
  • Posts: 3
    • View Profile
Re: Fujifilm "Film mode" exif field
« Reply #1 on: October 14, 2021, 11:42:39 AM »
Fujifilm cameras output EXIF data fields called "Film Mode" and "Saturation". Does anyone know how I can add these fields as Keywords? I don't see any variables matching these names.

Which OS? If Mac, I recently spent more time on a workaround for this than I expect I'll really need, but being new to Fuji (and PM) I wanted to experiment with film modes and not having the info easily available was frustrating.

What I did was build a simple Automator app with calls to exiftool to copy the film mode (or saturation) to the Special Instructions field. I'm sure creating keywords would be doable as well.

If Windows, I believe PM can make calls to exiftool more directly but I couldn't accomplish that with macOS, hence the Automator app in between.

I can provide more details if interested.

Cheers

Offline Mick O (Camera Bits)

  • Camera Bits Staff
  • Sr. Member
  • *****
  • Posts: 391
    • View Profile
    • Camera Bits
Re: Fujifilm "Film mode" exif field
« Reply #2 on: October 15, 2021, 04:52:48 PM »
I can provide more details if interested.

I am interested, as I am trying to learn more about Automator apps.  Are you calling the Automator app as an external editor in PM? Or making it a Folder Action that works on your Ingest destination? 

Mick
Mick O
Camera Bits

Offline flyingout

  • Newcomer
  • *
  • Posts: 3
    • View Profile
Re: Fujifilm "Film mode" exif field
« Reply #3 on: October 15, 2021, 07:29:27 PM »
I am interested, as I am trying to learn more about Automator apps.  Are you calling the Automator app as an external editor in PM? Or making it a Folder Action that works on your Ingest destination? 

Hi,

I'm calling the apps as external editors. I thought I was going to be able to call exiftool directly, or use shell scripts, but I found that the only thing that would actually run when called from PM were macOS .app files. I'm not sure if I was doing something wrong or not but Automator does produce .app files, so an acceptable workaround.

I wrote a handful of these little apps to handle camera specific metadata bits I wanted easier access to and to deal with the sidecar incompatibilities between PM and Capture One. (Moving sidecar data to embedded and back. This was the biggest pain point in figuring out how to use PM.)

Here, if the attachment makes it and at the risk of showing something stupid, is a simple example for moving the Fuji film mode to Instructions.

The first step just gets whatever files PM passes to it and filters out any file types that don't make sense. Then exiftool is called twice, once for .RAF files where I update its sidecar, and again for everything else, which updates embedded data.

Offline Mick O (Camera Bits)

  • Camera Bits Staff
  • Sr. Member
  • *****
  • Posts: 391
    • View Profile
    • Camera Bits
Re: Fujifilm "Film mode" exif field
« Reply #4 on: October 18, 2021, 02:43:40 PM »
Thank you very much flyingout! That makes sense. My own scripting skill is rather remedial, so this is a great help to me.  Running it on the XMP and RAF separately is something I wouldn't have immediately thought of.
Mick O
Camera Bits