Author Topic: Grep not working?  (Read 514 times)

Offline Frank

  • Full Member
  • ***
  • Posts: 194
    • View Profile
    • Frank Fitzpatrick Photography
Grep not working?
« on: August 03, 2022, 11:08:17 AM »
Using MacOS Monterey 12.5 and having problem with Grep in Find.

Trying to find Files with Start character of T. Even when I search in a directory which only has files starting with T it finds nothing.

Any ideas what I am doing wrong?

Screen grab below.

Thanks
« Last Edit: August 03, 2022, 11:47:04 AM by Kirk Baker »

Offline Mick O (Camera Bits)

  • Camera Bits Staff
  • Sr. Member
  • *****
  • Posts: 475
    • View Profile
    • Camera Bits
Re: Grep not working?
« Reply #1 on: August 03, 2022, 12:03:51 PM »
Settings look like they should work -- though I will note that Find will only search the Contact Sheet you have open and active in PM.  I'm not sure if that's how you are trying to do this when you say you are searching a directory.   Also, if there is an invisible space before or after ^T  then that will also cause the Find to fail.

If neither of those are the culprit, you may have to contact support for some deeper troubleshooting on your specific system. 

-Mick
Mick O
Camera Bits

Offline Frank

  • Full Member
  • ***
  • Posts: 194
    • View Profile
    • Frank Fitzpatrick Photography
Re: Grep not working?
« Reply #2 on: August 04, 2022, 02:28:00 AM »
Hi Mick,  thanks for the response.

I will check out your suggestions and if it still does not work will uninstall and reinstall.

Frank

Offline Frank

  • Full Member
  • ***
  • Posts: 194
    • View Profile
    • Frank Fitzpatrick Photography
Re: Grep not working?
« Reply #3 on: August 05, 2022, 12:33:09 AM »
I have now solved the problem, which was created by myself, with the help of Maury at camera bits support.

The trick, with the benefit of hindsight, is very obvious, is to ensure in the search box there are no invisible characters including a return. I now simply press the delete key in the search box, insert the required phrase(s), and search. Make sure you do not hit the return key as this puts in an invisible character.

Thanks again to Camera bits support.