Author Topic: PM crashing way too often...  (Read 10782 times)

Offline ocris1

  • Member
  • **
  • Posts: 57
    • View Profile
PM crashing way too often...
« on: June 05, 2007, 02:48:16 PM »
Kirk,

when browsing my files over a server, PM crashes too often and displays dark frames. I'm on a Macpro 10.4.9 and files are accessed via an Xserve over a network.

It's otherwise blazingly fast, but rather unstable.

PM 4.5.1.1




Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21959
    • View Profile
    • Camera Bits, Inc.
Re: PM crashing way too often...
« Reply #1 on: June 05, 2007, 05:12:02 PM »
when browsing my files over a server, PM crashes too often and displays dark frames. I'm on a Macpro 10.4.9 and files are accessed via an Xserve over a network.

It's otherwise blazingly fast, but rather unstable.

PM 4.5.1.1

Have you been filing Crash Reports when the PM Crash Reporter appears?

-Kirk

Offline ocris1

  • Member
  • **
  • Posts: 57
    • View Profile
Re: PM crashing way too often...
« Reply #2 on: June 05, 2007, 07:26:18 PM »
No, I haven't even noticed them. A lot of times I have to force quit the program.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21959
    • View Profile
    • Camera Bits, Inc.
Re: PM crashing way too often...
« Reply #3 on: June 05, 2007, 09:37:56 PM »
No, I haven't even noticed them. A lot of times I have to force quit the program.

Then it is a different kind of problem.  When a crash occurs you get a crash reporter that appears.

I don't have access to an Xserve so it is going to be hard for me to diagnose what is going on.

-Kirk

Offline ocris1

  • Member
  • **
  • Posts: 57
    • View Profile
Re: PM crashing way too often...
« Reply #4 on: June 06, 2007, 05:54:48 AM »
Kirk,

this must be a problem when accessing files over a networked drive. The Xserve doesn't do anything different in that regard.

Christian

Offline tomoc

  • Newcomer
  • *
  • Posts: 48
    • View Profile
    • Cloudview Images
Re: PM crashing way too often...
« Reply #5 on: June 06, 2007, 03:38:05 PM »
No, I haven't even noticed them. A lot of times I have to force quit the program.

Then it is a different kind of problem.  When a crash occurs you get a crash reporter that appears.

I don't have access to an Xserve so it is going to be hard for me to diagnose what is going on.

-Kirk


Kirk-

I'm on a PC and get some crashes, too but do not see any crash report window.

My crashes take place pretty regularly if I move a file with bridge while PM is open. Or if I start PS or Bridge when IM is open.

tom
Tom O'Connell
Cloudview Images

TomOC@earthlink.net
www.CloudViewImages.com

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21959
    • View Profile
    • Camera Bits, Inc.
Re: PM crashing way too often...
« Reply #6 on: June 06, 2007, 04:10:53 PM »
Tom,

No, I haven't even noticed them. A lot of times I have to force quit the program.

Then it is a different kind of problem.  When a crash occurs you get a crash reporter that appears.

I don't have access to an Xserve so it is going to be hard for me to diagnose what is going on.

I'm on a PC and get some crashes, too but do not see any crash report window.

My crashes take place pretty regularly if I move a file with bridge while PM is open. Or if I start PS or Bridge when IM is open.

What version of Photo Mechanic are you running?  The latest and most stable version as of this writing is version 4.5.1.1 and is available from our download page:

www.camerabits.com/download/index.html

-Kirk

Offline ocris1

  • Member
  • **
  • Posts: 57
    • View Profile
Re: PM crashing way too often...
« Reply #7 on: June 07, 2007, 12:47:20 PM »
Just had another crash and got the crash window... I have attached a text file with the log


[attachment deleted by admin]

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21959
    • View Profile
    • Camera Bits, Inc.
Re: PM crashing way too often...
« Reply #8 on: June 07, 2007, 01:32:28 PM »
Just had another crash and got the crash window... I have attached a text file with the log

Thanks.  I was able to figure out what is causing the crashes on your system.  I don't think it has anything to do with accessing an Xserve other than slow access may exacerbate the condition that causes the crash.

Contact me privately for a test version.

-Kirk

Offline tomoc

  • Newcomer
  • *
  • Posts: 48
    • View Profile
    • Cloudview Images
Re: PM crashing way too often...
« Reply #9 on: June 08, 2007, 05:57:38 PM »
Tom,

No, I haven't even noticed them. A lot of times I have to force quit the program.

Then it is a different kind of problem.  When a crash occurs you get a crash reporter that appears.

I don't have access to an Xserve so it is going to be hard for me to diagnose what is going on.

I'm on a PC and get some crashes, too but do not see any crash report window.

My crashes take place pretty regularly if I move a file with bridge while PM is open. Or if I start PS or Bridge when IM is open.

What version of Photo Mechanic are you running?  The latest and most stable version as of this writing is version 4.5.1.1 and is available from our download page:

www.camerabits.com/download/index.html

-Kirk


I'm using 4.5.1.1 but crash may be the wrong term. It closes...doesn't hang or anything, just closes and reopens fine

tom
Tom O'Connell
Cloudview Images

TomOC@earthlink.net
www.CloudViewImages.com

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21959
    • View Profile
    • Camera Bits, Inc.
Re: PM crashing way too often...
« Reply #10 on: June 08, 2007, 06:30:45 PM »
Tom,

No, I haven't even noticed them. A lot of times I have to force quit the program.

Then it is a different kind of problem.  When a crash occurs you get a crash reporter that appears.

I don't have access to an Xserve so it is going to be hard for me to diagnose what is going on.

I'm on a PC and get some crashes, too but do not see any crash report window.

My crashes take place pretty regularly if I move a file with bridge while PM is open. Or if I start PS or Bridge when IM is open.

What version of Photo Mechanic are you running?  The latest and most stable version as of this writing is version 4.5.1.1 and is available from our download page:

www.camerabits.com/download/index.html

-Kirk


I'm using 4.5.1.1 but crash may be the wrong term. It closes...doesn't hang or anything, just closes and reopens fine

So you're saying that PM just closes spontaneously while it is sitting in the background while you're using other applications?

Can you tell me how to reproduce this on my end?

-Kirk

Offline tomoc

  • Newcomer
  • *
  • Posts: 48
    • View Profile
    • Cloudview Images
Re: PM crashing way too often...
« Reply #11 on: June 09, 2007, 12:33:56 AM »
Kirk-

It has been related to an activity using Bridge... the thing I remember causing it more than once was deleting a file in bridge that was in the folder that was open in PM.

I haven't been using them together heavily in the last couple of days but will be again next week. When/if it happens, I will ping you with exact sequences asap.

tom
Tom O'Connell
Cloudview Images

TomOC@earthlink.net
www.CloudViewImages.com

Offline tomoc

  • Newcomer
  • *
  • Posts: 48
    • View Profile
    • Cloudview Images
Re: PM crashing way too often...
« Reply #12 on: June 13, 2007, 09:07:34 PM »
Kirk-

PM closed on me tonight...it's been more than a week since this happened but I got all the info. I had just changed the name of a folder that was either still open or had just previously been open in PM and I got the following:


Photo Mechanic 4.5.0.0 has encountered a problem and needs to close.  We are sorry for the inconvenience.

If you were in the middle of something, the information you were working on might be lost.

for further information about this error, click here

Error signature------
AppName: photo mechanic.exe    AppVer: 4.5.0.0    ModName: photo mechanic.exe
ModVer: 4.5.0.0    Offset: 000ad890

To view Technical information about the error report, click here...


When I went to the location the report was supposed to be, it was not. In the dialog box that had the link, is showed as a very long text report but could not be copied and it was not in the folder it was supposed to be in... do you need that? if so I will try to replicate error and find it again...

BTW, this is not any more than a pesky error for my use, but I can see where some would be in danger of losing important data from it.

cheers,

Tom O'Connell

Tom O'Connell
Cloudview Images

TomOC@earthlink.net
www.CloudViewImages.com

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21959
    • View Profile
    • Camera Bits, Inc.
Re: PM crashing way too often...
« Reply #13 on: June 13, 2007, 10:38:32 PM »
Tom,

PM closed on me tonight...it's been more than a week since this happened but I got all the info. I had just changed the name of a folder that was either still open or had just previously been open in PM and I got the following:


Photo Mechanic 4.5.0.0 has encountered a problem and needs to close.  We are sorry for the inconvenience.

If you were in the middle of something, the information you were working on might be lost.

for further information about this error, click here

Error signature------
AppName: photo mechanic.exe    AppVer: 4.5.0.0    ModName: photo mechanic.exe
ModVer: 4.5.0.0    Offset: 000ad890

To view Technical information about the error report, click here...


When I went to the location the report was supposed to be, it was not. In the dialog box that had the link, is showed as a very long text report but could not be copied and it was not in the folder it was supposed to be in... do you need that? if so I will try to replicate error and find it again...

BTW, this is not any more than a pesky error for my use, but I can see where some would be in danger of losing important data from it.

OK, thanks for the additional info.  You are still running 4.5.0.0 and not the latest 4.5.1.1 version.  My suggestion at this point would be to download 4.5.1.1 from the downloads page:

http://www.camerabits.com/download/index.html

Do an uninstall of the current version.  Don't worry, no settings will be lost.  Then do a restart and then reinstall the 4.5.1.1 version you just downloaded.

Photo Mechanic still won't like it that you renamed a folder you were working with (the contact sheet will become blank) but no data loss should occur.  You can always reopen the newly named folder again.

-Kirk

Offline tomoc

  • Newcomer
  • *
  • Posts: 48
    • View Profile
    • Cloudview Images
Re: PM crashing way too often...
« Reply #14 on: June 13, 2007, 10:52:37 PM »
Thanks, Kirk... I could have sworn I already upgraded.

You're working WAY too late at night !!!

tom

WHOOPSS....  I DID upgrade... but didn't uninstall the 4.5 and have two different shortcuts, so I'm more or less using them both!!!

Anything I should do to keep everything liking me??? or just uninstall 4.5??? or uninstall both and reinstall????
« Last Edit: June 13, 2007, 10:59:45 PM by tomoc »
Tom O'Connell
Cloudview Images

TomOC@earthlink.net
www.CloudViewImages.com