Author Topic: 4.5.2 Beta 4 - Load Selection on Multiple Files doesn't work  (Read 2860 times)

Offline FairfieldPhoto

  • Full Member
  • ***
  • Posts: 218
    • View Profile
    • Fairfield Photography, LLC
I have 22 "tag" files from a recent event.  In earlier betas of 4.5.2, I could multi-select all the tag files when doing a "Load Selection" and PM would read all the tag files and select the corresponding images.

It only seems to taking one of the tag files and selecting the corresponding images, not the whole batch of tag files in Beta 4.

-Mike

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21663
    • View Profile
    • Camera Bits, Inc.
Re: 4.5.2 Beta 4 - Load Selection on Multiple Files doesn't work
« Reply #1 on: July 24, 2007, 12:16:53 PM »
Mike,

I have 22 "tag" files from a recent event.  In earlier betas of 4.5.2, I could multi-select all the tag files when doing a "Load Selection" and PM would read all the tag files and select the corresponding images.

It only seems to taking one of the tag files and selecting the corresponding images, not the whole batch of tag files in Beta 4.

That's odd, I made no changes to that feature recently.

I'll look into it.

-Kirk

Offline FairfieldPhoto

  • Full Member
  • ***
  • Posts: 218
    • View Profile
    • Fairfield Photography, LLC
Re: 4.5.2 Beta 4 - Load Selection on Multiple Files doesn't work
« Reply #2 on: July 24, 2007, 12:19:06 PM »
I will keep trying to localize as to which tag file *is* being processed.

-Mike

Offline FairfieldPhoto

  • Full Member
  • ***
  • Posts: 218
    • View Profile
    • Fairfield Photography, LLC
Re: 4.5.2 Beta 4 - Load Selection on Multiple Files doesn't work
« Reply #3 on: July 24, 2007, 12:25:01 PM »
What I see happening is that I have 22 tag files.

If I select the first 8 as a multi-select and click OPEN, everything works great (I get the 14 images contained in the first 8 files).

Adding the 9th file to the multi-select causes the whole function to no longer work.  The 14 images from the previous "Load Selection" are still highlighted, but files 9 and on do not generate an error message nor a completion dialog box. 

I have examined all the tag files.  They look "normal".

-Mike

Offline FairfieldPhoto

  • Full Member
  • ***
  • Posts: 218
    • View Profile
    • Fairfield Photography, LLC
Re: 4.5.2 Beta 4 - Load Selection on Multiple Files doesn't work
« Reply #4 on: July 24, 2007, 06:25:35 PM »
Some additional testing shows that if I select the first 8 tag files, everything works fine.  If I then take the next 8 tag files, it works too.

I had 22 tag files so if I took them in batches of 8, 8, and then 6, everything worked.

Counter limit somewhere?

Looking back, I don't think I had a situation where I tried to load a selection consisting of more than 8 files.  I group the tag files by event so this past weekend was the first time I went over 8 tag files at the same time for the same event.

G'luck.  Let me know if you find something that will be fixed in the final release of 4.5.2 or a later version so I know whether to keep taking them in batches of 8 or to dump the whole set of tag files in at once.

Thanks.

-Mike